Jump to content

Some tracks for VAIO display support


  • This topic is locked This topic is locked
85 replies to this topic

#1
Krazubu

Krazubu

    InsanelyMac Legend

  • Retired
  • 874 posts
Fassl and I investigated on the display issue of VAIO laptops with nVidia.
Those are unable to show anything on the internal display as soon as acceleration is enabled.

After many searches we found that those laptops have a proprietary interface that interacts between the ACPI tables and the OS.
This controller is called SNC, there are several variations of it.
A linux driver exists, sources can be found here

Maybe it's possible to port this driver to OSX then use some methods that will make the display appear in a standard way that OSX understands.

#2
Biotics

Biotics

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
No news on this one?

#3
anomie

anomie

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
Damn Sony/VAIO!
Tried OS X like 8 months ago, but had this problem. Eventually tired of the terrible default display and uninstalled it. Was hoping there was a fix by now, but seems difficult.

Thanks Krazubu.
Sounds like we're close to a fix, we just need someone who knows enough about coding OS X and Linux, and with an interest in this specific project, to port it. Wish I could teach myself.

Playing with Windows 7 recently, which I like a bit more than Vista, but it still feels years behind OS X. It's basically an optimized Vista with a few visual tweaks. Made me want to give OS X another shot. Wishing I could sell my laptop for a reasonable price (likely lose $1000, though it's less than 2 years old) and get a MacBook these days. I could easily run both with no special hacking.

#4
pilar

pilar

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts
Im using the macvidia drivers to get a proper resolution in the internal lcd. I know macvidia doesnt support qe/ci, but what would happen when it will? I wonder this because no other injecters/kext gave me the possibility of changing the internal lcd's resolution, or sometimes getting any picture at all, whereas with macvidia I didnt even need to change any nvcap values.

#5
Biotics

Biotics

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
What card do you have pilar? I have osx on my VGN-FZ11M and I wish I could get the video working w/o an external monitor. Also internet & audio would be nice too!

#6
pilar

pilar

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts
I have a 7600go 128mb.
As I mentioned in my previous post, there was no way to get picture in the lcd with any of the other injecters(at least not with res bigger than 1024x768)

#7
pilar

pilar

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts
So, any coder owning a vaio who's willing to port the linux drivers?

#8
XFire

XFire

    XP You're Fired.

  • Members
  • PipPipPip
  • 170 posts
  • Gender:Male
Hmm.. i have a Vaio laptop as well, i have Geforce Go 6400 which is supporting my screen size of 1200x800, quite nice and i think i have CI..
However, no QE etc..

I used the Manual Install method for drivers by using this post - http://forum.insanel...howtopic=111072

Then following my Device ID and imputting it into the NVDAResman and NVDANV40Hal kexts, i also extracted the MacVidia 1.081 using Pacifist and used those drivers.

Also using NVinjectGO 2.0 which works well.. so my graphics are okay but not the best, tried to run a music video in VLC and it seems to crash VLC.. not very good.

Unfortunately no Wifi for me :( need to wait for 2200bg support.. (secured networks)

I hope that there is someone who can port it over.. would be great to get better graphics

#9
n0xx187

n0xx187

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
Any one know how I can get my 9600M GT workin on my vaio VGN aw-120J?

Right now I dont have a exturnal monter to test but every time I install a driver I get a blank screen..
For now It would be nice to be able to do any thing with out the screen being choppy.

Thanks for the help

#10
anomie

anomie

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
All I know is I'm never buying a VAIO again. I paid more for this laptop because it was the only 13" I could find at the time that wasn't using Intel integrated POS graphics. But Sony is as bad as Apple, if not worse, with controlling their hardware. nVidia just released a ton of updates for their drivers (though not mine), but the only exception was VAIO users. They instructed VAIO users to get updates from Sony.

I'm tempted to teach myself whatever it is I need to learn so I can try to resolve this problem. Not exactly sure what I'd need to learn or do though.

#11
XFire

XFire

    XP You're Fired.

  • Members
  • PipPipPip
  • 170 posts
  • Gender:Male
Currently trying different methods (ie Natit, Manual Install etc).. pretty much given up.. none work due to this reason, now i just receive an apple spinning logo followed by a black screen.

Would editing the NVCap make any difference whatsoever?

#12
pilar

pilar

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts
Ive tried many nvcap values, everytime getting a black scree, sometimes the external monitor woul work with qe/ci, only with macvidia I managed to get proper display(1280x800) without qe/ci.

#13
XFire

XFire

    XP You're Fired.

  • Members
  • PipPipPip
  • 170 posts
  • Gender:Male
By the way, does this problem affect EVERY Vaio user except some who can configure GMA..

So literally even a very supported nVidia card will not run with QE/CI at all, or any acceleration.. however much/however many different methods tried.. due to this SNC problem?

#14
stewball

stewball

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
I have some C++ experience but none in writing drivers especially not for OS X. I have, however, been reading alot of the Apple docs on authoring drivers and would like to have a go at writing/modifying existing drivers to work with VAIO internal displays. If a more experienced driver (display specialized maybe?) author would be willing to guide me through parts I'd love to give it a shot.

#15
XFire

XFire

    XP You're Fired.

  • Members
  • PipPipPip
  • 170 posts
  • Gender:Male
Well, if you can, then maybe give it a shot :) and if you do.. then gooood luck! we're all behind you if you decide to start

=D

#16
Biotics

Biotics

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
Wonderful! LIFE in this thread! I thought the all the VAIO users had given up. Courage! I'm getting the iPC final install disc and am going to start trying to get it to work on it.

#17
mjw06d

mjw06d

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
  • Gender:Male
  • Location:FL, US
I have a vaio Z520, 9300M GS 128 with the final distro of iPc 10.5.6.. For the others out there with this setup, you can get it to display with the Macbook Pro Latest NVIDIA kexts, but a terrible resolution, so until someone ports over the drivers, I don't think we'll be getting anything better unfortunately.. meanwhile, I'll be looking into doing some coding myself, although I've only been developing in java, c++, basic - but I'll give it try...

#18
Milance

Milance

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
i have Sony Vaio VGN-FE41z with GeForce Go 7600 128mb... if someone try to recode this linux driver for osx... ill can be tester :(

#19
Milance

Milance

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
I have some idea about vaios nvidia 7600 go...

i remember... 2 months ago i tryied to install iatkos. v4 and i selected nvinject i think... and after installing ... then comes to select your country and to make profile name... when u select your name u can choose your picture from system or there is option to TAKE YOUR PICTURE FROM WEBCAM!!! and i selected webcam photo and i saw me in camera...
the WEBCAM LED on my notebook monitor gone ON and it worked without selecting some kext for my internal webcam... i took picture and pushed next... after that he restarts or he just want to go on desktop and my internal displey gone off after that.... i restarted and just after bootloader internal display goes off...

i think webcam can go on just when QE/CI is supported... and i think nvinjector or natit (im not sure what i selected...) worked fine on INTERNAL DISPLAY just in low resolution???

so idea is maybee can someone create kext for nvidia go 128mb just in low resolution mode....

it must be some way to make it work....

pls ppl try to do something for vaio users

#20
epitorus

epitorus

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
Hello,

I started to search how the linux driver "sony_acpi" works under linux (ubuntu 8.10) , I load the sony_acpi.ko successfully. But then there is no "brightness" file in /proc/acpi/sony . I would like to test wether setting up the brightness while the lcd is off will turn on the the lcd. I would like to make this driver to work under linux to test under this os, and make some test before porting it under os x.

Here the attached source of sony_acpi.

Attached Files







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy