Jump to content

Logic Pro 8 with an unsopported card?


  • Please log in to reply
18 replies to this topic

#1
amaning11

amaning11

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
Hi i am building a hackintosh
Q6600 processor
4gb ddr2 800mhz ram
500gb sata hdd
sata dvdrw
HD4850 gpu
P5K-VM Motherboard

I want to be able to use logic pro 8 but i have seen that both the onboard Graphics Media Accelerator 3100 and the HD 4850 are unsupported. This causes the system to run in VESA mode is it called?

What problems am i going to have using OSX and logic?

I have the option of sending the 4850 back and replacing it with a 9800gtx+ but that would be allot of hassle

Thanks!

#2
Ztardust

Ztardust

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 122 posts
  • Gender:Male
  • Location:Oslo
I am running Logic 8 on my laptop, with an unsupported graphics card(x1300 mobility). All Logic requires is that QE and CI(Quartz Extreme and Core Image) are working on your card.
Only thing I had to do was to enable QE and CI by inserting my graphics card ID in the AtiRadeonx1000.kext...

Logic 8 does not work without QE and CI.

I dont know how you enable QE and CI on your card, but I assume there is a solution for that somewhere here on the forum.

- Ztardust

#3
christophski

christophski

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts
I have the same issue, ive just bought a retail copy of logic studio 8, i have a nvidia geforce 8500 GT on iATKOS 5i leopard 10.5.5 and am desperate to ge QE working as i just spent under 300 on the software

#4
OSXLion

OSXLion

    InsanelyMac Protégé

  • Members
  • PipPip
  • 67 posts
why don't you get a supported card for 30EUR and save yourself the pain?

#5
christophski

christophski

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts

why don't you get a supported card for 30EUR and save yourself the pain?


Which graphics cards are the most commonly supported, and cause the least hassle then ? , i may actually go and buy another.

#6
De Sad

De Sad

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 178 posts
  • Gender:Male
  • Location:France

why don't you get a supported card for 30EUR and save yourself the pain?



Absolutely there is the solution ,personally i run logic 8 with a poor video card cost me 50 NV 8400 GS 128 RAM and all is perfect,im happy with it ;)

#7
christophski

christophski

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts
Problem solved, i reached in to funds and made the jump..........i bought me a real macbook :wacko: dont regret it one bit

#8
tackle

tackle

    InsanelyMac Protégé

  • Members
  • PipPip
  • 54 posts
You must've dug deep into the funds then!

#9
the_star

the_star

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Hi,

I've got the same problem. I have to get the QE/CI running first on my 9800GT before I install it. Now the problem is logic says I've got 0 NVRAM but in the system profiler It says I've got 512 NVRAM. Do anyone knows how to solve this problem? Thanks

#10
steve9x

steve9x

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts

Hi,

I've got the same problem. I have to get the QE/CI running first on my 9800GT before I install it. Now the problem is logic says I've got 0 NVRAM but in the system profiler It says I've got 512 NVRAM. Do anyone knows how to solve this problem? Thanks


Yes.. I too have the same exact problem... The logic installer says I have 0 of the recommended 64M VRAM

I was able to forcefully install Logic Studio 8 by using pacifist. However there is a problem... Logic itself doesn't do a check whether you have at least 64M VRAM, but it does not run properly...

I wonder if it's because of the lack of a video card driver(kext) for my Intel GMA 4500M, or like Ztardust said, is it because of QE and CI are not enabled?

Logic loads up fine and I can create a new project, but added a midi clip and drawing some notes and trying to play them results in no sound output... Even though I have my sound working with VoodoHDA.

I suppose I have to change the preferences, and select an audio output... However, when I try to goto the preferences either through the button, the menu, or the keyboard shortcut the program freezes and the window never pops up... I have to forcefully quit logic to fix it. One time I have actually gotten the preferences window to show up, but I couldn't click anything as like I said logic freezes.

Is this because of a lack of a driver? or lack of QE?

take a look at this image:
Posted Image


As you can see Core Image (CI) says: Software... Does that mean its enabled (with software acceleration only, no hardware acceleration) or is that not what it supposed to say.

QuartzGL is enabled... but Quartz Extreme says its not supported...

Is there some hack I can do to get logic working good without needing a driver?

Like maybe take a GMA 950 driver and patch in my device id ? How would I do that?

Or somehow change the preferences manually to configure the audio device?

Maybe since I didn't use the logic installer because I couldn't get past that part, and used pacifist instead. It did not install properly and thats why it doesn't work?

What can I do? I really need logic to work...

I'm a music producer and this has put a wall up in my process...

My logic looks like this right now...
Posted Image

I hit play before taking the screenshot, yet I wasn't hearing anything from logic. Also on the left side, things are crossed out, and the bars don't go up!


Thanks for your help.

#11
Synaesthesia

Synaesthesia

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,168 posts
  • Gender:Male
  • Location:South Africa
Sorry - I very much doubt you will be able to get Logic running as it wants QE/CI - which you don't have.

#12
chaka123

chaka123

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts
to run logic without qe you can install logic with pacifist or copy the logic installer packages to your hdd
-> right click -> "Paketinhalt anzeigen" (in german i thin in english it is Show content)
-> then go into the folders -> go to the file "Requirements checker" -> right click show content
-> there must be a minsys.plist or something like that an in this file you replace all the "block" with "warn".
-> save the file an start the the setup
-> the warning pops up but the installation can continued now

hope that helps

#13
CCLNet

CCLNet

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
EDIT:

Never Mind I Got it with the last post before me!!! :whistle: thank u

#14
starobrno1

starobrno1

    InsanelyMac Legend

  • Banned
  • PipPipPipPipPipPipPip
  • 930 posts
  • Gender:Male
I use two noname silent really cheap 7300gs 512 mb pcie videocards and they work good, gives me four displays. I bought the cards on ebay from small hk store. They have a new 3d version of it now, if you look under operating systems it say it works with mac osx. If you use a Nvinject.kext I uploaded to a thread of mine in the hardware and drivers graphics part here you will get QE and everything you need to get Logic upp running.

http://cgi.ebay.co.u...-...3A11|294:30

#15
ktz

ktz

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
  • Gender:Male
I got 7600GT with QE CI enabled but Logic's GUI very slow. What's wrong?
Config in sign. Thx.

#16
CreepingAlex

CreepingAlex

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

why don't you get a supported card for 30EUR and save yourself the pain?





Can you tell me of a graphics card that supports QE and CI? A cheap one..

#17
MiamiSteve

MiamiSteve

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
I had the same issue with Logic Pro 8 and no graphics support! Forcefully installing with pacifist gets it installed, but it screws up when the application runs!

I solved the problem by getting Logic Pro 9! :) You still have to forcefully install if you don't have graphics hardware support (CI/QE) and just like version 8 the application itself doesn't verify your graphics support like the installer does...


So in short, Logic Pro 9 (NINE) works with or without CI/QE, while Logic Pro 8 only works if you have CI/QE otherwise it screws up when ran!

:) Hope that helps!

#18
guitaristz

guitaristz

    InsanelyMac Protégé

  • Members
  • PipPip
  • 56 posts
  • Gender:Male
  • Location:Vancouver
Chaka123's advise worked. I did have to try it a few times so it the .plist file would save. I opened the .cdr (which I renamed .dmg) with Pacifist. Now Logic is installing...yeah!

Onboard Intel915 video.

#19
EUSKALRAVER

EUSKALRAVER

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
Hi, Thanks Chaka, I Have install logic with your fix, i am on 10.8.2 with logic 9.1.7 Runs great,but i have a problem with the no native plugins, i have install waves fx audio units and the plugins opens and sounds but the plugin interface dont open he opens a plug window but i can see the interface, if i change the plugin view at controls. i can see all plugins controls and plugin works..
In ableton live i have the same issue,only i can view the interface of the native plugins,..
Any fix to thath?? Vram0 :C

Good news! :D I have install a Psp Audioware mixpack audio units, I open in logic and,,,Wow I can look the interface.. At moment the problem is with the waves package.. i will try it to unistall it and test other third part audio units..Logic runs very faast! Nicee





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy