Jump to content

[HOW TO] Getting IDT Audio Working


  • Please log in to reply
288 replies to this topic

#181
hambola

hambola

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts

i wonder if its related to hd codec enabled in bios(try disable hd codec), it says audio separately: enabled
a new codec dump would probably point differences due to hdmi and hdaudiolink header inside mobo?

i turned it off and it doesnt show much on lspci devices. so it likely is needed on.

I would love to work on this directly with some pros (with teamviewer they can take control of it).
im sure we can do this. i have linux codec dump of DG45iD from sssharer's link and i see it has many pinout config's .. id love to know how to use the dump to figure out this mess.

Codec: IDT 92HD73E1X5Address: 2Vendor Id: 0x111d7676 =decimal 287143542Subsystem Id: 0x80865002Revision Id: 0x100202


I will take a serious stab at this in a couple of days. I am pretty sure I got the pinconfig part right, but there were a couple of extra keys in the windows registry. One of them was a key stating the number of entries and I forget what the other one was. I will take a codec dump from a linux live cd and see where it goes from there.

#182
LatinMcG

LatinMcG

    Insanely digesting DSDT

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,509 posts
  • Gender:Male
  • Location:Tampa, Florida

I will take a serious stab at this in a couple of days. I am pretty sure I got the pinconfig part right, but there were a couple of extra keys in the windows registry. One of them was a key stating the number of entries and I forget what the other one was. I will take a codec dump from a linux live cd and see where it goes from there.

compare your dump to sssharer's dump to see if its really same :unsure: :hysterical:
i had started yesterday to edit applehda as in thread and found they mixed their ids in the binary. and a typo
AREOS dev id (decimal) = 287143600
age_sabres18 dev id (decimal) = 287143602
typo is ex. CodecID = 2871433602 in step 4.
ours is ex. CodecID = 287143542

do they have hdmi that could be extra config.to a separate chan that we see in dump (elimitate ? i wish ther would be an IDT patcher lol) the hdaenabler might have issues.?

anyways i got stuck at step 4 not sure what we got Edit IOPCIPrimaryMatch with your HD audio controller.
Mine is Intel Audio Controller 0x293e8086
ex. IOPCIPrimaryMatch = 0x293e8086
ahh i see this is the dev_293e . will be trying pinconfig and patch guide for next day. been busy with kid all day.

i wonder if ridgeline could see pinout on this.

the ironic part is i had usb sound card few weeks ago and gave it to a friend. doh.. im selling this board i think.
going for one on the plugins list of universal installer :wacko:

#183
hambola

hambola

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts

compare your dump to sssharer's dump to see if its really same :D :)
i had started yesterday to edit applehda as in thread and found they mixed their ids in the binary. and a typo
AREOS dev id (decimal) = 287143600
age_sabres18 dev id (decimal) = 287143602
typo is ex. CodecID = 2871433602 in step 4.
ours is ex. CodecID = 287143542

do they have hdmi that could be extra config.to a separate chan that we see in dump (elimitate ? i wish ther would be an IDT patcher lol) the hdaenabler might have issues.?

anyways i got stuck at step 4 not sure what we got Edit IOPCIPrimaryMatch with your HD audio controller.
Mine is Intel Audio Controller 0x293e8086
ex. IOPCIPrimaryMatch = 0x293e8086
ahh i see this is the dev_293e . will be trying pinconfig and patch guide for next day. been busy with kid all day.

i wonder if ridgeline could see pinout on this.

the ironic part is i had usb sound card few weeks ago and gave it to a friend. doh.. im selling this board i think.
going for one on the plugins list of universal installer :D


Here's the codec dump for my audio from a Linux live CD, maybe it will help you out in the meantime. I will play around with this audio problem in the next day or two and let you know.

Attached Files



#184
hambola

hambola

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
Still not able to get audio to work, but I think I found the value that goes into IOPCIPrimaryMatch. I believe it is 0x3a3e8086. I got this by looking under the "High Definition Audio Controller" in Device Manager in Windows 7. Under the Details tab under property "Hardware IDs". I got it by concatenating the DEV ID with the VEN ID. It sounds about right, pun intended.

As for giving your USB sound away, looks like no good deed goes unpunished.

I tried adding the pinconfig in the configdata section of the plist, but still no audio. Any luck on your end?

#185
juanbosco

juanbosco

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
Still not able to get audio to work in my PCChips P17G Motherboard with AUDIO CODEC: Intel High Definition Audio Specification Rev. 1.0 Compliant....

I also installed the latest MacOSx86 Leopard v.10.5.5. iDeneb v.1.3.iso, but I dont know witch audio driver I have to select during the installation of the OSX?...Any Help?

Anyone here have success with Intel HDA Audio?

#186
Gambit642

Gambit642

    InsanelyMac Protégé

  • Members
  • PipPip
  • 99 posts
Has anyone created a working driver for the Audio in the Dell Studio 13 (m1340) with the ATD 92HD73C1?

#187
toshiroo

toshiroo

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hi



thanks for this guide, IDT sucks on laptop, and i was scared it was impossible to find a solution

But I have a little problem ( i have not tried the guide yet coz i am lost about device ID)

The Step 1: Codec device id

To check my ID, i went to system/device manager ...

I checked the properties : IDT high definition audio codec

In device ID, i don't have like : 0x111D76B0

I have :

HDAUDIO\FUNC_01&VEN_8384&DEV_7627&SUBSYS_30D4103C&REV_1002
HDAUDIO\FUNC_01&VEN_8384&DEV_7627&SUBSYS_30D4103C

I installed Everest, and check , i am more lost :

I have two things :

[ Intel 82801HBM ICH8M - High Definition Audio Controller ]
Device ID :8086-284B
subsystem ID :103C-30D4
Hardware ID : PCI\VEN_8086&DEV_284B&SUBSYS_30D4103C&REV_03


[ SigmaTel STAC9271D ]
Device ID : 8384-7627
Subsystem ID : 30D4-103C
Hardware ID : HDAUDIO\FUNC_01&VEN_8384&DEV_7627&SUBSYS_30D4103C&REV_1002

Which Id is for the step 1 and the Intel Audio Controller in step 4 ??

:(

thanks

#188
LatinMcG

LatinMcG

    Insanely digesting DSDT

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,509 posts
  • Gender:Male
  • Location:Tampa, Florida
sorry hambola.. i ended up returning desktop to friend and looking into a better model for future for my new rigg!

#189
chris7519

chris7519

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
First off, big thanks to age_sabres18 for this excellent guide!!! However, I'm pretty much at my wits end with this kernel panic caused by the AppleHDAController... I downloaded a working HDA kext for my IDT 0x111D76B2 and get it, and I edited the provided kext in the first post and still receive the same panic. Skimming through the posts, it looks like the HDAs I'm working on may be older than the 10.5.6 kext that I would need??? Someone please help!!!

Attached Files



#190
underball

underball

    InsanelyMac Protégé

  • Members
  • PipPip
  • 76 posts
The VooDooHDA codec works for IDT audion onthe Intel DG boards.

#191
chris7519

chris7519

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts

The VooDooHDA codec works for IDT audion onthe Intel DG boards.

Actually I gave that a try... it worked but the audio was extremely quite. I'll give it another try and see if it fixes the shutdown issue, and possibly if there's some way to set the defaults to increase the volume...

#192
hambola

hambola

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
True the volume is a bit low, but at least audio works.

#193
Cacho_from_GDL

Cacho_from_GDL

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

True the volume is a bit low, but at least audio works.


I have an Mobo DP45SG, already installed voodoHDA, it look like it worked, but i have audio only if connect the jack to the half, not completely pluged....

its very strange... any idea?

When installed voodoHDA you removed appleHDA?

True the volume is a bit low, but at least audio works.


I have an Mobo DP45SG, already installed voodoHDA, it look like it worked, but i have audio only if connect the jack to the half, not completely pluged....

its very strange... any idea?

When installed voodoHDA you removed appleHDA?

#194
Turlan

Turlan

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Sorry if this seems like a stupid question, but how do i find my HD audio controller number (the one that you put in IOPCIPrimaryMatch) ?

#195
disciple

disciple

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
i am a noob, this guide sounds very difficult to me :)

#196
Supercar1000

Supercar1000

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts

i am a noob, this guide sounds very difficult to me :)



Because it is! I cannot understaind all that {censored}

#197
rjohnst2

rjohnst2

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Anyone have this working on a HP Mini 1000? VoodooHDA is nice, but it would be even better to have the IDT Audio working fully including internal mic.

#198
tk31

tk31

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
wtf... i didnt do all this.. i simply downloaded and installed 2 kexts with OSx86 Tools and rebooted, and IDT is working on my HP DV5-1134TX.

None of this editing was needed. I think it may be pre-built versions using this tutorial, but if anyone wants the drivers and cant do this tutorial, PM me... ill send em over to you.

EVERYTHING works: External mic jack, internal microphone, dual headphone jacks. Though theres a slight glitch with the headphones, but its nothing major.

EDIT:
Posted Image

#199
Infocore

Infocore

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
Is it right that headphones may work on IDT 92HD73C1 together with speaker? Please confirm this fact. It's VERY important for Dell Studio 1535 users.

#200
Dennis Zatsepin

Dennis Zatsepin

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
how do i find the device id





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy