Jump to content

HELP with Asus N10 OS X install.....


  • Please log in to reply
126 replies to this topic

#1
ShadowBandit

ShadowBandit

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
Good afternoon everyone so i picked up one of these machines in the hopes to install OSX. I first did a lot of reading and what not on installing OSX, i was successful on 2 machines(Inspiron 1505, and Sony CR series notebook) I only really did the installs and nothing more bc it was mostly a learning experience. I searched around before I bought this notebook for Chipset, Sound, Video, and Network and all seemed to match some kind of system or another. For the most part this system is similar to most of the Netbooks out there that have OSX installed and running. ie. EeePC 1000h or 901, MSI Wind, and Lenovo S10. This lead me to the conclusion that the hardware would be supported but i apperantly missed something in my readings(maybe i was up too late lol). I am basically tried 4 diff install methods:

iDeneb v1.3 10.5.5: Hangs at the apple screen just like the rest with pretty much the same verbose screen as below....

JAS 10.4.8 universal: Reboots as soon as darwin starts to load,

Kalyway 10.5.2: Gives me a kernel panic on 4counts i believe they were all related to ACPI issues,

Boot 132 method with Retail 10.5.4: Used Generic ISO found on here and then swapped out to Retail Leo. makes it to the grey apple screen but never starts loading anything. If i use -v it will show loading all the kext, but it then hangs once it gets to dmos: starting....

I would greatly appreciate any help to get this machine up and running i know i might be missing some kind of kext to get it to work propperly but being that i am new at this i just need a little guidance. I feel like i have confused myself from reading so many post and different methods of installing OSX lol..

thanks again....


Specs:

CPU: N270 Atom 1.6ghz with HT
Chipset: 945GSE Express North and ICH7 south
Sound: Azalia Realtek HD audio
GPU: GMA950, and Nvidia 9300(tried install with GMA and then with 9300)
LAN/WLAN: Realtek RTL8168/Atheros AR928x

If you guys need anymore information please ask i will open up the bottom and check out the ID's on the WIFI, i did last night but did not write em down but i know it had diff numbers from what is posted int he device manager.

Update: 2008/10/24
Standard timesplicing quatum is 10000 us
Vm_page_bootstrap: 510042 free pages and 14246 wired pages
Mig_table_max_displ = 79
	HTT: 1 core per package; 2 logical cpus per package
ACPI CA 20051117 [debug level=0 layer=0]
appleACPICPU: ProcessorApicId=1 LocalApicid=0 enabled
appleACPICPU: ProcessorApicId=2 LocalApicId=1 enabled
Loading security extension com.apple.nke.applicationfirewall
Loading security extension com.apple.security.seatbelt
Calling mpo_policy_init for mb
Seatbelt MACF policy initialized
Security policy loaded: seatbelt policy (mb)
Loading security extension com.apple.security.TMSafetyNet
Calling mpo_policy_init for TMSafetyNet
Security plicy loaded: safety net for time machine (TMSafetyNet)
Copyright  1982, 1986, 1991, 1993
	The regents of the university of California. All rights reserved.

MAC Framework successfully initialized 
Using 10485 buffer headers and 4096 cluster IO buffer headers
IOAPIC: version 0x20 Vectors 0:23
ACPI: System State [s0 s3 s4 s5] (s3)
Extension com.apple.driver.applePCIconfigurator has immediate depndencies on both com.apple.kernel and com.apple.kpi components; use only style.
Mbinit: done
Security auditing service present
bSM auditing present
From path: uuid,
Waiting for boot volume with UUID 804603d3-83e9-36b8-ab8e-11501d1805d6
Waiting on <dict ID=0>IOProviderClass</Key><string ID=1>IOResources</sting><key>IOresource
Match</key><string ID=2>boot-uuid-media</string></dict>

Thanks again.

#2
ShadowBandit

ShadowBandit

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
no one yet???

#3
Nick14

Nick14

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,125 posts
  • Gender:Male
price ???

#4
ShadowBandit

ShadowBandit

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
i paid 675, but it can be had for about 500 after rebates from the Live.com program which i did not know about until after i bought mine :D oh well... i mean if i were to buy the 1000H I would be stuck upgrading the ram and faster HD. so i would spend more anyways so the way i look at it is i paid another 100bux for the GPU.

I am thinking it will work with osx since it has the same chipset as the Eee and msi but i dont think the wifi is compatible. Hopefully it is removable and i can swap it out for one of the dell oem ones.

We shal see.....

#5
ShadowBandit

ShadowBandit

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
Alright ladies and gents, looks like fedex screwed me :) was set to arrive today but it didnt. So i am going to call in a few minutes and just pick up the package tomorrow morning, I am going to try the Boot 132 method to install osx hopefully i can find the right kext to install and 10.5.5 updates will hopefully take care of my Nvidia 9300m GS. I will keep everyone updated and will change around the first post to reflect since i already bought the net/notebook.

Thanks.

#6
ShadowBandit

ShadowBandit

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
Got my N10J today, but so far no luck with installing :unsure:.....

Boot 132 will get stuck on the grey apple screen, i also tried Kalway 10.5.2 and i get kernel panics for both....

I would appreciate some help if anyone could post :D I tried the 132 from the MSI, Generic, and a couple of others.... I just am not sure what what the kernel panic is all about. I do believe it might be possible to install osx its just a matter of figuring what the problem is and i am no expert unfortunately.

I would appreciate any help you guys can offer,

Thanks.

#7
ShadowBandit

ShadowBandit

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
Updated first post to reflect, my current situation :)

#8
ShadowBandit

ShadowBandit

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
no help???

#9
dies

dies

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 119 posts
I assume you already tried this

http://uneasysilence.../2008/10/13519/

and this

http://wiki.osx86pro...Inspiron/mini_9


Should work, looks like the same basic internals aside from your graphics card which should be a plus in any case. The again, Asus does tend to put out some buggy BIOS... at least when it comes to working with stuff other than Windows.

#10
ShadowBandit

ShadowBandit

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
dies thank you for the post, I am no longer getting kernel panic after a bios update i got from kabyl but the installs are now hanging at the grey apple screen without a rotating wheel. here is the code:

Standard timesplicing quatum is 10000 us
Vm_page_bootstrap: 510042 free pages and 14246 wired pages
Mig_table_max_displ = 79
	HTT: 1 core per package; 2 logical cpus per package
ACPI CA 20051117 [debug level=0 layer=0]
appleACPICPU: ProcessorApicId=1 LocalApicid=0 enabled
appleACPICPU: ProcessorApicId=2 LocalApicId=1 enabled
Loading security extension com.apple.nke.applicationfirewall
Loading security extension com.apple.security.seatbelt
Calling mpo_policy_init for mb
Seatbelt MACF policy initialized
Security policy loaded: seatbelt policy (mb)
Loading security extension com.apple.security.TMSafetyNet
Calling mpo_policy_init for TMSafetyNet
Security plicy loaded: safety net for time machine (TMSafetyNet)
Copyright  1982, 1986, 1991, 1993
	The regents of the university of California. All rights reserved.

MAC Framework successfully initialized 
Using 10485 buffer headers and 4096 cluster IO buffer headers
IOAPIC: version 0x20 Vectors 0:23
ACPI: System State [s0 s3 s4 s5] (s3)
Extension com.apple.driver.applePCIconfigurator has immediate depndencies on both com.apple.kernel and com.apple.kpi components; use only style.
Mbinit: done
Security auditing service present
bSM auditing present
From path: uuid,
Waiting for boot volume with UUID 804603d3-83e9-36b8-ab8e-11501d1805d6
Waiting on <dict ID=0>IOProviderClass</Key><string ID=1>IOResources</sting><key>IOresource
Match</key><string ID=2>boot-uuid-media</string></dict>

every method, and dvd that i try gives me the same result..... the hdd does nothing, and the dvd player quiets down so i am assuming this is a hang? although i see no panics??

I am going to aquire the msiwindosx dvd and see if i have any luck with that, i would like to do the boot 132 or efi method but i feel like you really need a previous install of osx to build yourself a nice .img file to house all your kext, kernel, and dsmos....... if someone could make one for me i would appreciate it greatly!!! I do believe i downloaded the msi iso before for boot 132 and had no luck with it.

Thanks

#11
themyers

themyers

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
I too have an n10j and asus got us this time. with current bios there is no way to shut off the on board hardware to install mac os. what did you use to flash to the modded bios? You have to be able to turn off all on board hardware (like you could on the 1000h. No option for that in the N10 bios currently. I wonder what the sound card is on the n10. I already bought an apple wifi card in hopes we will be able to install mac os. Keep us posted and good luck.

#12
ShadowBandit

ShadowBandit

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
yea man, i can shut off the lan, wifi, and sound, usb, and the touchpad but even when i shut off all but the usb(to run the dvd obviously) it gets stuck :D...... i flashed the bios after i requested it to be modified by osrom. I have looked up the componenets, and for the most part they are all the same as the eee1000. I wonder what could happen if the n10 was modded with Eee1000 bios mod to allow the install........ and if it would be possible to return to the regulard bios afterwards? I dont know i have even tried native installs, modded os-x dvd's and i even got vmware all with no luck!!!

tried dvds:
Kalyway 10.5.2 intel/amd
iDeneb 1.3 10.5.5 intel/amd
Jas 10.4.8
wondosx DVD
and Retail DVD 10.5.4 with boot 132 from many diff systems, msiwind, lenovo, generic, and couple of others.... to no luck.

So i guess unti lsomeone figures out a way to modify a DVD to work with our systems specs i guess we are SOL :( unless it is possible to mod the bios with eee 1000h bios....

Until then, to speed up your vista just restore with vista dvd that came with your system and once it is finished dont put in the app and driver dvd when it tells you. Instead just reboot the system and when it comes to the desktop you can put in the dvd to install only the needed items! trust me it made a huge diff in boot times and starting up apps!

or do what i did after the re-install if you are not happy with the vista hogging your ram just install XP ;)

Good luck and i hope someone chimes in with an idea to install osx :)

#13
ShadowBandit

ShadowBandit

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
still looking for a solution ;( help....

#14
themyers

themyers

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
What did you use to update your bios? I too have the modded bios and can't get winflash to update it. What did you use?

#15
ShadowBandit

ShadowBandit

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
I actually did it from the bios screen..... i could nto do it through windows bc it was the same date and version, so it kept giving me an error but it will work if you do it from the actual bios screen :)

have you had any progress?? if you are successful please update this thread. I just tried another cd and i still get the exact same error.

Jas 10.48
Kalyway 10.5.2
Kalyway 10.5.1(intell only, still no dice :D )
Ideneb 10.5.5
WindOSX cd
Retail DVD with boot 132, generic, msi wind, lenovo, mini9, and others....

Every install gives me the same exact error :) If i dont use the -v it will boot to the grey screen but without the rotating wheel, and if i use -v i see the waiting for uuid blah blah.... see the code above.

Hope someone figures this mess out :)

#16
ShadowBandit

ShadowBandit

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
bump!!!

oh and i am using an external DVD DL Drive.... it is IDE not sure if this might be a cause of the problem as well?

#17
CMOSQ

CMOSQ

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts

bump!!!

oh and i am using an external DVD DL Drive.... it is IDE not sure if this might be a cause of the problem as well?


Did you try in the BIOS under the SATA configuration to change it from Enhanced to Compatible? I had to do this to install XP on it.

#18
hughson

hughson

    InsanelyMac Protégé

  • Members
  • PipPip
  • 61 posts
Any luck yet?

#19
ShadowBandit

ShadowBandit

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts
No luck yet :) and i believe i did try to install with SATA set to Enhanced but no dice..... none one has had this error yet ???

#20
hughson

hughson

    InsanelyMac Protégé

  • Members
  • PipPip
  • 61 posts
This is just a shot in the dark but maybe if you already have a vanilla hackingtosh lying around try installing to an usb drive using the boot-123(usb key) method on that hack(leaving it on touched) than see if the usb boot-123 key boots the externel usb Vanilla drive on your n10. *remember to add cpus=1 flag to the boot.plist.

I did this method on the aspire one(though it is not necessary on the aspire one) I just like having an osx86 installed on an external USB that I can switch between my desktop hack,my aspire one and my brother real mac!

downside of this method is the slow usb2 drive speeds.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy