Jump to content

Audio Intel 82801H


  • Please log in to reply
18 replies to this topic

#1
yonib

yonib

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
lspci -nn
00:00.0 Host bridge [0600]: Intel Corporation Mobile Memory Controller Hub [8086:2a00] (rev 03)00:01.0 PCI bridge [0604]: Intel Corporation Mobile PCI Express Root Port [8086:2a01] (rev 03)00:03.0 Communication controller [0780]: Intel Corporation Mobile MEI Controller [8086:2a04] (rev 03)00:19.0 Ethernet controller [0200]: Intel Corporation 82566MM Gigabit Network Connection [8086:1049] (rev 03)00:1a.0 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Contoller #4 [8086:2834] (rev 03)00:1a.1 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 [8086:2835] (rev 03)00:1a.7 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 [8086:283a] (rev 03)<strong class='bbc'>00:1b.0 Audio device [0403]: Intel Corporation 82801H (ICH8 Family) HD Audio Controller [8086:284b] (rev 03)</strong>00:1c.0 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 [8086:283f] (rev 03)00:1c.1 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 [8086:2841] (rev 03)00:1c.2 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 [8086:2843] (rev 03)00:1d.0 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 [8086:2830] (rev 03)00:1d.1 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 [8086:2831] (rev 03)00:1d.2 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 [8086:2832] (rev 03)00:1d.7 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 [8086:2836] (rev 03)00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev f3)00:1f.0 ISA bridge [0601]: Intel Corporation Mobile LPC Interface Controller [8086:2811] (rev 03)00:1f.1 IDE interface [0101]: Intel Corporation Mobile IDE Controller [8086:2850] (rev 03)00:1f.2 SATA controller [0106]: Intel Corporation Mobile SATA AHCI Controller [8086:2829] (rev 03)01:00.0 VGA compatible controller [0300]: nVidia Corporation Unknown device [10de:042a] (rev a1)02:00.0 Network controller [0280]: Intel Corporation Unknown device [8086:4229] (rev 61)05:00.0 Memory controller [0580]: Intel Corporation Unknown device [8086:444e] (rev 01)06:0b.0 CardBus bridge [0607]: Texas Instruments PCIxx12 Cardbus Controller [104c:8039]06:0b.1 FireWire (IEEE 1394) [0c00]: Texas Instruments PCIxx12 OHCI Compliant IEEE 1394 Host Controller [104c:803a]06:0b.2 Mass storage controller [0180]: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD) [104c:803b]06:0b.3 SD Host controller [0805]: Texas Instruments PCIxx12 SDA Standard Compliant SD Host Controller [104c:803c]

gfxutil -f pci8086,284b
DevicePath = PciRoot(0x0)/Pci(0x1b,0x0)

I created an input.plist:
<?xml version="1.0" encoding="UTF-8"?><!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd"><plist version="1.0"><dict><key>PciRoot(0x0)/Pci(0x1b,0x0)</key>       <dict>             <key>PinConfigurations</key>             <string></string>             <key>built-in</key>             <string>0x00</string>             <key>layout-id</key>             <string>0x0000000c</string>             <key>revision-id</key>             <string>0x00000003</string>             <key>subsystem-id</key>             <string>0x000001db</string>             <key>subsystem-vendor-id</key>             <string>0x00001028</string>             <key>vendor-id</key>             <string>0x00008086</string>       </dict></dict></plist>

and gfxutiled it to get a hex:
2f0100000100000001000000230100000700000002010c00d041030a000000000101060001b7fff04001c0000007200650076006900730069006f006e002d0069006400000008000000030000028000000500069006e0043006f006e00660069006700750072006100740069006f006e0073000000400000018000000760065006e0064006f0072002d0069006400000008000000868000002c00000730075006200730079007300740065006d002d00760065006e0064006f0072002d006900640000008000000281000001e000000730075006200730079007300740065006d002d006900640000000800000db010000180000006c00610079006f00750074002d00690064000000080000000c00000016000006200750069006c0074002d0069006e0000000500000000

so now my com.apple.Boot.plist is:
<?xml version="1.0" encoding="UTF-8"?><!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd"><plist version="1.0"><dict>        <key>Kernel</key>        <string>mach_kernel</string>        <key>Kernel Flags</key>        <string>-v</string>        <string>cpus=1</string>        <string>rd=disk0s2</string>        <key>Boot Graphics</key>        <string>Yes</string>        <key>Quiet Boot</key>        <string>No</string>        <key>Timeout</key>        <string>5</string>        <key>Graphics Mode</key>        <string>1680x1050x32</string>        <key>device-properties</key>        <string>2f0100000100000001000000230100000700000002010c00d041030a0000000001010600001b7ff04001c0000007200650076006900730069006f006e002d0069006400000008000000030000002800000500069006e0043006f006e00660069006700750072006100740069006f006e0073000000040000018000000760065006e0064006f0072002d0069006400000008000000868000002c00000073005006200730079007300740065006d002d00760065006e0064006f0072002d006900640000000800000281000001e000000730075006200730079007300740065006d002d0069006400000008000000db10000180000006c00610079006f00750074002d00690064000000080000000c00000016000000620750069006c0074002d0069006e0000000500000000</string></dict></plist>

and still, no sound...

Help!!

#2
yonib

yonib

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Solved!
used a package named "To Fix OSX86 Sound.pkg"
I will try to upload it, as I can't remember where i got it from...

#3
Howie N

Howie N

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Gender:Male
  • Location:Hong Kong
my laptop is using Intel 82801IB ICH9 - High Definition Audio Controller.

00:1b.0 Audio device [0403]: Intel Corporation 82801I (ICH9 Family) HD Audio Controller [8086:293e] (rev 03)

subsystem ID: 17AA-3A0D

can u please tell me how to do this???
i have no idea where to create an input.plist and which driver sultable for my laptop.
can u write the details of how to make 82801Audio work???
thanks a lot!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

btw, i found the To_Fix_OSX86_Sound.pkg there:
http://forum.insanel...t...st&id=13834

#4
PainWarlock

PainWarlock

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 140 posts
  • Gender:Male
i would also like help on my 82801g

#5
yonib

yonib

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

my laptop is using Intel 82801IB ICH9 - High Definition Audio Controller.

00:1b.0 Audio device [0403]: Intel Corporation 82801I (ICH9 Family) HD Audio Controller [8086:293e] (rev 03)

subsystem ID: 17AA-3A0D

can u please tell me how to do this???
i have no idea where to create an input.plist and which driver sultable for my laptop.
can u write the details of how to make 82801Audio work???
thanks a lot!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

btw, i found the To_Fix_OSX86_Sound.pkg there:
http://forum.insanel...t...st&id=13834


My best suggestion is that you download and use OSX86Tools and also PlistEdit Pro. These tools enable you to edit Plists and to modify com.apple.Boot.plist.

good luck

yoni

i would also like help on my 82801g


See my reply to the prev post.

download the fix sound pkg (see the prev post - the guy found and linked it) and also the OSX86Tools and PlistEdit Pro packages.

good luck
yoni

#6
Howie N

Howie N

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Gender:Male
  • Location:Hong Kong
thanks yonib. im gonna try to use them.
is your audio card 100% work now???
are the headphone and microphone also work fine after edited it?

and im wondering which driver i should use. AppleHDA.kext??

#7
PainWarlock

PainWarlock

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 140 posts
  • Gender:Male

My best suggestion is that you download and use OSX86Tools and also PlistEdit Pro. These tools enable you to edit Plists and to modify com.apple.Boot.plist.

good luck

yoni



See my reply to the prev post.

download the fix sound pkg (see the prev post - the guy found and linked it) and also the OSX86Tools and PlistEdit Pro packages.

good luck
yoni


thank you very much mic works everything does :)

#8
kidalive

kidalive

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 275 posts
  • Gender:Male
same card dude
01471c1f 01471d10 02471e21 01471f01 01571c10 01571d01 01571e13
01571f99 01671cf0 01671d11 01671e11 01671f41 01771cf0 01771d11
01771e11 01771f41 01871d98 01871c30 01871f01 01871ea1 01971d09
01971c3f 01971f99 01971ea3 01a71d11 01a71cf0 01a71f41 01a71e11
01b71d11 01b71cf0 01b71f41 01b71e11 01c71d01 017c1cf0 01c71f59
01c71e33 01d71d01 01d71cf0 01d71f59 01d71e83 01e71d11 01e71c20
01e71f01 01e71e45 01f71d11 01f71cf0 01f71f41 01f71e11


#9
Carlos Pombo

Carlos Pombo

    InsanelyMac Protégé

  • Members
  • PipPip
  • 97 posts
  • Gender:Male
  • Location:Porto - Portugal
Have the exact same Audio
After installing the linked AppleAzaliaAudio:kext got sound out working
Sound in / mic not working..
still looking for solution

#10
lnknprksoldier

lnknprksoldier

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
anyone find a fix for this yet?

#11
marreco

marreco

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Hi yonib,
I have the same audio card as u,
did u got line out and mic ?

Or just speaker out?

00:1b.0 Audio device [0403]: Intel Corporation 82801H (ICH8 Family) HD Audio Controller [8086:284b] (rev 03)

If u had got a line out or/and mic please please please post step by step how u did this!
I had tried everithing the only way that i have sound is with azaliaaudio and only speaker out!

No line out and no mic

Thanks a lot

#12
edabe

edabe

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Thanks for the guide!
I also have the 82801H and it works for audio, but no line in nor line out.

On my case I also had to remove AppleHDA.kext from the system.

Thanks,
edabe

#13
Noise123123123

Noise123123123

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
million times thank u 4 To_Fix_OSX86_Sound.pkg, i killed damn whole day with this problem

#14
manpe

manpe

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

million times thank u 4 To_Fix_OSX86_Sound.pkg, i killed damn whole day with this problem


Hi
I downloaded the To_Fix_OSX86_Sound.pkg package but when I double click on it I get the following error :

Operation could not be completed. (com.apple.installer.pagecontroller error -1.)
Couldn't open "To_Fix_OSX86_Sound.pkg".

New to OSX so I don't know how to solve this :/
Any tips on where to go from there ?

Thx by advance

#15
firsttime

firsttime

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Any input?

My mic does not work.

Any ideia?

#16
howephillip

howephillip

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

lspci -nn

00:00.0 Host bridge [0600]: Intel Corporation Mobile Memory Controller Hub [8086:2a00] (rev 03)00:01.0 PCI bridge [0604]: Intel Corporation Mobile PCI Express Root Port [8086:2a01] (rev 03)00:03.0 Communication controller [0780]: Intel Corporation Mobile MEI Controller [8086:2a04] (rev 03)00:19.0 Ethernet controller [0200]: Intel Corporation 82566MM Gigabit Network Connection [8086:1049] (rev 03)00:1a.0 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Contoller #4 [8086:2834] (rev 03)00:1a.1 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 [8086:2835] (rev 03)00:1a.7 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 [8086:283a] (rev 03)<strong class='bbc'>00:1b.0 Audio device [0403]: Intel Corporation 82801H (ICH8 Family) HD Audio Controller [8086:284b] (rev 03)</strong>00:1c.0 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 [8086:283f] (rev 03)00:1c.1 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 [8086:2841] (rev 03)00:1c.2 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 [8086:2843] (rev 03)00:1d.0 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 [8086:2830] (rev 03)00:1d.1 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 [8086:2831] (rev 03)00:1d.2 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 [8086:2832] (rev 03)00:1d.7 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 [8086:2836] (rev 03)00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev f3)00:1f.0 ISA bridge [0601]: Intel Corporation Mobile LPC Interface Controller [8086:2811] (rev 03)00:1f.1 IDE interface [0101]: Intel Corporation Mobile IDE Controller [8086:2850] (rev 03)00:1f.2 SATA controller [0106]: Intel Corporation Mobile SATA AHCI Controller [8086:2829] (rev 03)01:00.0 VGA compatible controller [0300]: nVidia Corporation Unknown device [10de:042a] (rev a1)02:00.0 Network controller [0280]: Intel Corporation Unknown device [8086:4229] (rev 61)05:00.0 Memory controller [0580]: Intel Corporation Unknown device [8086:444e] (rev 01)06:0b.0 CardBus bridge [0607]: Texas Instruments PCIxx12 Cardbus Controller [104c:8039]06:0b.1 FireWire (IEEE 1394) [0c00]: Texas Instruments PCIxx12 OHCI Compliant IEEE 1394 Host Controller [104c:803a]06:0b.2 Mass storage controller [0180]: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD) [104c:803b]06:0b.3 SD Host controller [0805]: Texas Instruments PCIxx12 SDA Standard Compliant SD Host Controller [104c:803c]

gfxutil -f pci8086,284b
DevicePath = PciRoot(0x0)/Pci(0x1b,0x0)

I created an input.plist:
<?xml version="1.0" encoding="UTF-8"?><!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd"><plist version="1.0"><dict><key>PciRoot(0x0)/Pci(0x1b,0x0)</key>       <dict>             <key>PinConfigurations</key>             <string></string>             <key>built-in</key>             <string>0x00</string>             <key>layout-id</key>             <string>0x0000000c</string>             <key>revision-id</key>             <string>0x00000003</string>             <key>subsystem-id</key>             <string>0x000001db</string>             <key>subsystem-vendor-id</key>             <string>0x00001028</string>             <key>vendor-id</key>             <string>0x00008086</string>       </dict></dict></plist>

and gfxutiled it to get a hex:
2f0100000100000001000000230100000700000002010c00d041030a000000000101060001b7fff04001c0000007200650076006900730069006f006e002d0069006400000008000000030000028000000500069006e0043006f006e00660069006700750072006100740069006f006e0073000000400000018000000760065006e0064006f0072002d0069006400000008000000868000002c00000730075006200730079007300740065006d002d00760065006e0064006f0072002d006900640000008000000281000001e000000730075006200730079007300740065006d002d006900640000000800000db010000180000006c00610079006f00750074002d00690064000000080000000c00000016000006200750069006c0074002d0069006e0000000500000000

so now my com.apple.Boot.plist is:
<?xml version="1.0" encoding="UTF-8"?><!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd"><plist version="1.0"><dict>        <key>Kernel</key>        <string>mach_kernel</string>        <key>Kernel Flags</key>        <string>-v</string>        <string>cpus=1</string>        <string>rd=disk0s2</string>        <key>Boot Graphics</key>        <string>Yes</string>        <key>Quiet Boot</key>        <string>No</string>        <key>Timeout</key>        <string>5</string>        <key>Graphics Mode</key>        <string>1680x1050x32</string>        <key>device-properties</key>        <string>2f0100000100000001000000230100000700000002010c00d041030a0000000001010600001b7ff04001c0000007200650076006900730069006f006e002d0069006400000008000000030000002800000500069006e0043006f006e00660069006700750072006100740069006f006e0073000000040000018000000760065006e0064006f0072002d0069006400000008000000868000002c00000073005006200730079007300740065006d002d00760065006e0064006f0072002d006900640000000800000281000001e000000730075006200730079007300740065006d002d0069006400000008000000db10000180000006c00610079006f00750074002d00690064000000080000000c00000016000000620750069006c0074002d0069006e0000000500000000</string></dict></plist>

and still, no sound...

Help!!

Ok..I'm a complete noob to OSX86. What the heck is this and how do I do it? My thing says: 82801I

#17
mr hp

mr hp

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
i tried the To_Fix_OSX86_Sound.pkg file and it didn't help me. I have the same intel audio card and no sound.

#18
gattu marrudu

gattu marrudu

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts

I created an input.plist:

<?xml version="1.0" encoding="UTF-8"?><!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd"><plist version="1.0"><dict><key>PciRoot(0x0)/Pci(0x1b,0x0)</key>       <dict>             <key>PinConfigurations</key>             <string></string>             <key>built-in</key>             <string>0x00</string>             <key>layout-id</key>             <string>0x0000000c</string>             <key>revision-id</key>             <string>0x00000003</string>             <key>subsystem-id</key>             <string>0x000001db</string>             <key>subsystem-vendor-id</key>             <string>0x00001028</string>             <key>vendor-id</key>             <string>0x00008086</string>       </dict></dict></plist>


My vendor/device id is 8086:293e (Intel 82801I). Same PCI root.
Which part do I have to change in the .plist? I saw your vendor id which is the same as mine, but I don't see your device id so I don't know how to substitute it with mine.

Thanks!
gm

#19
ccsr

ccsr

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 104 posts
  • Gender:Male
  • Location:UK
Hi everyone. Many thanks for the fix posted, it has fixed my audio out but not my mic. I have snow leo 10.6 and let me tell ya, it has been a struggle. For days I tried to install this OS without luck but yesterday I took out my broadcom wlan card and a gig out of my 4 gig and installed first time. Obviously with no sound.I then put the wlan card in and airport wouldn't turn on but eventually got that sorted too. On the hunt for the audio fix I came to this thread. After applying the fix I got my sound working through the speakers but no inputs. So, no mic or line in which is a pain coz I use skype. Everything else works great which is a shame really as I am afraid of fixing the rest of the audio and mess everything else up. I also have the 82801H intel sound card and if anyone can help me with editing the plist or any other fix I would really appreciate that. I know this is an old thread but have to give it a try.


Thanks again





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy