Jump to content

Problema con Time Machine en ideneb 10.5.5


  • Please log in to reply
56 replies to this topic

#1
RiSaMa

RiSaMa

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 149 posts
Buenas me gustaria usar el time machine en mi hackintosh ya que tengo muchos archivos de los que mi vida depende :D jaja

Tengo instalado ideneb 10.5.5 en este pc: E6700, p5w dh deluxe, 4gb ddr2 800, HD WD, seagate, externo...

Existen dos problemillas:

* El primero: el disco duro externo que tengo tiene salida eSATA (y la asus p5w dh deluxe tiene entrada), pero en todos los osx que he puesto si lo conecto por eSATA, va bien un tiempo pero siempre acaba saliendo como una cortinilla gris con letras en varios idiomas diciendo que debo reiniciar el pc (vamos que no va...) Alguien sabe como hacer funcionar un disco eSATA con esta placa?

* El segundo: ahora tengo conectado el disco externo por USB (ya q el eSATA, por ahora no va). Configuro el time machine y me dice: "no se a encontrado el volumen de la copia de sguridad" alguna solucin?

Muchas gracias!!!

#2
roidm

roidm

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,057 posts
  • Gender:Male
  • Location:Spain
La controlador eSata de esa placa es Jmicron y tu tienes 4gb de ram por lo que si no usas la versin del driver par 64bit obtendrs kernel panic cuando el uso de la memoria de tu sistema sobrepase 3,2 gb....

Prueba el driver que te adjunto y comenta como te ha ido... suerte :D

Para que el timemachine funcione correctamente puedes aadir efistrings para tu ethernet con el efistudio o usar el SMbiosresolver de superhai (http://www.superhai.com/darwin.html), que aade fix para el "uuid error35" que es el causante del fallo del TM.

Attached File  JMicronATA.kext.zip   53.11KB   27 downloads


edit:
ArmandoCST tienes CI/QE activado para tu grfica?

#3
RiSaMa

RiSaMa

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 149 posts

La controlador eSata de esa placa es Jmicron y tu tienes 4gb de ram por lo que si no usas la versin del driver par 64bit obtendrs kernel panic cuando el uso de la memoria de tu sistema sobrepase 3,2 gb....

Prueba el driver que te adjunto y comenta como te ha ido... suerte :)


Voy a probarlo :)

Para que el timemachine funcione correctamente puedes aadir efistrings para tu ethernet con el efistudio o usar el SMbiosresolver de superhai (http://www.superhai.com/darwin.html), que aade fix para el "uuid error35" que es el causante del fallo del TM.

Siento decirte que no se lo que me estas diciendo :) jeje

Por lo que veo hay dos opciones... "aadir efistrings para tu ethernet con el efistudio" --> como se hace :)?
o
"Usar SMbiosresolver de superhai" --> como se hace?

Que me recomiendas hacer? lo mas facil... cual es?

Siento ser tan novato...:(

Salu2!!! y MUCHAS GRACIAS!

#4
roidm

roidm

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,057 posts
  • Gender:Male
  • Location:Spain
Para el TM usa el Zip que te adjunto, instlalo con kexthelper por ejemplo, reinicia con -f :(

Attached File  ZIP.zip   34.41KB   121 downloads

#5
RiSaMa

RiSaMa

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 149 posts
Primero he intentado hacer solo lo de arreglar el eSATA:

He sustituido IOATAFamily.kext y el JMicronATA.kext de extensions, he borrado el Extensions.mkext, he restaurado permisos y el ordenador no arranca... Sale la pantalla gris con la manzanita y sale al tiempo una seal de prohibido aparcar...

Si inicio el pc con -f y el disco duro apagado --> arranca bien.

Si inicio el pc con -f y el disco duro encendido --> arranca bien y NO detecta el externo...

Si inicio "normal" no se enciende... sale la pantallita gris con la seal de prohibido...

edito: si arranco con -v y el disco conectado se queda (y se repite y repite esto):

USBF: x.xx [numeros] The IOUSFamily was not able to enumerate a device.
The IOSUBFamily is having trouble enumerating a USB device that has been plugged in It will keep retring



tal vez algo que modificamos en la bios el otro dia ay q cambiar?? en la bios dejamos JMicron SATA/RAID BOOTROM --> disable (tiene q ser asi?)

Qu puedo hacer?!!!

Salu2!

#6
roidm

roidm

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,057 posts
  • Gender:Male
  • Location:Spain
Y xque has modificado el Ioata? :unsure: lo nico que te he mandado es el jmicron para la controladora externa, no tenas que haber modificado el ioata. Tendrs que restaurarlo. Por tus discos en AHCI.

activa tu jmicron y ponla en modo ahci, de esa forma podrs pinchar/despinchar en caliente.

#7
RiSaMa

RiSaMa

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 149 posts
En el JMICRON64BIT.zip que me has mandado esta el ioata y el jmicron... :unsure:...

Bueno que hago para arreglar esto!!! :(???

He iniciado con el -f y e vuelto a poner los dos que estaban antes... pero nada... me da el mismo error :(...

Salu2!...

#8
roidm

roidm

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,057 posts
  • Gender:Male
  • Location:Spain
Tienes razn en el pack va el ioatafamily y no debera de estar ah, perdona compaero :unsure:

Bueno tranquilo que hay solucin :(

ten a mano los originales, muevete con el finder a la carpeta /S/L/extensions y elimina el ioatafamily y el jmicron, te pedir contrasea. Copia y pega los originales, te volver a pedir contrasea, ahora abre un terminal y teclea:

sudo -s
(contrasea)

cd /system/library/extensions
chmod -R 755 * && chown -R root:wheel *
cd ..
rm extensions.mkext
kextcache -a i386 -e
reboot


reinicia con -f

#9
RiSaMa

RiSaMa

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 149 posts
ok, solo una cosa...q significa reiniciar con -f jeje.

ahora mismo lo pruebo.

gracias

#10
roidm

roidm

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,057 posts
  • Gender:Male
  • Location:Spain
fuerza a recargar todas las extensiones y recrea el kextcache.

#11
RiSaMa

RiSaMa

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 149 posts
Formul mal la pregunta... Como se "reinicia en -f"? Cuando se inicia el ordenador, despues de reiniciar?? F8 y ahi pongo -f

Quiers decir eso :unsure:?

Salu2!

#12
roidm

roidm

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,057 posts
  • Gender:Male
  • Location:Spain
sip :(

#13
RiSaMa

RiSaMa

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 149 posts
Bueno ya he hecho eso :(... y ahora :(?

Salu2! :)

#14
roidm

roidm

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,057 posts
  • Gender:Male
  • Location:Spain
tienes todo como estaba antes? es para partir de la base que empezamos :(

#15
RiSaMa

RiSaMa

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 149 posts
S, los kext originales, todo como estaba.

Arranca perfectamente tal cual lo hacia antes.

Salu2!!

#16
roidm

roidm

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,057 posts
  • Gender:Male
  • Location:Spain
abre un terminal y teclea kextstat, copia y pega la informacin en un codebox aqui.

#17
RiSaMa

RiSaMa

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 149 posts
Ah esta:
[codebox]Index Refs Address Size Wired Name (Version) <Linked Against>
1 1 0x0 0x0 0x0 com.apple.kernel (9.5.0)
2 38 0x0 0x0 0x0 com.apple.kpi.bsd (9.5.0)
3 3 0x0 0x0 0x0 com.apple.kpi.dsep (9.5.0)
4 52 0x0 0x0 0x0 com.apple.kpi.iokit (9.5.0)
5 54 0x0 0x0 0x0 com.apple.kpi.libkern (9.5.0)
6 49 0x0 0x0 0x0 com.apple.kpi.mach (9.5.0)
7 26 0x0 0x0 0x0 com.apple.kpi.unsupported (9.5.0)
8 1 0x0 0x0 0x0 com.apple.iokit.IONVRAMFamily (9.5.0)
9 1 0x0 0x0 0x0 com.apple.driver.AppleNMI (9.5.0)
10 1 0x0 0x0 0x0 com.apple.iokit.IOSystemManagementFamily (9.5.0)
11 1 0x0 0x0 0x0 com.apple.iokit.ApplePlatformFamily (9.5.0)
12 14 0x0 0x0 0x0 com.apple.kernel.6.0 (7.9.9)
13 1 0x0 0x0 0x0 com.apple.kernel.bsd (7.9.9)
14 1 0x0 0x0 0x0 com.apple.kernel.iokit (7.9.9)
15 1 0x0 0x0 0x0 com.apple.kernel.libkern (7.9.9)
16 1 0x0 0x0 0x0 com.apple.kernel.mach (7.9.9)
17 16 0x5564c000 0x10000 0xf000 com.apple.iokit.IOPCIFamily (2.4.1) <7 6 5 4>
18 8 0x55662000 0x4000 0x3000 com.apple.iokit.IOACPIFamily (1.2.0) <12>
19 2 0x556b0000 0x3d000 0x3c000 com.apple.driver.AppleACPIPlatform (1.1.0) <18 17 12 7 4>
20 1 0x55796000 0x9000 0x8000 com.apple.driver.AppleSMC (2.0.1d2) <18 7 6 5 4>
21 0 0x557a1000 0x3000 0x2000 com.apple.Dont_Steal_Mac_OS_X (6.0.2) <20 7 5 4 2>
22 3 0x55828000 0x1c000 0x1b000 com.apple.iokit.IOGraphicsFamily (1.5.2) <17 7 6 5 4>
23 9 0x558c3000 0x18000 0x17000 com.apple.iokit.IOStorageFamily (1.5.2) <7 6 5 4 2>
24 0 0x558f6000 0x10000 0xf000 com.apple.driver.DiskImages (195) <23 7 6 5 4 2>
25 0 0x55913000 0x2000 0x1000 com.apple.dsmos (1.0.0d1) <7 5 4 2>
26 0 0x5592a000 0x5000 0x4000 com.apple.BootCache (30.1) <7 6 5 4 2>
27 3 0x559f1000 0x39000 0x38000 com.apple.iokit.IOHIDFamily (1.5.3) <7 6 5 4 2>
28 0 0x55a5e000 0x3000 0x2000 com.apple.security.TMSafetyNet (3) <7 6 5 3 2>
29 0 0x55a78000 0x8000 0x7000 com.apple.nke.applicationfirewall (1.0.77) <7 6 5 4 2>
30 0 0x55ab8000 0x18000 0x17000 com.apple.security.seatbelt (107.10) <7 6 5 3 2>
31 0 0x55b1f000 0x3000 0x2000 com.apple.driver.AppleAPIC (1.2.0) <12>
32 0 0x55b34000 0x5000 0x4000 com.apple.driver.AppleSMBIOS (1.0.13) <12>
34 0 0x5b7fe000 0x3000 0x2000 com.apple.driver.AppleACPIPCI (1.1.0) <19 18 17 12>
35 0 0x5b840000 0x5000 0x4000 com.apple.driver.AppleRTC (1.0.6) <18 6 5 4 2>
36 0 0x5b87a000 0x3000 0x2000 com.apple.driver.AppleHPET (1.1) <18 7 6 5 4>
37 1 0x5b8de000 0x9000 0x8000 com.apple.iokit.IOSerialFamily (9.1) <7 6 5 4 2>
38 1 0x5b910000 0x9000 0x8000 com.apple.driver.Apple16X50Serial (1.9) <37 17 12>
39 0 0x5b920000 0x2000 0x1000 com.apple.driver.Apple16X50ACPI (1.9) <38 18 12>
40 0 0x5baeb000 0x4000 0x3000 com.apple.driver.AppleACPIButtons (1.1.0) <27 19 18 7 6 5 4 2>
41 0 0x5bb15000 0x3000 0x2000 com.apple.driver.AppleLPC (1.2.2) <17 6 5 4>
42 7 0x5bbc5000 0x28000 0x27000 com.apple.iokit.IOUSBFamily (3.1.5) <7 6 5 4>
43 0 0x5bc1e000 0xe000 0xd000 com.apple.driver.AppleUSBUHCI (3.1.5) <42 17 7 6 5 4>
44 0 0x5bc3a000 0x3000 0x2000 com.apple.driver.AppleEFIRuntime (1.1.0) <7 5 4>
46 0 0x5bda7000 0x12000 0x11000 com.apple.driver.AppleUSBEHCI (3.1.5) <42 17 7 6 5 4>
47 4 0x5be2a000 0xd000 0xc000 com.apple.iokit.IOATAFamily (1.7.3f1) <6 5 4 2>
48 0 0x5be51000 0x9000 0x8000 com.apple.driver.AppleIntelPIIXATA (2.0.0) <47 17 6 5 4>
51 2 0x5bfdb000 0x16000 0x15000 com.apple.iokit.IONetworkingFamily (1.6.0) <7 6 5 4 2>
52 0 0x5c03a000 0x40000 0x3f000 com.apple.iokit.AppleYukon2 (3.1.10b2) <51 17 12 4 2>
53 2 0x5c0f1000 0xe000 0xd000 com.apple.iokit.IONDRVSupport (1.5.2) <22 17 7 6 5 4>
54 0 0x5c14a000 0x2000 0x1000 com.apple.iokit.IOUSBUserClient (3.0.7) <42 6 5 4>
55 2 0x5c191000 0x6000 0x5000 com.apple.iokit.IOHDAFamily (1.2.9a4) <6 5 4 2>
56 0 0x5c1a5000 0x7000 0x6000 com.apple.driver.AppleHDAController (1.4.0a23) <55 17 6 5 4 2>
57 1 0x5c1f8000 0x3000 0x2000 com.apple.kext.OSvKernDSPLib (1.1) <6 5>
58 2 0x5c224000 0x17000 0x16000 com.apple.iokit.IOAudioFamily (1.6.4b7) <57 6 5 4 2>
59 0 0x5c246000 0x4000 0x3000 com.apple.driver.AudioIPCDriver (1.0.4) <58 6 5 4 2>
60 1 0x5c2ab000 0x6000 0x5000 com.apple.iokit.IOAHCIFamily (1.0.4) <6 5 4 2>
61 0 0x5c2c4000 0xa000 0x9000 com.apple.driver.AppleAHCIPort (1.5.1) <60 17 6 5 4 2>
62 0 0x5c36f000 0x7000 0x6000 com.jmicron.JMicronATA (1.0.0) <47 17 12>
63 0 0x5c3db000 0xb000 0xa000 com.apple.driver.AppleUSBHub (3.1.5) <42 6 5 4>
64 0 0x5c56a000 0x5e000 0x5d000 com.apple.ATIRadeonX1000 (5.3.0) <53 22 17 12 6 5 4 2>
65 2 0x5c728000 0x3f000 0x3e000 com.apple.iokit.IOFireWireFamily (3.4.4) <6 5 4 2>
66 0 0x5c79e000 0x20000 0x1f000 com.apple.driver.AppleFWOHCI (3.4.4) <65 17 7 6 5 4 2>
67 4 0x5c853000 0x19000 0x18000 com.apple.iokit.IOSCSIArchitectureModelFamily (2.0.4) <6 5 4 2>
68 0 0x5c88e000 0x4000 0x3000 com.apple.iokit.IOATAPIProtocolTransport (1.5.2) <67 47 12>
70 0 0x5c966000 0xe000 0xd000 com.apple.iokit.IOATABlockStorage (2.0.0) <47 23 6 5 4 2>
71 0 0x5caeb000 0x40000 0x3f000 com.apple.kext.ATY_Wormy (5.3.0) <53 22 18 17 6 5 4 2>
72 0 0x5cb91000 0x5000 0x4000 com.apple.driver.XsanFilter (2.7.91) <23 12>
73 0 0x5cd26000 0x6000 0x5000 com.apple.iokit.SCSITaskUserClient (2.0.4) <67 23 6 5 4 2>
74 3 0x5ce0d000 0x8000 0x7000 com.apple.iokit.IOCDStorageFamily (1.5) <23 6 5 4 2>
75 2 0x5ce4f000 0x6000 0x5000 com.apple.iokit.IODVDStorageFamily (1.5) <74 23 6 5 4 2>
76 1 0x5ce78000 0x16000 0x15000 com.apple.iokit.IOSCSIBlockCommandsDevice (2.0.4) <67 23 6 5 4 2>
77 1 0x5ce9c000 0x5000 0x4000 com.apple.iokit.IOBDStorageFamily (1.5) <75 74 23 6 5 4 2>
78 0 0x5cec8000 0x16000 0x15000 com.apple.iokit.IOSCSIMultimediaCommandsDevice (2.0.4) <77 76 75 74 67 23 6 5 4 2>
79 0 0x5cf28000 0x2000 0x1000 com.apple.driver.AppleUSBMergeNub (3.0.7) <42 5 4>
80 0 0x5cf79000 0x4000 0x3000 com.apple.driver.AppleUSBComposite (3.0.0) <42 5 4>
81 1 0x5d024000 0x5000 0x4000 com.apple.iokit.IOUSBHIDDriver (3.1.0) <42 27 6 5 4>
82 0 0x5d14d000 0x3000 0x2000 com.apple.driver.AppleHIDKeyboard (1.0.7f1) <81 27 12>
83 0 0x55844000 0x4b000 0x4a000 com.apple.driver.AppleHDA (1.4.0a23) <58 55 6 5 4 2>
84 0 0x55a90000 0x9000 0x8000 com.apple.iokit.IOFireWireIP (1.7.1) <65 51 6 5 4 2>
85 0 0x5bf6b000 0xb000 0xa000 com.apple.filesystems.autofs (2.0.1) <7 6 5 4 2>
86 0 0x5c1bd000 0x1b000 0x1a000 com.apple.filesystems.ntfs (2.1) <7 6 5 2>[/codebox]

#18
roidm

roidm

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,057 posts
  • Gender:Male
  • Location:Spain
edita y pon en vez del "quote" "codebox" as no ocupa tanto espacio.... :)

pues ahora probamos con el jmicron64 que te pas (solo el jmicron :) ) con el finder vas a tu carpeta de extensiones y eliminas el jmicron y copias y pegas el nuevo.

luego abres un terminal y tecleas

sudo -s
(contrasea)

chmod -R 755 /system/library/extensions/jmicron.kext
chown -R root:wheel /system/library/extensions/jmicron.kext
rm /system/library/extensions.mkext



reinicia y activa la controladora jmicron en modo AHCI

usa de nuevo el -f

#19
RiSaMa

RiSaMa

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 149 posts
Los dos comandos del terminal deben ser estos:

chmod -R 755 /system/library/extensions/jmicronATA.kext
chown -R root:wheel /system/library/extensions/jmicronATA.kext

no?

Ya que sin el ATA... no me encuentra nada...

edito:

He seguido los pasos con esos dos comandos (con ...ATA), e reiniciado, activado jmicron y encendido el mac con -f.

El disco externo no aparece... ni en el escritorio ni en utiliidad de discos :)... Hay que hacer algo mas? o no funciona...?

Gracias y salu2! :)

#20
roidm

roidm

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,057 posts
  • Gender:Male
  • Location:Spain
correcto era jmicronATA.kext jeje, has activado el AHCI en la controladora jmicron?

repite el kextstat de nuevo con el driver activado y reinicia con el disco pinchado.

de paso puedes hacerme un pack con tu AppleAHCI..., IOAHCI... y adjuntarmelo por favor?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy