Jump to content

Driver for nForce4 LAN


  • Please log in to reply
764 replies to this topic

#741
drumthrasher109

drumthrasher109

    InsanelyMac Legend

  • Guests
  • PipPipPipPipPipPipPip
  • 528 posts
I would try installing the kext with Kext Helper.

Go to the Extensions folder and delete the kext, reboot with -f, and try installing the kext with Kext Helped.

It's just an idea :thumbsup_anim:.

#742
bitshiftr

bitshiftr

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Gender:Male
Tried all 3 of the .zip's up on the front page and all of them return the exact same thing. I checked the info.plist's for all of the kexts and they all have 0x037310DE so I couldn't tell you why it's not working.

This is on an nForce 570 Asus M2N-E (no, not SLI), and I've been told it works on this motherboard if you use forcedeth-nockd.kext. (For what it's worth Dev ID = 01DE, Vendor ID = 0373 (0x037310de))

Rumor also has it that the forcedeth_Fix_PHYError.zip that has been kicking around works on the M2N-E but the rapidshare link that was posted in this forum has had its download limit exceeded, so hopefully someone in the forum may be able to post it. (FOUND in the Italian forum, look at the bottom of post. Hopefully this is the one everyone is so excited about.)

Thanks for your help.

Apr  1 10:04:04 htpcs-mac-pro kernel[0]: forcedeth: Initializing.
Apr  1 10:04:04 htpcs-mac-pro kernel[0]: forcedeth: Probing.
Apr  1 10:04:04 htpcs-mac-pro kernel[0]: forcedeth: WARNING - your nVidia device 0x10DE:0x0373 is not known to work. Continuing anyway...
Apr  1 10:04:04 htpcs-mac-pro kernel[0]: forcedeth: Starting.
Apr  1 10:04:04 htpcs-mac-pro kernel[0]: forcedeth: PCI system 0x10DE:0x0373, subsystem 0x1043:0x8239 opened.
Apr  1 10:04:04 htpcs-mac-pro kernel[0]: forcedeth: Mapped from 0xFE02A000 of length 4096.
Apr  1 10:04:04 htpcs-mac-pro kernel[0]: forcedeth: Allocated 3072 bytes of contiguous memory for DMA: rx at 0x412d9000, tx at 0x412d9400, wired at 0x23070000.
Apr  1 10:04:04 htpcs-mac-pro kernel[0]: forcedeth: Found nForce4 LAN with MAC: 00:18:F3:A3:35:09.
Apr  1 10:04:04 htpcs-mac-pro kernel[0]: forcedeth: Found PHY 0x5040:0x0003 at address 1.
Apr  1 10:04:05 htpcs-mac-pro kernel[0]: com_triton_forcedeth: Ethernet address 00:18:f3:a3:35:09
Apr  1 10:04:05 htpcs-mac-pro kernel[0]: forcedeth: Enabling... 1 2 3 4 5 6 7
Apr  1 10:04:05 htpcs-mac-pro kernel[0]: forcedeth: Starting transmit/receive engines
Apr  1 10:04:05 htpcs-mac-pro kernel[0]: forcedeth: Network link down.
Apr  1 10:04:05 htpcs-mac-pro kernel[0]: forcedeth: output, seg: 1/1, demand ck: 0, start: a0000155, end: a0000155 - 0
Apr  1 10:04:05 htpcs-mac-pro kernel[0]: forcedeth: Done with packet with flags 2000015a
Apr  1 10:04:05 htpcs-mac-pro kernel[0]: forcedeth: packet 80000000 - 8000062e
Apr  1 10:04:35: --- last message repeated 2998 times ---
Apr  1 10:04:35 htpcs-mac-pro kernel[0]: forcedeth: packet 80000000 - 8000062e

Attached Files



#743
eno

eno

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 188 posts
forcedeth.kext has been made obsolete by nForceLAN. You can find the new extension in the LAN and Wireless forum.

Tried all 3 of the .zip's up on the front page and all of them return the exact same thing. I checked the info.plist's for all of the kexts and they all have 0x037310DE so I couldn't tell you why it's not working.

This is on an nForce 570 Asus M2N-E (no, not SLI), and I've been told it works on this motherboard if you use forcedeth-nockd.kext. (For what it's worth Dev ID = 01DE, Vendor ID = 0373 (0x037310de))

Rumor also has it that the forcedeth_Fix_PHYError.zip that has been kicking around works on the M2N-E but the rapidshare link that was posted in this forum has had its download limit exceeded, so hopefully someone in the forum may be able to post it. (FOUND in the Italian forum, look at the bottom of post. Hopefully this is the one everyone is so excited about.)

Thanks for your help.

Apr  1 10:04:04 htpcs-mac-pro kernel[0]: forcedeth: Initializing.
Apr  1 10:04:04 htpcs-mac-pro kernel[0]: forcedeth: Probing.
Apr  1 10:04:04 htpcs-mac-pro kernel[0]: forcedeth: WARNING - your nVidia device 0x10DE:0x0373 is not known to work. Continuing anyway...
Apr  1 10:04:04 htpcs-mac-pro kernel[0]: forcedeth: Starting.
Apr  1 10:04:04 htpcs-mac-pro kernel[0]: forcedeth: PCI system 0x10DE:0x0373, subsystem 0x1043:0x8239 opened.
Apr  1 10:04:04 htpcs-mac-pro kernel[0]: forcedeth: Mapped from 0xFE02A000 of length 4096.
Apr  1 10:04:04 htpcs-mac-pro kernel[0]: forcedeth: Allocated 3072 bytes of contiguous memory for DMA: rx at 0x412d9000, tx at 0x412d9400, wired at 0x23070000.
Apr  1 10:04:04 htpcs-mac-pro kernel[0]: forcedeth: Found nForce4 LAN with MAC: 00:18:F3:A3:35:09.
Apr  1 10:04:04 htpcs-mac-pro kernel[0]: forcedeth: Found PHY 0x5040:0x0003 at address 1.
Apr  1 10:04:05 htpcs-mac-pro kernel[0]: com_triton_forcedeth: Ethernet address 00:18:f3:a3:35:09
Apr  1 10:04:05 htpcs-mac-pro kernel[0]: forcedeth: Enabling... 1 2 3 4 5 6 7
Apr  1 10:04:05 htpcs-mac-pro kernel[0]: forcedeth: Starting transmit/receive engines
Apr  1 10:04:05 htpcs-mac-pro kernel[0]: forcedeth: Network link down.
Apr  1 10:04:05 htpcs-mac-pro kernel[0]: forcedeth: output, seg: 1/1, demand ck: 0, start: a0000155, end: a0000155 - 0
Apr  1 10:04:05 htpcs-mac-pro kernel[0]: forcedeth: Done with packet with flags 2000015a
Apr  1 10:04:05 htpcs-mac-pro kernel[0]: forcedeth: packet 80000000 - 8000062e
Apr  1 10:04:35: --- last message repeated 2998 times ---
Apr  1 10:04:35 htpcs-mac-pro kernel[0]: forcedeth: packet 80000000 - 8000062e



#744
bruise

bruise

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
  • Gender:Male
  • Location:UK
Hi, :D i have successfully installed Kalyway-10.5.2 DVD-intel-AMD,
on my pc, many thanks. ever since somebody stole my mac pro, i could never pay
that price again.i have sound and usb's working and i have already installed my logic pro 7.2
and it works perfectly normal, but i have been unlucky with internet.so please
can somebody help me with internet, just a step by step instructions relating to
my system device.my pc dual boot just fine, i have windows vista running on another partition, and everything is perfectly normal there.what tricks me is how could my Logic Pro read my
midi keyboard cause i haven't installed my keyboard drive yet :huh: .one more question,
if i buy a legit Leopard, will it be possible to install it over the Patched one.

well i followed your instructions, and everytime i try this message
comes up ;)

" WARNING: Improper use of the sudo command could lead to data loss
or the deletion of important system files.
Please double-check your
typing when using sudo. Type "man sudo" for more information.
To proceed, enter your password, or type Ctrl-C to abort".

i have copied your sudo commands exactly as they are and paste
the commands in my terminal window, i paste line by line and this warning keeps
coming up.please help. :(



Cheers!

Motherboard-socket AM2-KN9 Ultra
hard drive-Hitachi HDT25040VLA SCSi Disk Device
display adapters-radeon x1650 Series
ATA contrllers:Nvidia nforce Serial ATA controller
network adapters:Belkin Wireless G USB Network Adapter
and Nvidia nforce Networking controller.
processors:AMD Athlon 64 x2 dual Core 4200+
Memory:2 GB
Realteck High definition Audio.
32bit operating system.
rating windows experience:5.0

#745
bruise

bruise

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
  • Gender:Male
  • Location:UK
i tried loading the forcedeth kext, but i keep getting this error:"extension forcedeth.kext does not contain code for this architecture administrators-macpro31:desktop admin$".i tried all three different forcedeth kext.i have installed kalyway 10.5.2 on partition 2, and my vista is running on partition 1 of my hardrive.everything works, sound, usb and videos, i am just unfortunate with the internet so far.i also have belkini wireless usb, its so unstable, it only worked twice after that never, i managed to get it working with zydas drivers, but now is dead, and i need something stable.i have a cable that i want to use for internet instead of my wireless usb.my leopard shows i have no airport, i don't if this might be the problem and in my plist it shows the path as en0.i just hope that i provided enough information about my OS, so you can help me out in finding solutions.
Cheer!


my system:vista 32 bit operating system
AMD Athlon™ 64x2 Dual core processor 4200+
display adpters:radeon x1650 series
network:nvidia nforce 10/100/1000 mbps ethernet
network:Belkini wireless G usb network adapter
controllers:nvidia nforce serial ata controller
system device:nvidia nforce PCI system management.

#746
PGHammer

PGHammer

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 281 posts

i tried loading the forcedeth kext, but i keep getting this error:"extension forcedeth.kext does not contain code for this architecture administrators-macpro31:desktop admin$".i tried all three different forcedeth kext.i have installed kalyway 10.5.2 on partition 2, and my vista is running on partition 1 of my hardrive.everything works, sound, usb and videos, i am just unfortunate with the internet so far.i also have belkini wireless usb, its so unstable, it only worked twice after that never, i managed to get it working with zydas drivers, but now is dead, and i need something stable.i have a cable that i want to use for internet instead of my wireless usb.my leopard shows i have no airport, i don't if this might be the problem and in my plist it shows the path as en0.i just hope that i provided enough information about my OS, so you can help me out in finding solutions.
Cheer!
my system:vista 32 bit operating system
AMD Athlon™ 64x2 Dual core processor 4200+
display adpters:radeon x1650 series
network:nvidia nforce 10/100/1000 mbps ethernet
network:Belkini wireless G usb network adapter
controllers:nvidia nforce serial ata controller
system device:nvidia nforce PCI system management.


Try installing nForceLAN.kext using OSx86 Tools (what I used on my P5N-EM HDMI with the nForce 630i chipset doing a triple of 7 RC Ultimate/Kubuntu 9.04/iAtkos 51 updated via iDeneb Combo Update to 10.5.7, all 64-bit). Internet is dead-stable (just as stable as in either Kubuntu or 7), and thanks to my digging up a USB 4-port PCI card from my spare-parts bin, the only hardware that *doesn't* work in all three OSes (internal hardware, that is) is my X-Fi (which is not supported in Leopard, of course).

HP DeskJet 940C (USB): Works OOTB
Logitech Communicate STX (USB): Works in iChat OOTB; have not tried in YM for Mac (which works otherwise)
HIS Radeon HD3450 256 MB PCIe: Works somewhat using combo of x2000/Natit (resolution tops at 1400x1050, no CI or QE)
Onboard audio: Works using VoodooHDA
Onboard LAN: Works (using nForceLAN.kext from the first post in this topic)
Onboard SATA: Works using NForceATA (despite complaint about AHCI port driver); with AHCI mode set in BIOS. IDE mode does not work.
Onboard IDE/PATA: Works using PCGenericATA.kext (included as plugin with IOATAFamily.kext); for some odd reason, the 630i's PATA port does NOT use NForceATA.kext, even when present.

#747
yangxin

yangxin

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
My device ID is 0269 10DE,after installing the driver in the post,my network card works correctly,but just in ipv4.
So,my question is does the driver support ipv6? In my case,it can not detect ipv6 address automatically,but in windows it can.

#748
Triconick

Triconick

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Hi, Im new to the hole mac on pc thing. I tryed all of the files here but none of them work, and they all give the same error. here is my log, can some one please help me? Thank you.




Log:
Jul 8 13:39:31 Tri-con-macpro31 kernel[0]: forcedeth: Found nForce4 LAN with MAC: 00:1F:C6:BC:DA:2A.
Jul 8 13:39:31 Tri-con-macpro31 kernel[0]: forcedeth: Could not find a valid PHY.
Jul 8 13:39:31 tri-con-macpro31 kernel[0]: forcedeth: Stopping


Does any one know why i it cand find a valid PHY?

i am useing iDeneb v1.3 10.5.5

My pc specs:

Motherboard: ASUS M2N-SLI
Chipset: Nvidia nForce560 SLI
AMD Phenon quad core 2.6GHZ

Ps: I have been looking all around for a solution but i cant find one. Can anyone help me please?
Thank you,
Triconick

#749
king123

king123

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Yeah when i try the sudo thing it always says to enter my password am i doing something wrong

Yeah when i try the sudo thing it always says to enter my password am i doing something wrong

#750
Mel11235

Mel11235

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
I'm not having any luck with this. Could you please have a quick look at my log, below? Note that I tried using just 'forcedeth.kext' first, with similar results to using 'forcedeth-nockd.kext'. Note also that I posted absolutely everything log entry, as I didn't know what was important/unimportant.

Last login: Mon Jul 27 04:45:36 on console
aa-fdsafdss-macpro31:~ aafdsafds$ tail -f /var/log/system.log
Jul 27 04:45:47 aa-fdsafdss-macpro31 iCal Helper[128]: _CFGetHostUUIDString: unable to determine UUID for host. Error: 35
Jul 27 04:45:47 aa-fdsafdss-macpro31 kernel[0]: CODE SIGNING: cs_invalid_page: p=131[mdworker] clearing CS_VALID
Jul 27 04:45:47 aa-fdsafdss-macpro31 mdworker[131]: _CFGetHostUUIDString: unable to determine UUID for host. Error: 35
Jul 27 04:45:48 aa-fdsafdss-macpro31 kernel[0]: CODE SIGNING: cs_invalid_page: p=132[mdworker] clearing CS_VALID
Jul 27 04:45:48 aa-fdsafdss-macpro31 mdworker[132]: _CFGetHostUUIDString: unable to determine UUID for host. Error: 35
Jul 27 04:45:49 aa-fdsafdss-macpro31 backupd-helper[133]: _CFGetHostUUIDString: unable to determine UUID for host. Error: 35
Jul 27 04:46:23 aa-fdsafdss-macpro31 TextEdit[135]: _CFGetHostUUIDString: unable to determine UUID for host. Error: 35
Jul 27 04:46:27 aa-fdsafdss-macpro31 AppleSpell[136]: _CFGetHostUUIDString: unable to determine UUID for host. Error: 35
Jul 27 04:46:34 aa-fdsafdss-macpro31 Terminal[138]: _CFGetHostUUIDString: unable to determine UUID for host. Error: 35
Jul 27 04:46:35 aa-fdsafdss-macpro31 login[139]: USER_PROCESS: 139 ttys000
Jul 27 04:46:58 aa-fdsafdss-macpro31 login[150]: USER_PROCESS: 150 ttys001
Jul 27 04:47:48 aa-fdsafdss-macpro31 sudo[161]: aafdsafds : TTY=ttys001 ; PWD=/Users/aafdsafds/Desktop/forcedeth/build/Release ; USER=root ; COMMAND=/usr/sbin/chown -R root:wheel forcedeth-nockd.kext
Jul 27 04:48:04 aa-fdsafdss-macpro31 sudo[162]: aafdsafds : TTY=ttys001 ; PWD=/Users/aafdsafds/Desktop/forcedeth/build/Release ; USER=root ; COMMAND=/bin/chmod -R 755 forcedeth-nockd.kext
Jul 27 04:48:21 aa-fdsafdss-macpro31 sudo[163]: aafdsafds : TTY=ttys001 ; PWD=/Users/aafdsafds/Desktop/forcedeth/build/Release ; USER=root ; COMMAND=/sbin/kextload -v forcedeth-nockd.kext
Jul 27 04:49:03 aa-fdsafdss-macpro31 com.apple.launchd[95] (0x109810.Locum[164]): Exited: Terminated
Jul 27 04:49:03 aa-fdsafdss-macpro31 quicklookd[165]: _CFGetHostUUIDString: unable to determine UUID for host. Error: 35
Jul 27 04:49:04 aa-fdsafdss-macpro31 kernel[0]: CODE SIGNING: cs_invalid_page: p=166[lssave] clearing CS_VALID
Jul 27 04:49:45 aa-fdsafdss-macpro31 /Applications/TextEdit.app/Contents/MacOS/TextEdit[135]: Had to sleep for 200 milliseconds to clear transactions race for -102/(.TemporaryItems/folders.501/TemporaryItems/(A Document Being Saved By TextEdit),(null))
Jul 27 04:50:17 aa-fdsafdss-macpro31 /Applications/TextEdit.app/Contents/MacOS/TextEdit[135]: Had to sleep for 200 milliseconds to clear transactions race for -102/(.TemporaryItems/folders.501/TemporaryItems/(A Document Being Saved By TextEdit),(null))


Thanks for any assistance.

#751
welshie

welshie

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
I've tried version 0.3 of your driver on a machine with a Foxconn AM2 N570SM2AA-8EKRS2H motherboard. Whilst all versions of your driver find the NICs and work out the MAC addresses, none of them manage to bring the link up.

This is with PCI id 0x10de:0x0373.

With the latest (0.3) driver, soon after it's identified the MAC addresses, it crashes the AppleUSBEHCI, meaning that the keyboard and mouse die.

... kernel[0]: com_triton_forcedeth: Ethernet address 00:15:58:5b:5d:19
... kernel[0]: com_triton_forcedeth: Ethernet address 00:15:58:5b:5d:18
... kernel[0]: USBF: 228.782 AppleUSBEHCI [0x3357000]:: Found a transaction past the completion deadline on bus 34, timing out!

Co-incidentally, on the same motherboard, the NIC doesn't work (no link light) in Ubuntu 8.10 or 8.04.1 either, but does work under Windows XP (boo), so it looks to be a problem on the upstream driver from where you're borrowing code from.

#752
eno

eno

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 188 posts

I've tried version 0.3 of your driver on a machine with a Foxconn AM2 N570SM2AA-8EKRS2H motherboard. Whilst all versions of your driver find the NICs and work out the MAC addresses, none of them manage to bring the link up.

This is with PCI id 0x10de:0x0373.

With the latest (0.3) driver, soon after it's identified the MAC addresses, it crashes the AppleUSBEHCI, meaning that the keyboard and mouse die.

... kernel[0]: com_triton_forcedeth: Ethernet address 00:15:58:5b:5d:19
... kernel[0]: com_triton_forcedeth: Ethernet address 00:15:58:5b:5d:18
... kernel[0]: USBF: 228.782 AppleUSBEHCI [0x3357000]:: Found a transaction past the completion deadline on bus 34, timing out!

Co-incidentally, on the same motherboard, the NIC doesn't work (no link light) in Ubuntu 8.10 or 8.04.1 either, but does work under Windows XP (boo), so it looks to be a problem on the upstream driver from where you're borrowing code from.


Try the nForceLAN driver from the other sticky'd thread.

#753
frenkiebus

frenkiebus

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
I can't do it...when i do the step 4 the terminal ask me :No such file on directory ;) can someone help me?!! :(

#754
leoaguirre

leoaguirre

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
After to enter the last command, system keep working, but my usb keyboard and my usb don't work. Then I must restart. What can I do??
Please help me.

#755
eno

eno

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 188 posts

After to enter the last command, system keep working, but my usb keyboard and my usb don't work. Then I must restart. What can I do??
Please help me.


Use nForceLAN (the other sticky thread in the forum). forcedeth.kext is obsolete.

#756
leoaguirre

leoaguirre

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

Use nForceLAN (the other sticky thread in the forum). forcedeth.kext is obsolete.


Ok... I'll try.
Thanks!

#757
olaszvandor

olaszvandor

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts

Post the source code as well as the actual thing. That way more development can be made on this.

Also, just as a warning. You may get alot of people asking how to load it etc etc etc. You may want to make a little tutorial, which should save you time instead of having to answer questions over and over.

But thanks :) This is great progress! Hopefully soon, nForce will be fully supported, lol

TheFighter

:D

#758
an12345

an12345

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
:(

#759
hackingmacisback

hackingmacisback

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Last login: Thu May 27 12:21:57 on ttys000


localhost:~ jamie$ tail -f /var/log/system.

log
May 27 12:21:06 localhost mdworker[217]: _CFGetHostUUIDString: unable to determine UUID for host. Error: 35
May 27 12:21:44 localhost iTunes[218]: _CFGetHostUUIDString: unable to determine UUID for host. Error: 35



May 27 12:21:57 localhost Terminal[219]: _CFGetHostUUIDString: unable to determine UUID for host. Error: 35
May 27 12:21:57 localhost login[220]: USER_PROCESS: 220 ttys000
May 27 12:22:03 localhost TextEdit[230]: _CFGetHostUUIDString: unable to determine UUID for host. Error: 35


May 27 12:22:07 localhost AppleSpell[231]: _CFGetHostUUIDString: unable to determine UUID for host. Error: 35


May 27 12:22:34 localhost login[220]: DEAD_PROCESS: 220 ttys000


May 27 12:22:35 localhost kernel[0]: CODE SIGNING: cs_invalid_page: p=236[mdworker] clearing CS_VALID


May 27 12:22:35 localhost mdworker[236]: _CFGetHostUUIDString: unable to determine UUID for host. Error: 35


May 27 12:22:36 localhost login[237]: USER_PROCESS: 237 ttys000
May 27 12:24:07 localhost quicklookd[248]: _CFGetHostUUIDString: unable to determine UUID for host. Error: 35
May 27 12:24:08 localhost kernel[0]: CODE SIGNING: cs_invalid_page: p=249[lssave] clearing CS_VALID

I have ideneb 1.3 with a nvidia nforce network controller im trying to get the driver to work but this error comes up :wallbash:
please help me ASAP

#760
evil_evo

evil_evo

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
Hi guys, I tried to install the driver however everytime I type the following command:

kextload -v ~/desktop/forcedeth/build/release/forcedeth.kext

I get failed to load authentication failure (file ownership/permissions)

I have tried this under sudo -s I get the same message, I have tried giving the folder all the permission still doesnt work.

Can someone here please help me? Thanks





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy