Jump to content

[BOOT-132] Legacy AppleHDA


  • Please log in to reply
231 replies to this topic

#221
andreJPBR

andreJPBR

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts

I don't know your setup but I'm sure you have HDAenabler, don't you
keep your audio kext except replace HDAenabler with this one:

(I didn't make this I just found it in this forum...)

10.5.7 give me a kernel panic too
Solution:
Reboot w 132
Install AppleHDA.kext v.1.6.2a37 (original 10.5.6 previous back-up) w Kext Helper
Reboot with -v -f
All works fine again! ;)
100% Vanilla?????? I d know, but i m happy!!!! :(
Another solution???
Tanks.

#222
chagani

chagani

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts

I don't know your setup but I'm sure you have HDAenabler, don't you
keep your audio kext except replace HDAenabler with this one:

(I didn't make this I just found it in this forum...)


Thanks for suggestion, I tried it but no joy, still kernel panics. Am going to revert back to the AppleHDA from 10.5.6 until someone finds out what has changed in the 10.5.7 AppleHDA.

#223
Dr. Hurt

Dr. Hurt

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,493 posts
  • Gender:Male
  • Location:Cairo, Egypt and NYC, USA
  • Interests:Wandering around on the internet!! Politics, Sci/Tech, Medicine.
KP here too. I guess I'm going to back to the patched version instead of the legacy version since I have to replace the kext anyway in updates.

#224
jjoe

jjoe

    InsanelyMac Protégé

  • Members
  • PipPip
  • 57 posts
Audio works on my ga-p35-ds3l rev 2.0 with alc888, tested on 10.5.6.

If you are using Boot-132 created by munky, and have a fresh install.just do the following:

1. Download the zip file, extract to ~/Download for example.
2. Add <string>OSBundleRequired</string> <key>Root</key> to info.plist for each of the three download kexts.
3. Mount EFI partition, copy the three kexts to EFI/Extra/Extensions/
4. Fix EFI/Extra/Extension permissions
5. Update EFI/Extra/Extensions.mkext
6. Fix /EFI/Extra/Extension.mkext permission
7. unmount EFI
8. ready to reboot

Make sure the original AppleHDA.kext is in /System/Library/Extensions.

If you have working audio with taruga's AppleHDA patcher, you'll have two updated kext in /System/Library/Extensions/:
1. ALCinject.kext
2. AppleHDA.kext

Those two files won't load like other kexts in EFI, if you copy them to EFI.
To make it work, replace the modified AppleHDA in /System/Library/Extensions with the original one from a retail DVD, and delete ALCinject.kext.
Then you can follow the steps mentioned previously, like you have a fresh install.

#225
jjoe

jjoe

    InsanelyMac Protégé

  • Members
  • PipPip
  • 57 posts

10.5.7 give me a kernel panic too
Solution:
Reboot w 132
Install AppleHDA.kext v.1.6.2a37 (original 10.5.6 previous back-up) w Kext Helper
Reboot with -v -f
All works fine again! :)
100% Vanilla?????? I d know, but i m happy!!!! :(
Another solution???
Tanks.


So you replaced AppleHDA.kext from 10.5.7 with AppleHDA.kext from 10.5.6?

I thought this thread is for avoiding this kind of updating problem. Or we could just keep patched AppleHDA.kext in /System/Library/Extensions. It will cause kernel panic as well I guess.

#226
mattrb

mattrb

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 318 posts
  • Location:Chicago, IL

So you replaced AppleHDA.kext from 10.5.7 with AppleHDA.kext from 10.5.6?

I thought this thread is for avoiding this kind of updating problem. Or we could just keep patched AppleHDA.kext in /System/Library/Extensions. It will cause kernel panic as well I guess.


For legacy HDA 10.5.7 to work:

HDAenabler needs edit in plisteditpro to work on 10.5.7

actual HDAenabler info.plist (open contents) says near end of file:
CODE <key>com.apple.kernel.iokit</key>
<string>6.9.9</string>

need to say:
CODE <key>com.apple.kernel.iokit</key>
<string>7.9.9</string>

Thanks to macgirl

#227
Cathul

Cathul

    InsanelyMac Protégé

  • Members
  • PipPip
  • 69 posts
  • Gender:Male

For legacy HDA 10.5.7 to work:

HDAenabler needs edit in plisteditpro to work on 10.5.7

actual HDAenabler info.plist (open contents) says near end of file:
CODE <key>com.apple.kernel.iokit</key>
<string>6.9.9</string>

need to say:
CODE <key>com.apple.kernel.iokit</key>
<string>7.9.9</string>

Thanks to macgirl


Whatever, i still got kernel panics with this change, so i switched to tmongkols legacy kexts for 10.5.7.

#228
Ritz Carltn

Ritz Carltn

    Ritz Carltn

  • Members
  • PipPipPipPip
  • 248 posts
  • Gender:Male
  • Interests:HP EliteBook 8540p,i7-820QM, 68CVD Ver F.0F, nVidia NVS5100M, ML with Clover

Audio works on my ga-p35-ds3l rev 2.0 with alc888, tested on 10.5.6.


I think you will have KP after upgrading 10.5.7.

#229
FKA

FKA

    are we there yet?

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,626 posts
  • Gender:Male
Has anybody else noticed that having EFI runtime disabler is causing sound assertion errors!

I've been using a disabler.kext for CPU Power managment and ACPI_SMC_Platform.

I swapped this for one that included EFI runtime and this lead to 4 or 5 sound assertion errors on boot ...... !

#230
Dr. Hurt

Dr. Hurt

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,493 posts
  • Gender:Male
  • Location:Cairo, Egypt and NYC, USA
  • Interests:Wandering around on the internet!! Politics, Sci/Tech, Medicine.

Has anybody else noticed that having EFI runtime disabler is causing sound assertion errors!

I've been using a disabler.kext for CPU Power managment and ACPI_SMC_Platform.

I swapped this for one that included EFI runtime and this lead to 4 or 5 sound assertion errors on boot ...... !


You're right
I thought that the assertion errors I was getting were due to an incorrectly patched Legacy kext. Apparently that was not the case. Removing the disabler.kext got rid of all the assertion errors.

#231
Opes

Opes

    InsanelyMac Protégé

  • Members
  • PipPip
  • 89 posts
Im hearing noise in my headphones that are connected in the front panel port when I do something in the computer, but not if I connect them in the back panel. I have GA-EP45-DS5, 889a. Any fix for this?

#232
Gurujee

Gurujee

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts
Hi,

Is there any new version of these available to work in SL x64 mode. I have GA EP45-UD3L (ICH10 with ALC888) running SL in x64 mode without any error or issue. got QE/CI working for my 8800GT and LAN working through DSDT.aml. But no sound. This board is excellent for running hackintosh but only problem is the sound chip. Any suggestion how to get sound from it. I simple need 2 channel sound and mic input from fron if possible. No 5.1 / DTS / 7.1 required. Simple 2 channel output. Any way?

If so, can anyone guide me which files should I use and where to keep them. S/L/E or E/E. Also one input required. To put kexts in S/L/E I normally use KextHelper, but to put kext in E/E I simple make a copy of kext and put it there. Am I doing right?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy