Jump to content

Intel 82566mm Ethernet works on Mac OS X (Leopard 10.5.3)


  • Please log in to reply
186 replies to this topic

#161
hrcolb0

hrcolb0

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Not working...

I have edited the plist to be in the same voice (using 10.5.5 So whatever voice that is in using kextstat). My device ID was already in there (10CE80806). I have a gateway sx2800 running ideneb 10.5.5. I have tried loading with kexthelper, and pcwiz's and I got nothing.

The only item showing up under system ->network is firewire. Is there a chance I have another kext blocking this (no other network ones that I can tell) Is there some other kext htat this guy depends on that I should have loaded? I have updated my extensions boot cache, so it is at least trying to laod the correct one.

Any ideas?

#162
Rushabh

Rushabh

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts
  • Gender:Male
  • Location:India
Hi everyone,
I got the ethernet working finally using sleepwatcher but the problem is ethernet only wakes the first time i wake my computer. After the first sleep and wake ethernet is unusable. Anyone know what causes sleepwatcher to only run once?

Also, if i buy a usb to ethernet adapter, will it work fine after sleep?

Thanks!

Snow Leopard 10.6.1
Intel DG33FB
Core 2 Duo
2 GB RAM
Nvidia 8500GT 512MB

#163
Chris Ross

Chris Ross

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

My SL can regconize the ethernet card but it can not receive IP from DHCP server :(


Similarly, I see the device, but I *can* get packets from DHCP. However name service seems not to work. If I use host(1), I get answers, but when I use the system name resolution, it falls completely, so Network Diagnostic shows the Internet as unavailable, and no programs work.

I'm running vanilla 10.6.0 on a Dell Optiplex 755, Intel 82566MM, according to what I'm seeing everywhere incl. under linux.

Thanks.

#164
embedded123

embedded123

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts

After around one month part-time work. I ported the Linux e1000e driver to my Laptop (Lenovo T61p) running Hackintocsh Mac OS X (Leopard 10.5.3).

Detail in my blog http://techresearchinfo.blogspot.com.

Guijin Ding



#165
iccccceman

iccccceman

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Sorry guys but I am missing what exactly I am replacing in the plist or in my kextstat. I have both open but can't figure out what I am supposed to be changing, I've read through everything but am still unclear of what I am changing. Thanks so much.

Edit: iDeneb had the drivers on there but now the only thing showing up under network is firewire. Any ideas?

#166
j1978

j1978

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Hello

I have installed iAtkos v7 on my pc but i cant for the life of me get the Ethernet card to be recognized.
I followed all the instructions i could find on these forums to no avail.
i have the Intel Dx58so motherboard.
if anyone can post step by step detailed instructions i would be very grateful.

I haver downloaded the kext file.
I have tried updating the p file (not sure i did that right)
i used kexthelper and pcwiz.
nothing!
The only network device visible is a firewire card...

Please help! total mac noob here.

Thanks


Jay

#167
apexio

apexio

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Here's the latest version from Google Code compiled for 10.5.x. Works after multiple sleep/wakeups, including DHCP. I'm using iDeneb 1.4 (10.5.6) on a DG35EC with Q6600s.

Instructions:
Unzip the .zip, open Terminal.app and cd to the directory in which Intel82566MM.kext resides.
Then:
cp -r Intel82566MM.kext /System/Library/Extensions/
chmod -R 755 /System/Library/Extensions/Intel82566MM.kext
chown -R root:wheel /System/Library/Extensions/Intel82566MM.kext
rm -rf /System/Library/Extensions.kext
rm -rf /System/Library/Extensions.mkext
rm -rf /System/Library/Caches/*

Test with:
kextload /System/Library/Extensions/Intel82566MM.kext
kextunload /System/Library/Extensions/Intel82566MM.kext

Could also be installed with kext helper or OSX86Tools.

Attached Files



#168
asifkhan

asifkhan

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

I have a 82566DC but does not work ... I just change only OSBundleLibrary or also the DEVICE ID 0x294c8086?
please help me!!!



#169
hockeyman96

hockeyman96

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts
Worked for me with DQ965GF using 10.5.2. Thanks!!

#170
obsidian23

obsidian23

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
Here is the latest version compiled for Snow Leopard (I haven't tested if the above version for Leopard works under Snow).

Attached Files



#171
smoothdvd

smoothdvd

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts
I have Dell Optiplex 760 with Intel82567LM, Snow Leopard 10.6 64bit, Which version is working and how to install it?
I tried kexthelp to install, but it not working.

#172
quietguy

quietguy

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

Here is the latest version compiled for Snow Leopard (I haven't tested if the above version for Leopard works under Snow).



It is still not working with 82566Dm (optiplex755) in 64bit mode (half working, ip address and no host resolution).

#173
SOrrentoid

SOrrentoid

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
  • Gender:Male

Here is the latest version compiled for Snow Leopard (I haven't tested if the above version for Leopard works under Snow).


===========================================
Correction: In the original post there was a mistake about Snow Leopard version used to compile and test.
The proper version is 10.6 retail DVD.
===========================================

I have Intel® 82566DC network on-board card in my Intel DG965SS motherboard.

None of the drivers recompiled for Snow Leopard and posted here or elsewhere on the internet worked for me (they would install and nothing would happen, console showing dependency errors upon attempting to load the kext).

So, finally I was able to recompile one myself and it installed and found my card successfully on my Snow Leopard 10.6 (retail edition).

The Info.plist in this package is also updated to support Intel® 82566DC card and has the updated dependencies in Info.plist under OSBundledLibraries.

Additional note:
Unlike in Leopard, there was no notification of card being detected after using KextHelper immediately or even after reboot. But going to System Preferences->Network confirmed it was found.

Attached File  Intel82566MM.kext.zip   118.36KB   282 downloads

#174
phetoko

phetoko

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hi, im Ariel from argentina, can u help me to fix the trouble with my onboard Lan INTEL 82566? i put the kext on the Extensions Folder but no found, my mother is a INTEL DQ35MP and i have a Leopard 10.5.5 runing well but only need the LAN driver. and my Inglish is not very nice...

thanks...



arielsierra_sp@hotmail.com

#175
remus25

remus25

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
how can i install the driver ? i paste to the System\Library\Extensions\Intel82566MM.kext

and change the permission to read&write login user ? but i dont see the network

#176
Heywood Floyd

Heywood Floyd

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hi everyone,

My 10.6.3 upgrade kicked my to 64bit, causing the 82566MM driver to stop working.

Instead of forcing 32bit I decided to try to recompile for 64bit. I seem to have been
successful.

I have added an ticket to the projects issue list on Google Code. It has both the diff
and a compiled kext attached. I hope this is helpful to someone:

http://code.google.c...ues/detail?id=6

Attached Files



#177
Smith@@™

Smith@@™

    InsanelyMac LOL

  • Retired
  • 2,928 posts
  • Gender:Male
  • Location:Somewhere over the rainbow...ITALIA!
  • Interests:Dark matter and dark energy. E basta. HD3000. E basta.

Hi everyone,

My 10.6.3 upgrade kicked my to 64bit, causing the 82566MM driver to stop working.

Instead of forcing 32bit I decided to try to recompile for 64bit. I seem to have been
successful.

I have added an ticket to the projects issue list on Google Code. It has both the diff
and a compiled kext attached. I hope this is helpful to someone:

http://code.google.c...ues/detail?id=6


It works great for my 82566DC in 64 bit mod on one of my hackintosh
:(

#178
durain

durain

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
Does any ever get Bridge Networking working under VMWare Fusion or Parallels Desktop. I am having issues with bridge networking.

Thanks for any help/advise.

#179
hnak

hnak

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 303 posts
  • Gender:Male

Does any ever get Bridge Networking working under VMWare Fusion or Parallels Desktop. I am having issues with bridge networking.

Thanks for any help/advise.


This extension doesn't handle promiscuous mode correctly, which is required for bridging.
Use AppleIntelE1000e.kext instead.

#180
Smith@@™

Smith@@™

    InsanelyMac LOL

  • Retired
  • 2,928 posts
  • Gender:Male
  • Location:Somewhere over the rainbow...ITALIA!
  • Interests:Dark matter and dark energy. E basta. HD3000. E basta.

Hi everyone,

My 10.6.3 upgrade kicked my to 64bit, causing the 82566MM driver to stop working.

Instead of forcing 32bit I decided to try to recompile for 64bit. I seem to have been
successful.

I have added an ticket to the projects issue list on Google Code. It has both the diff
and a compiled kext attached. I hope this is helpful to someone:

http://code.google.c...ues/detail?id=6


Hey, great work, listen me. Can you recompile for 64 bit the new kext (in attached) from realtek release this april 2010?
Link to discussion

Attached File  AppleRTL8169Ethernet.kext.zip   272.13KB   47 downloads





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy