Jump to content

[INSTALLING] 10.5.4 on a Lenovo S10


  • Please log in to reply
33 replies to this topic

#21
kome

kome

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
http://ipis-osx.wiki...s-ugly-stop-gap

finally the sound opens on S10.....!

One more issue killed

remaining

- LAN driver....not top of the agenda item though...I can live without it
- Fan does not auto-kick-in when the machine getting hot....
- Brightness control ; hotkeys
- Sleep, I still need to turn off AirPort before go to sleep....

otherwise, it is a perfect MAC b o o k ^ mini

#22
mega

mega

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 178 posts
I had to use a couple more kexts to get everything 100 %, still no auto fan, or eth, but everything else including sleep works with these kexts and iakios 4i



I keep a list of what I have to use to get it 100 %

Superhai's EHCISleepEnabler + clamshell for sleep/resume, genericCPUPowermangagement.kext & app for speedstep
http://superhai.com/darwin.html

stock 10.5.5 AppleSMBIOS.kext (for efi add on, fsb fix, about this mac fix)
appleSMBIOSEFI-28 for macbook air (fsb fix)
http://forum.insanel...howtopic=108606

appleACPIBatteryManager.kext (or package, using newest)
http://forum.insanel...howtopic=114105

AzaliaAudio.pkg.zip and quinnstorms script to enable sound or headphones, using
http://ipis-osx.wiki...ternal-speakers

audieee now
http://ipis-osx.wiki...s-ugly-stop-gap

bcm43xx_enabler.sh for built in wifi
http://forum.insanel...showtopic=51725

0x27ae.zip video drivers (new ones below, I have not tried)
http://www.s10lenovo....php?f=15&t=450

#23
purplelimo

purplelimo

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
I installed appleACPIBatteryManager.kext and the PowerManagement.bundle but my battery meter is still reading 0% when on battery power. Any ideas?

Also, fan seems to be running at medium speed all of the time. Any way to control the speed of the fan?

Ok, I restarted and the fan is now quiet again. One thing I did notice is that if I use sleep, any restarts afterwards would cause the machine to hang after system shutdown (doesn't restart on its own). I have to force power down then power up again. Anyone else notice the same thing?

#24
ToGaR

ToGaR

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts
  • Gender:Male
  • Location:Cincinnati, OH
I currently have everything working except for auto fan and ethernet. Sleep works, sound works, brightness works. Volume and brightness keys work. Battery display works. I was able to get additional info at s10lenovo.com. Let me research my kexts and I'll let you know what I used to get all of this working.

As for the fan, its speed is set during bootup by the bios. If I've been using the system for a while and it gets hot, if I reboot the fan will kick on high and stay that way until I restart again.

As for the lockup on shutdown after sleeping, I'm pretty sure I'm having the same problem. Sometimes it will restart and sometimes not. I never made the connection between sleep before, but it makes sense.

#25
purplelimo

purplelimo

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts

I currently have everything working except for auto fan and ethernet. Sleep works, sound works, brightness works. Volume and brightness keys work. Battery display works. I was able to get additional info at s10lenovo.com. Let me research my kexts and I'll let you know what I used to get all of this working.


Would appreciate any help you can provide getting the battery meter working. Everything else works for me as well.

As for the fan, its speed is set during bootup by the bios. If I've been using the system for a while and it gets hot, if I reboot the fan will kick on high and stay that way until I restart again.


Ah, makes sense.


n/m now battery meter is working.

Before, when I used System Profiler->Power to look at my battery stats, it was showing fully charged capacity as 0, which is why the meter was broken. Now after a few reboots, it is reading a correct value. Maybe my recent restarts and battery fully charging did the trick. Not sure the exact sequence there...

#26
MyRightEye

MyRightEye

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts

3. Customize the setup and checking off +stock kernel, +SATA and +intel GMA950.



Can you drastically expand on this please. I have iATKOS 5 and I can not get a working install.

Much thanks.

#27
MyRightEye

MyRightEye

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts

I installed msiwindosx. Installed the wifi driver. updated to 10.5.5 then used kext helper to install miglo's kexts which are available here ---> http://www.mediafire...2db6fb9a8902bda

Post #1 pretty much sums up the process.

[Update] After installing the kexts, be sure to repair your permissions and upon the first reboot, hit F8 at the Darwin prompt, type -F, hit enter. Everything should work nicely afterward.

Hmm... i had WiFI working until I installed those kext's of yours. Any idea what killed it?

#28
MyRightEye

MyRightEye

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
This morning the USB ports on my S10 stopped working. They are still supplying some power, but nothing will connect at all. Anyone encountered this?

#29
Alex Castro

Alex Castro

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
  • Gender:Male
  • Location:Montreal, Quebec
  • Interests:ASUS P5K-E, Core2Duo E8400, 2x2G Kingstone 800Mhz 6400, <br />MSI NE8800GT , Dell 2009W...
Is there Mic works ?

#30
loko__loko

loko__loko

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
hi, newbie here.


i used msiwindosx.iso 10.5.4
when i updated to 10.5.5 or 10.5.6 the keyboard and trackpad wont work
currently no sound even after using the audiee..... will try this "Install Apple Developer Tool"
no mic (i think)
wont sleep... will try the Superhai's EHCISleepEnabler + clamshell for sleep/resume, genericCPUPowermangagement.kext & app for speedstep
http://superhai.com/darwin.html again w/c im not sure w/c file.. i cannot find it.

btw, can we install 2gig ram to become 2.5gig? or the 1.5gig is the max? thanks

#31
Sugar Cone

Sugar Cone

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts

btw, can we install 2gig ram to become 2.5gig? or the 1.5gig is the max? thanks


2GB RAM is the maximum. If you install a 2GB stick you will have 2.5GB but the S10 will only utilize 2GB.

I was wondering about the sleep kexts too since the names stated arent listed.. But I think the kext you want is "VoodooUSBEHCI". I say this based solely on the fact that it has EHCI in the title.



Any clarification on which kexts to grab from /darwin would be appreciated.

#32
digdugbug

digdugbug

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

2GB RAM is the maximum. If you install a 2GB stick you will have 2.5GB but the S10 will only utilize 2GB.


This is not true with my hardware. I have a 2GB stick, the BIOS says 2GB when it boots but OSX sees the whole thing.

Activity Monitor, System Profiler all report 2.5GB

The S10 is a great little mac. Now if external video functioned I would be really stoked.

/Digdugbug

#33
evereste

evereste

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

Here is a quick and simple guide to installing Leopard 10.5.4 on the Lenovo S10 netbook. Things that work: Video (with QE/CI), Wifi, Sleep, and webcam.

What does NOT currently work: LAN(BCM5906), Sound (ALC269)

I used the iAtkos 4i distrib, since its my favorite. I'm sure others will work with minor modifications.

0. Make sure to have these files handy on a jumpdrive or something:
a. KEXT installer - http://www.cheetha.n...r/Software.html
b. Go to Superhai's page @ http://superhai.com/darwin.html
and grab EHCISleepEnabler.kext and ClamshellDisplay.kext
c. for Video - http://windosx.wikis.../Install Tweeks
d. for Wifi - http://forum.insanel...showtopic=51725
make sure to get the bcm43xx enabler 0.5.1pre.sh.zip file
1. Make sure to boot from the DVD.
2. Go to diskutils and partition your drive to MacOS+journeled.
3. Customize the setup and checking off +stock kernel, +SATA and +intel GMA950.
4. Wait 20-30mins.
5. When you are logged in and on the desktop, run the KEXT helper and install the video kexts and superhai's 2 kext. Make sure to follow superhai's instructions for installation of the EHCISleepEnabler.kext.
6. Follow the Wifi instructions to install the bcm wifi script.
7. Profit!!

I hope this helps some of you. I will clean this up and make it more concise as I find time.

Do I check off (remove) the Kexts listed on 3.? Bit confused...

#34
SouthTxTek

SouthTxTek

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
I have been able to get 10.5.8 working on my Lenovo s10. Airport works. The Wi-Fi card shows up as an Ericson F3507g. Haven't quite gotten that to work yet. Sound is another issue. In iTunes I can play sound through the Airport Express speakers just fine. But nothing from the built in speakers. I've installed AzaliaAudio and Audieee and set Audieee to internal speakers but still no sound.

m

PS Thanks to everyone for all your input on this. The 10" MacBook is blowing minds around here!!!!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy