Jump to content

TSC sync XNU patch


  • Please log in to reply
211 replies to this topic

#161
AlexD.

AlexD.

    InsanelyMac Protégé

  • Members
  • PipPip
  • 73 posts
  • Gender:Male
  • Location:Moscow

Thank you...
... By the way - you helped - thank you for that. You pointed me to the working Ethernet kext, which I can load from either boot-132 or Chameleon, and also works on my D630.

You're welcome! Ethernet i patched myself according the information found here. Thanks to all guys involved...
I like D620, it's almost perfect. :) That's why i want to make it 99% working. :thumbsup_anim:

With minor modification, I think it will work for D620 and D630 with NVIDIA graphics, not that you seem to need it.

For nVidia graphics that's very simple with the new Cameleon RC2.
You need to remove all GFX strings from boot.plist AND remove all injectors; then put autodetection flag: GraphicsEnabler=Yes
For me this works perfectly.

Sounds like you've got things under control. Now with Dual core support for 10.5.8, it's a beautiful thing.

Not everything, unfortunately. :thumbsup_anim:
One thing more I want badly: to figure out how to enable AHCI. I know D620 supports this. But Dell decided to strip the switch from the BIOS (obviously because of peoples' complains about crashing Windows after they switch to AHCI to cut down service-calls amount :rolleyes:)

I'll let You know if this succeeds.
:lol:

#162
leppy700m

leppy700m

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 373 posts

Not everything, unfortunately. :D
One thing more I want badly: to figure out how to enable AHCI. I know D620 supports this. But Dell decided to strip the switch from the BIOS (obviously because of peoples' complains about crashing Windows after they switch to AHCI to cut down service-calls amount ;))

I'll let You know if this succeeds.
:)


I noticed that myself. Although OS X sees the HD as a SATA device, the protocol used is ATA. On my D630, there's a switch in the BIOS, and I found a thread that showed my how to load the Intel ACHI drivers in windows post install (registry editing and all that). That made dual doot with the D630 nice. No such switch on the D620. It's a very minor thing, really. I don't know how much speed would really be gained with full AHCI support.

THe GMA950 graphics on the D620 aren't the best. I think that the Dell GMA950 implementation is the reason that sleep doesn't work right. And in order to use the internal display with hardware acceleration, a kext from Tiger is needed which causes some small artifacts. I can get correct resolution but no hardware acceleration with a custom DSDT file and an EFI string, but not full EFI support. I am seriously thinking of replacing the motherboard with one of the NVIDIA boards from E-bay to be rid of these issues.

Anyway, I realize we are off topic here, but you're impossible to send PMs to with your name displayed as it is.

#163
AlexD.

AlexD.

    InsanelyMac Protégé

  • Members
  • PipPip
  • 73 posts
  • Gender:Male
  • Location:Moscow

Anyway, I realize we are off topic here, but you're impossible to send PMs to with your name displayed as it is.

You're right. This is not the right place for discussing our laptops.
Let's move to PMs. I'll change my nick (strange, but it worked before).

#164
liaodan

liaodan

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
Please make a SNOW LEOPARD(432) can be used for th kernel, thank you

#165
macxso

macxso

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

Description: read the topic's title/description.

The patch introduces a new boot arg; tscsync.

All credits goes to OUI


Hello all,

first, thanks to OUI, Kassi, cosmot1 for this work.

On a Dell 9400, I installed 10.5.3 Kalyway with 9.3 tscsync patched kernel from this thread,
took off cpu=1 and inserted -tscsync instead.

Now I have 2 cores but when screen saver kicks in, the flurring is not fluid, it is stuttering.

Speed is still 1ghz with "About this Mac" and "Sys profiler".

Using Xbench_1.3, I get ~50 for the cpu, quite similar to my G4 867Mhz.

Sound on video seems to be ok.

Something's wrong,
can someone help me to get this machine up to its top speed of 2ghz ?

Do I need some other patch like speedstep ?

Thanks in advance :)

Rob

Dell 9400 2Ghz, 2gb mem, OSX 10.5.3 kalyway, xp, Apple wifi card

#166
AlexD.

AlexD.

    InsanelyMac Protégé

  • Members
  • PipPip
  • 73 posts
  • Gender:Male
  • Location:Moscow

On a Dell 9400, I installed 10.5.3 Kalyway with 9.3 tscsync patched kernel from this thread,
took off cpu=1 and inserted -tscsync instead.


Try without this switch.

#167
macxso

macxso

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

Try without this switch.


Thanks,

pulled -tscsync flag

no change, screen saver still stuttering and bad xbench results....

I tried also with Flag

idehalt=0 - May stop stuttering, from:

http://www.insanelym...php/t58495.html

no good,

Xbench gives

total 34.96
CPU 41.33

Really bad ! :)

Any more suggestions I can try folks ?

Rob

EDIT

***************************************************

* I found the reason for the CPU 1GHZ LIMIT

***************************************************

The official Dell Power Supply, because of a broken wire inside the cable between the brick and the PC, could not use the third wire connected to the inner pin, to communicate with the PC, thus the PC BIOS would not allow max performance of the CPU and not charge the battery)

I repaired the cable and now the BIOS dialogues with the PC and it can put the CPU to 2 ghz.
and
it recharges the battery again, so it will last a bit more.

The Xbench now gives

total ~135
CPU ~140

The Screen saver is better but still shows a bit of a broken motion, I'll live with it for now.

#168
crystalprince

crystalprince

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Oh Plase Make a Snow Leopard (Retail) Kernel for Dell thanks... Or you can tech me how to make it..

#169
JaE-V

JaE-V

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 933 posts
  • Gender:Male
  • Location:Texas
Need kernel bad! There has to be a way to patch the dsdt to avoid the need for patched kernels. However i cant figure it out lol...my eyes are tired of research. Snow Leo of course.

#170
AlexD.

AlexD.

    InsanelyMac Protégé

  • Members
  • PipPip
  • 73 posts
  • Gender:Male
  • Location:Moscow
10.6 sources are up.
:D

Has anyone tried SL on Dell yet?
I will this weekend.

Oops...
Didn't noticed:

Dell Latitude D820
Intel Core 2 Duo T7600 2.33GHz, 4GB DDR2 667, 80GB SATA, Nvidia Quadro 120M/7400 Go, 15.4 WUXGA LCD

All running full retail 10.5.8 and Snow 10.6



#171
crystalprince

crystalprince

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts

10.6 sources are up.
:(

Has anyone tried SL on Dell yet?
I will this weekend.

Oops...
Didn't noticed:

yeah I has been install it but it only Cpus=1 even if the system profiler show us 2 core Look it‘s My Dell Latitude D820
Attached File  Mac10.jpg   50.39KB   29 downloads
Attached File  Mac10___6.jpg   30.1KB   19 downloads
Attached File  Mac106.jpg   49.74KB   18 downloads

Need kernel bad! There has to be a way to patch the dsdt to avoid the need for patched kernels. However i cant figure it out lol...my eyes are tired of research. Snow Leo of course.

Sorry I see you notice by yourself : full running 10.5.8 and 10.6 Could you tell me is it 2 core process running in 10.6?or if yet how can do it?

#172
sonotone

sonotone

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,151 posts
For now, there is no XNU sources for 10.6 on apple's opensouces web site, witch means no tsc patch.

#173
AlexD.

AlexD.

    InsanelyMac Protégé

  • Members
  • PipPip
  • 73 posts
  • Gender:Male
  • Location:Moscow

For now, there is no XNU sources for 10.6 on apple's opensouces web site, witch means no tsc patch.


Apple decided to tease OSx86 crowd...
:unsure:

#174
JaE-V

JaE-V

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 933 posts
  • Gender:Male
  • Location:Texas

yeah I has been install it but it only Cpus=1 even if the system profiler show us 2 core Look it€˜s My Dell Latitude D820
Attached File  Mac10.jpg   50.39KB   29 downloads
Attached File  Mac10___6.jpg   30.1KB   19 downloads
Attached File  Mac106.jpg   49.74KB   18 downloads


Sorry I see you notice by yourself š full running 10.5.8 and 10.6 Could you tell me is it 2 core process running in 10.6?or if yet how can do it?



No there is no two core process yet lol. Stutters like hell! Threw cpus=1 in my plist til future notice. I wish there was a way we could fix our dsdt.

And have you been able to get your ethernet to work yet?

#175
JaE-V

JaE-V

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 933 posts
  • Gender:Male
  • Location:Texas
Formatting my snow drive to use as an external til we get a damn kernel or fix lol

#176
Dispnt

Dispnt

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
Waiting patched kernel
hope it released soon :s

#177
paddyoquinn

paddyoquinn

    InsanelyMac Protégé

  • Members
  • PipPip
  • 71 posts
Considering the new kernel source code is now up, is there any chance we can see the TSU Sync pateced version soon?
Regards

#178
ryanodabees

ryanodabees

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
would love a tsc patched snow leopard kernel here as well or any reference on how to apply such a patch to the 10.6 snow leopard vanilla kernel using cpus=1 on a dell 9400 myself
Cheers

#179
TheGreatDeceiver

TheGreatDeceiver

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 862 posts
  • Location:Soederhof/Germany

Considering the new kernel source code is now up, is there any chance we can see the TSU Sync pateced version soon?
Regards

can you provide the link here quinn? thanks
can't wait to get my fingers on the patched kernel. I can't find the old instructions on how to patch it myself anymore....

everything working except cpus=2

#180
paddyoquinn

paddyoquinn

    InsanelyMac Protégé

  • Members
  • PipPip
  • 71 posts

can you provide the link here quinn? thanks
can't wait to get my fingers on the patched kernel. I can't find the old instructions on how to patch it myself anymore....

everything working except cpus=2



http://www.opensourc...456.1.26.tar.gz

theres a direct download to the file

heres the source repo
Hope it helps http://www.opensourc...e/mac-os-x-106/
Regards
Patrick





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy