Jump to content

HP 2710p almost operational on OSX


  • Please log in to reply
12 replies to this topic

#1
wuzzle

wuzzle

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Location:Canada
Greetings all, it's YAN (Yet another Newb) or shall we say, experimenter.

I managed to scarf a HP 2710p from work as it was acting terribly under XP, and while passable under Vista Business, I thought to muck about.

Tried to get it up using JaS 10.5.x with no luck. Then I tripped over Kalyway 10.5.2 and 10.5.3 update and its up most of the way without even trying.

Here's the lspci.txt
[codebox]00:00.0 Host bridge [0600]: Intel Corporation Mobile Memory Controller Hub [8086:2a00] (rev 0c)
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile Integrated Graphics Controller [8086:2a02] (rev 0c)
00:02.1 Display controller [0380]: Intel Corporation Mobile Integrated Graphics Controller [8086:2a03] (rev 0c)
00:03.0 Communication controller [0780]: Intel Corporation Mobile MEI Controller [8086:2a04] (rev 0c)
00:03.2 IDE interface [0101]: Intel Corporation Mobile PT IDER Controller [8086:2a06] (rev 0c)
00:03.3 Serial controller [0700]: Intel Corporation Mobile KT Controller [8086:2a07] (rev 0c)
00:19.0 Ethernet controller [0200]: Intel Corporation 82566MM Gigabit Network Connection [8086:1049] (rev 03)
00:1a.0 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Contoller #4 [8086:2834] (rev 03)
00:1a.1 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 [8086:2835] (rev 03)
00:1a.7 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 [8086:283a] (rev 03)
00:1b.0 Audio device [0403]: Intel Corporation 82801H (ICH8 Family) HD Audio Controller [8086:284b] (rev 03)
00:1c.0 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 [8086:283f] (rev 03)
00:1c.1 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 [8086:2841] (rev 03)
00:1c.2 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 [8086:2843] (rev 03)
00:1d.0 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 [8086:2830] (rev 03)
00:1d.1 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 [8086:2831] (rev 03)
00:1d.2 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 [8086:2832] (rev 03)
00:1d.7 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 [8086:2836] (rev 03)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev f3)
00:1f.0 ISA bridge [0601]: Intel Corporation Mobile LPC Interface Controller [8086:2811] (rev 03)
00:1f.1 IDE interface [0101]: Intel Corporation Mobile IDE Controller [8086:2850] (rev 03)
02:09.0 FireWire (IEEE 1394) [0c00]: Ricoh Co Ltd R5C832 IEEE 1394 Controller [1180:0832] (rev 05)
02:09.1 SD Host controller [0805]: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter [1180:0822] (rev 22)
02:09.2 System peripheral [0880]: Ricoh Co Ltd Unknown device [1180:0843] (rev 12)
[/codebox]

PROS: Happily, it shows correctly that it has a 1.2ghz Core 2 Duo and 2 gig of ram. The graphics come right up with full acceleration. Speed of Drive is what i'd expect considering it's one of those PATA half 2.5" drives.

CONS: no WIFI, no Ethernet (both unsupported Intel), there is no 'trackpad' but it has a trackeraser which works, but it seems like the acceleration is way out of whack and does a side step with every movement. No Sound. Webcam doesn't currently work with iUSBCam/macam, but we'll see :)

External devices: It is working well with my Microsoft Wheel Mouse Optical 1.1. It is working well with my Linksys USB200M v2.1. It worked well enough with my Transcend 2GB USB drive. When I plugged in my external usb 2.0 sata drive, it appeared on the screen but I couldn't click on anything after that. It basically screwed all USB at that point :(

I have e-bay'd a broadcom WIFI card to replace the Intel one.

Overall a very nice start, and not one complaint from me. With a little more elbow grease I hope to make this a viable little machine!

#2
blank

blank

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
I have this every same laptop. Same Pros and Cons as you but with 2 exceptions.

1, The Sound will work with the SoundMax driver on these forums. Although the microphone doesn't.
2, The Tablet works perfectly with TabletMagic.. http://forum.insanel...showtopic=43948. With the tablet I had a little trouble getting it recognised at first. I had to run the script a few times then run TabletMagic and kill the process from in there, then run the script again. It will eventually find the Tablet. One thing of note (that I had) is even without the script it recognised the Tablet on Serial port 1 but it did not work. After running the script numerous times, and killing the TabletMagic process etc, it did eventually add another serial device on Serial Port 0, that was the Tablet and it works great, using Automatic for selection doesn't work for me.

EDIT: The problem you are discribing with the thumb mouse can be fixed. I had that very same issue. If you go to the mouse settings set the sensitivity all the way to the lowest setting. This will fix it, and it doesn't seem to lower the sensitivity either.

I don't keep as up to date with this stuff as I should, but I was suprised that the X3100 graphics works out of the box too with 10.5.2, as rfom what I've read a lot of people seem to have problems with it.

#3
agnivarsh

agnivarsh

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Me three! Which version of osx are you guys using? (i noticed wuzzle say kalyway update - does that mean u installed jas and updated to kalyway or just installed kalyway 10.5.3?) I tried the iatkos 2 and it works pretty well. I installed azlea sound and it seems to have recognized it but i cant get any sound out. Can you link to the driver that worked for you?
The other issue i have is that the mouse pointer when using the track point is not very smooth. Is that what you fixed by lowering the sensitivity all the way?
wuzzle - which broadcom card did you order from ebay? I am interested in getting a broadcom 802.11n card that would work with this - any ideas?

I also had issues with the tabletmagic driver but it eventually worked. The main issue i still have with it is that calibration seems off. What settings are you using with the driver to make it work properly?

Does sleep/deep-sleep work for you guys? When I am running osx and close the lid - i notice that it doesnt really go into any low power state. Just drains the battery.

#4
wuzzle

wuzzle

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Location:Canada

Me three! Which version of osx are you guys using? (i noticed wuzzle say kalyway update - does that mean u installed jas and updated to kalyway or just installed kalyway 10.5.3?) I tried the iatkos 2 and it works pretty well. I installed azlea sound and it seems to have recognized it but i cant get any sound out. Can you link to the driver that worked for you?
The other issue i have is that the mouse pointer when using the track point is not very smooth. Is that what you fixed by lowering the sensitivity all the way?
wuzzle - which broadcom card did you order from ebay? I am interested in getting a broadcom 802.11n card that would work with this - any ideas?

I also had issues with the tabletmagic driver but it eventually worked. The main issue i still have with it is that calibration seems off. What settings are you using with the driver to make it work properly?

Does sleep/deep-sleep work for you guys? When I am running osx and close the lid - i notice that it doesnt really go into any low power state. Just drains the battery.


Kalyway 10.5.2 and then the Kalyway 10.5.3. I've been leery to try software update since its working 'for the most part'.

I too have the calibration way off for the tablet functions. At the moment, that is unusable for me.

I've yet to get sound working or showing as a loaded driver :(

I tend to just use an optical mouse instead

441090-001 Wireless LAN module 802.11b/g PCI card V6000 was the one i got. took a bit of wiggling to get it electrically connected. It should show in lspci as 10:00.0 Network controller: Broadcom Corporation BCM94311MCG wlan mini-PCI (rev 02)

Sleep is not working for me currently.

I also find half the time, the video doesn't come up. It shows as a garbled screen. I have to reboot a few times to correct it.

Having this issue and unsure if i have to remove some driver or what: Ideas anyone?
Jul 15 17:08:35 localhost kernel[0]: ACPI: System State [S0 S3 S4 S5] (S3)Jul 15 17:08:35 localhost kernel[0]: Extension "com.apple.driver.AppleACPIPlatform" has immediate dependencies on both com.apple.kernel and com.apple.kpi components; use only one style.Jul 15 17:08:35: --- last message repeated 2 times ---Jul 15 17:08:35 localhost kernel[0]: Starting AppleACPIPS2NubJul 15 17:08:35 localhost kernel[0]: Extension "com.apple.driver.AppleACPIPlatform" has immediate dependencies on both com.apple.kernel and com.apple.kpi components; use only one style.Jul 15 17:08:35 localhost kernel[0]: Found mouse PNP deviceJul 15 17:08:35 localhost kernel[0]: AppleACPIPS2Nub startup completeJul 15 17:08:35 localhost kernel[0]: mbinit: doneJul 15 17:08:35 localhost kernel[0]: Security auditing service presentJul 15 17:08:35 localhost kernel[0]: BSM auditing presentJul 15 17:08:35 localhost kernel[0]: Class "AppleEHCIedMemoryBlock" is duplicateJul 15 17:08:35 localhost kernel[0]: Duplicate classJul 15 17:08:36 localhost kernel[0]: kmod_control/start failed for com.orByte.driver.PCGenUSBEHCI; destroying kmodJul 15 17:08:36 localhost kernel[0]: ^[[33mFailed to load extension com.orByte.driver.PCGenUSBEHCI.Jul 15 17:08:36 localhost kernel[0]: ^[[0mFrom path: "uuid", Jul 15 17:08:36 localhost kernel[0]: Waiting for boot volume with UUID FA939311-86FB-3B3F-9B1F-32CE2C1B28B8Jul 15 17:08:36 localhost kernel[0]: Waiting on IOProviderClassIOResourcesIOResourceMatchboot-uuid-mediaJul 15 17:08:36 localhost kernel[0]: Class "AppleEHCIedMemoryBlock" is duplicateJul 15 17:08:36 localhost kernel[0]: Duplicate classJul 15 17:08:36 localhost kernel[0]: kmod_control/start failed for com.orByte.driver.PCGenUSBEHCI; destroying kmodJul 15 17:08:36 localhost kernel[0]: ^[[33mFailed to load extension com.orByte.driver.PCGenUSBEHCI.


#5
wuzzle

wuzzle

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Location:Canada

Me three! Which version of osx are you guys using? (i noticed wuzzle say kalyway update - does that mean u installed jas and updated to kalyway or just installed kalyway 10.5.3?) I tried the iatkos 2 and it works pretty well. I installed azlea sound and it seems to have recognized it but i cant get any sound out. Can you link to the driver that worked for you?
The other issue i have is that the mouse pointer when using the track point is not very smooth. Is that what you fixed by lowering the sensitivity all the way?
wuzzle - which broadcom card did you order from ebay? I am interested in getting a broadcom 802.11n card that would work with this - any ideas?

I also had issues with the tabletmagic driver but it eventually worked. The main issue i still have with it is that calibration seems off. What settings are you using with the driver to make it work properly?

Does sleep/deep-sleep work for you guys? When I am running osx and close the lid - i notice that it doesnt really go into any low power state. Just drains the battery.


I paused on the laptop while I built up a new desktop which is ripping fast. (my signature)

Now I'm rebuilding the 2910p with JaS' latest 10.5.4 cd. still figuring out what should and shouldn't be checked for the install. Much better support for the video now, no glitching. This time out I want to figure out the power management, sleep, etc.

*update* I worked on the machine and got the keyboard and sound working under JaS' latest. Now for the rest :)

#6
Wenle Z.

Wenle Z.

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 254 posts
  • Gender:Male
i have a 2510p, which is similar to 2710p. Everything works beside LAN, sleep, and sound.

#7
viper17790

viper17790

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Does anyone have any resources on installing the new broadcom wireless card? I'm picking up a 2710p in a few days.

#8
stickman

stickman

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Any news on this laptop?

Have you guys made any improvements?

#9
Jurip

Jurip

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
I have got HP 2710p week ago.
So what…

Installation iDeneb 1.3 Leopard 10.5.5
Video: was problem on first start (black screen with mouse cursor) I remove AppleIntelGDAX100.kext and now all worked correctly…
LAN: detected but not checked
WiFi: Not
I was tray to install Dell DW1490, but receive – 104 unsupported wireless card…

Sound: detected but no sound
WebCam: detected but no picture (green background)

No sleep…

Somebody have solutions for this...

#10
viper17790

viper17790

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Updated: Used Kalyway 10.5.2

Wifi works with the Ebay-ed broadcom card

Sound still isn't working with the SoundMax driver.

Anyone get sound to work?

#11
stickman

stickman

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
What's the exact model of the card you installed? It's interesting since 2710p has wifi cards blacklisted and if you say this one worked for you...

#12
wuzzle

wuzzle

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Location:Canada

What's the exact model of the card you installed? It's interesting since 2710p has wifi cards blacklisted and if you say this one worked for you...


"441090-001 Wireless LAN module 802.11b/g PCI card V6000 was the one i got. took a bit of wiggling to get it electrically connected. It should show in lspci as 10:00.0 Network controller: Broadcom Corporation BCM94311MCG wlan mini-PCI (rev 02)"

I no longer have the machine due to company closing and taking all equipment back.

@ viper17790 re: sound

I did have sound working, If memory serves, I booted into a linux flavour and queried the sound device to find out what ADXXXX codec it was using.

Digging through old backups, thus far I find this lspci query of the machine:

00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)
		Subsystem: Hewlett-Packard Company Unknown device 30c8
		Flags: bus master, fast devsel, latency 0
		Capabilities: [e0] Vendor Specific Information
 
	 00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c) (prog-if 00 [VGA])
		Subsystem: Hewlett-Packard Company Unknown device 30c8
		Flags: bus master, fast devsel, latency 0, IRQ 16
		Memory at e4400000 (64-bit, non-prefetchable) [size=1M]
		Memory at d0000000 (64-bit, prefetchable) [size=256M]
		I/O ports at 4000 [size=8]
		Capabilities: [90] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
		Capabilities: [d0] Power Management version 3
 
	 00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
		Subsystem: Hewlett-Packard Company Unknown device 30c8
		Flags: bus master, fast devsel, latency 0
		Memory at e4500000 (64-bit, non-prefetchable) [size=1M]
		Capabilities: [d0] Power Management version 3
 
	 00:03.0 Communication controller: Intel Corporation Mobile PM965/GM965 MEI Controller (rev 0c)
		Subsystem: Hewlett-Packard Company Unknown device 30c8
		Flags: bus master, fast devsel, latency 0, IRQ 255
		Memory at e4600000 (64-bit, non-prefetchable) [size=16]
		Capabilities: [50] Power Management version 3
		Capabilities: [8c] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
 
	 00:03.2 IDE interface: Intel Corporation Mobile PM965/GM965 PT IDER Controller (rev 0c) (prog-if 85 [Master SecO PriO])
		Subsystem: Hewlett-Packard Company Unknown device 30c8
		Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 11
		I/O ports at 4008 [size=8]
		I/O ports at 4010 [size=4]
		I/O ports at 4018 [size=8]
		I/O ports at 4020 [size=4]
		I/O ports at 4030 [size=16]
		Capabilities: [c8] Power Management version 3
		Capabilities: [d0] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
 
	 00:03.3 Serial controller: Intel Corporation Mobile PM965/GM965 KT Controller (rev 0c) (prog-if 02 [16550])
		Subsystem: Hewlett-Packard Company Unknown device 30c8
		Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 17
		I/O ports at 4040 [size=8]
		Memory at e4601000 (32-bit, non-prefetchable) [size=4K]
		Capabilities: [c8] Power Management version 3
		Capabilities: [d0] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
 
	 00:19.0 Ethernet controller: Intel Corporation 82566MM Gigabit Network Connection (rev 03)
		Subsystem: Hewlett-Packard Company Unknown device 30c8
		Flags: bus master, fast devsel, latency 0, IRQ 20
		Memory at e4620000 (32-bit, non-prefetchable) [size=128K]
		Memory at e4640000 (32-bit, non-prefetchable) [size=4K]
		I/O ports at 4060 [size=32]
		Capabilities: [c8] Power Management version 2
		Capabilities: [d0] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
 
	 00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Contoller #4 (rev 03) (prog-if 00 [UHCI])
		Subsystem: Hewlett-Packard Company Unknown device 30c8
		Flags: bus master, medium devsel, latency 0, IRQ 16
		I/O ports at 4080 [size=32]
 
	 00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03) (prog-if 00 [UHCI])
		Subsystem: Hewlett-Packard Company Unknown device 30c8
		Flags: bus master, medium devsel, latency 0, IRQ 17
		I/O ports at 40a0 [size=32]
 
	 00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03) (prog-if 20 [EHCI])
		Subsystem: Hewlett-Packard Company Unknown device 30c8
		Flags: bus master, medium devsel, latency 0, IRQ 18
		Memory at e4641000 (32-bit, non-prefetchable) [size=1K]
		Capabilities: [50] Power Management version 2
		Capabilities: [58] Debug port
 
	 00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
		Subsystem: Hewlett-Packard Company Unknown device 30c8
		Flags: bus master, fast devsel, latency 0, IRQ 17
		Memory at e4644000 (64-bit, non-prefetchable) [size=16K]
		Capabilities: [50] Power Management version 2
		Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
		Capabilities: [70] Express Unknown type IRQ 0
 
	 00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03) (prog-if 00 [Normal decode])
		Flags: bus master, fast devsel, latency 0
		Bus: primary=00, secondary=08, subordinate=08, sec-latency=0
		Capabilities: [40] Express Root Port (Slot-) IRQ 0
		Capabilities: [80] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
		Capabilities: [90] Subsystem: Hewlett-Packard Company Unknown device 30c8
		Capabilities: [a0] Power Management version 2
 
	 00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 03) (prog-if 00 [Normal decode])
		Flags: bus master, fast devsel, latency 0
		Bus: primary=00, secondary=10, subordinate=10, sec-latency=0
		Memory behind bridge: e4000000-e40fffff
		Capabilities: [40] Express Root Port (Slot-) IRQ 0
		Capabilities: [80] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
		Capabilities: [90] Subsystem: Hewlett-Packard Company Unknown device 30c8
		Capabilities: [a0] Power Management version 2
 
	 00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 (rev 03) (prog-if 00 [Normal decode])
		Flags: bus master, fast devsel, latency 0
		Bus: primary=00, secondary=18, subordinate=18, sec-latency=0
		I/O behind bridge: 00002000-00003fff
		Memory behind bridge: e0000000-e3ffffff
		Capabilities: [40] Express Root Port (Slot+) IRQ 0
		Capabilities: [80] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
		Capabilities: [90] Subsystem: Hewlett-Packard Company Unknown device 30c8
		Capabilities: [a0] Power Management version 2
 
	 00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03) (prog-if 00 [UHCI])
		Subsystem: Hewlett-Packard Company Unknown device 30c8
		Flags: bus master, medium devsel, latency 0, IRQ 19
		I/O ports at 40c0 [size=32]
 
	 00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03) (prog-if 00 [UHCI])
		Subsystem: Hewlett-Packard Company Unknown device 30c8
		Flags: bus master, medium devsel, latency 0, IRQ 20
		I/O ports at 40e0 [size=32]
 
	 00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03) (prog-if 00 [UHCI])
		Subsystem: Hewlett-Packard Company Unknown device 30c8
		Flags: bus master, medium devsel, latency 0, IRQ 18
		I/O ports at 4100 [size=32]
 
	 00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03) (prog-if 20 [EHCI])
		Subsystem: Hewlett-Packard Company Unknown device 30c8
		Flags: bus master, medium devsel, latency 0, IRQ 19
		Memory at e4648000 (32-bit, non-prefetchable) [size=1K]
		Capabilities: [50] Power Management version 2
		Capabilities: [58] Debug port
 
	 00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3) (prog-if 01 [Subtractive decode])
		Flags: bus master, fast devsel, latency 0
		Bus: primary=00, secondary=02, subordinate=02, sec-latency=32
		Memory behind bridge: e4100000-e43fffff
		Capabilities: [50] Subsystem: Hewlett-Packard Company Unknown device 30c8
 
	 00:1f.0 ISA bridge: Intel Corporation 82801HBM (ICH8M-E) LPC Interface Controller (rev 03)
		Subsystem: Hewlett-Packard Company Unknown device 30c8
		Flags: bus master, medium devsel, latency 0
		Capabilities: [e0] Vendor Specific Information
 
	 00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 03) (prog-if 8a [Master SecP PriP])
		Subsystem: Hewlett-Packard Company Unknown device 30c8
		Flags: bus master, medium devsel, latency 0, IRQ 16
		I/O ports at 01f0 [size=8]
		I/O ports at 03f4 [size=1]
		I/O ports at 0170 [size=8]
		I/O ports at 0374 [size=1]
		I/O ports at 4120 [size=16]
 
	 02:09.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05) (prog-if 10 [OHCI])
		Subsystem: Hewlett-Packard Company Unknown device 30c8
		Flags: bus master, medium devsel, latency 64, IRQ 19
		Memory at e4100000 (32-bit, non-prefetchable) [size=2K]
		Capabilities: [dc] Power Management version 2
 
	 02:09.1 Generic system peripheral [0805]: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)
		Subsystem: Hewlett-Packard Company Unknown device 30c8
		Flags: bus master, medium devsel, latency 64, IRQ 20
		Memory at e4101000 (32-bit, non-prefetchable) [size=256]
		Capabilities: [80] Power Management version 2
 
	 02:09.2 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev 12)
		Subsystem: Hewlett-Packard Company Unknown device 30c8
		Flags: bus master, medium devsel, latency 64, IRQ 5
		Memory at e4102000 (32-bit, non-prefetchable) [size=256]
		Capabilities: [80] Power Management version 2
 
	 10:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN Network Connection (rev 61)
		Subsystem: Intel Corporation Unknown device 1000
		Flags: bus master, fast devsel, latency 0, IRQ 17
		Memory at e4000000 (64-bit, non-prefetchable) [size=8K]
		Capabilities: [c8] Power Management version 3
		Capabilities: [d0] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
		Capabilities: [e0] Express Endpoint IRQ 0

The sound in the HP2710p is:

Audio Audio Output Sound card Audio Codec AD1981HD Compliant Standards Sound Blaster Pro, High Definition Audio Audio Input Microphone

#13
stickman

stickman

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

"441090-001 Wireless LAN module 802.11b/g PCI card V6000 was the one i got. took a bit of wiggling to get it electrically connected. It should show in lspci as 10:00.0 Network controller: Broadcom Corporation BCM94311MCG wlan mini-PCI (rev 02)"


You mean it was hard because of the short cables I suppose... I also had that problem when I bought the 3G card, it took a few minutes to get everything in place.

It's good to know there's one card non-blacklisted that works. Thanks for the heads up!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy