Jump to content

Release for Toshiba Satellite P10x users: modded BIOS to try and activate Conexant sound chip


  • Please log in to reply
369 replies to this topic

#361
BugsB

BugsB

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,513 posts
  • Gender:Male
  • Location:Kauai, Hawai'i
@ nyu1985 (or anybody else): since you have a P100-316 with a 64 bit Core 2 Duo: should/can I swap my P100's Core Duo (32bit = not fully Lion compatible) with a (specific) Core 2 Duo (64bit = fully Lion compatible), best the 2GHz kind Toshi utilizes in yours? The Intel 945PM (Mobile/Express) chipset is obviously capable of 64 bit (see here and here), and so seems the all-in-one P10x BIOS (which is the same for all of us, right, no matter if we run a 32 or 64 bit Toshi P10x Satellites)!?

The socket in my P100-102 mobo is PGA socket-M, Micro-FCBGA (FCPGA6) which the T7200 2GHz Core 2 Duo DOES fit in.

What I am uncertain about right now is voltage requirement (current T2400 1.83GHz Core Duo vs. T7200 2GHz Core 2 Duo). I wonder if the specific mobo in my P100-105 would support a (specific) Core 2 Duo in the first place .....

I have my Toshi disassembled right now (because the 7600Go burnt through) and am about to put it back together (with a refurbished mobo I could get hold of), so if there really was compatibility for a Core Duo --> Core 2 Duo upgrade, this would be the perfect time. The 1.83GHz has been running extremely silent and cool, so I don't have the slightest doubt that the 2x170MHz more would cause any temp. prob.

Competent input greatly appreciated :P

Cheers,
Bugs

UPDATE: now look-a-there: here's somebody who successfully upgraded his Notebook's Core Duo T2400 1.83GHz (same as mine) with the mobile Core 2 Duo T7200 2GHz which is used in at least three of the Toshiba Satellite P10x Laptops (making them 64 bit compatible). That guy is now running Window 64 very happily (on his Dell Inspiron E1505). I am getting more positive about this. Opinions?

#362
BugsB

BugsB

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,513 posts
  • Gender:Male
  • Location:Kauai, Hawai'i
anybody still alive in this thread, or would I need to visit most of you on the graveyard (or at least in the nursing home for the elderly)?

Well anyway I scored a Toshi P105 w. a 64bit 2GHz Core2Duo for a few $$, ventured ahead and installed Lion on it, and behold, EVERYTHING is working - apart from the old culprit, no sound after wake-up from sleep (when using AppleHDA - no idea if there is sound after sleep via the ole Azalia kext 'cause I do need the mike in) ....

So I was wondering if there is still anybody here w. a P10x who is using sleep mode AND still has working sound after sleep w. AppleHDA?

(VoodooHDA still causes KP with the Toshi Conexant Waikiki as always ..)

Thanks,
Bugs

#363
nicheljd

nicheljd

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
Hi BugsB, I'm going to resurrect my old toshiba, very interesting!!! this week I will change the prosesador and see what happens, and actulizare AppleHDA with a newer version, and I'll tell you, a greeting and bye.....

#364
BugsB

BugsB

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,513 posts
  • Gender:Male
  • Location:Kauai, Hawai'i
Due to popular request: my P10x Lion pack. I set version to 1.0.

ReadMe.txt:

1. read and apply BIOS.txt

2. u need 2 create ur own DSDT 4 sound 2 work

3. I only have two GMA950 Toshis P10x working right now. Extra.kext includes the good ole NVEnabler which hopefully still works in Lion. If not, remove and use

<key>GraphicsEnabler</key>
<string>Yes</string>

in org.chameleon.Boot.plist

4. No sound after wake-up from sleep

5. Battery Meter would require DSDT patching

BugsB
2012-08-09
10.7.4
Chameleon 2.1 rev. 2033

AppleHDA is still clubber77's contribution ..

Enjoy :)

I prepped my Toshis up w. new high-res LCD panels, fastest CPU, 7200 HDD, and am very happy.

PS: re. Mountain Lion (64 bit only unless trying to use 32 bit h'tosh community kernel + old 32 bit Finder + all sorts of patchworked XTs = not my cup of Tea):

I don't have any working Nvidia P10x Toshi at hand right now, only two GMA950's for which there is no good 64 bit driver pack (only the buggy 10.6.2 one Apple decommissioned). Contained AppleHDA is old and only 32 bit (or the HDAEnabler is - dunno). If u have a Nvidia Toshi P10x, then for ML you'd have to delete

<key>arch</key>
<string>i386</string>

from org.chameleon.Boot.plist and see if you can get sound and grfx to work.

Attached Files



#365
tone602

tone602

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
Hi everyone,

I've tried the bios for p105-s6024 from the op page but still cant get speakers working with SL 10.6.6i from Hazard. I can get the Azilia kext to recognize the HD Audio Output in sound prefs but theres no sound. I tried to input the deviceid in the kext and still no go. I do not have a DSDT for this laptop as i cant get past the errors when i tried to compile the aml file (if anyone has a DSDT for this model could send me... ps i think i have an after market DVDRW drive installed).

With the most current bios 4.70 I can boot into both osx and win8 and have sound working on windows. Is there something else I should try?

Update: I got my dsdt finally past the complile errors but still no sound with Azailia kext. Can someone look at the dsdt fike and tell me if im doing something wrong??
patched it with Dsdt patcher and patches from the ich8 patches but still no sound using stock Phoenix 4.70 bios. I will try flashing one of the modded bios from the op page and report back.

Update2: Still no success with getting sound to work. Tried the Bios 4.20 for p100 and DSDT edited with no errors and with different distros of os x. Currently im back on osx 10.6.6i from Hazzard with Win XP. Everthing is working still except Sound. In system profiler the sound has device id: 12.

Please someone help me if this thread is still alive.

Attached Files



#366
nyu1985

nyu1985

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 134 posts

Hi tone602,

 

You can find attached 3 dsdt.dsl with sound working.

 

The first one is the one I used as example, the second is only to make the sound working and the last contains sound and graphic card (7600 go).

 

I made its about 3 years ago so I don't exactly remember what I did but as far as I can see today ... well ... what I did wasn't really catholic but it works so I hope it will help.

Attached Files



#367
nyu1985

nyu1985

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 134 posts

Hi BugsB,

 

I saw your post only today, about 2 years late xD (I came back few weeks ago on the forum as I have upgraded my PCs).

 

As I can see, you already purchased a Core 2 Duo which make your P100 more compatible with Lion but as there is no kexts with 64 bits support for graphics, you still boot in 32 bit mode.

I was in the same boat so as I couldn't upgrade to ML, I stayed with SL (I never really appreciated Lion).

 

Actually, I gave my P100 to my cousin and right now I'm trying to install ML on my new G75VX.

 

Anyway, anyone who needs help can ask as I've kept the files that I used.



#368
BugsB

BugsB

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,513 posts
  • Gender:Male
  • Location:Kauai, Hawai'i

tone602,

 

1. which exact model do you have - also an p105-s6024, or a different one? In your sig I only see the Dell

 

2. is the attached DSDT original extracted from the Toshiba, without ANY alterations from you? That's what I'd need.

Hi everyone,

I've tried the bios for p105-s6024 from the op page but still cant get speakers working with SL 10.6.6i from Hazard. I can get the Azilia kext to recognize the HD Audio Output in sound prefs but theres no sound. I tried to input the deviceid in the kext and still no go. I do not have a DSDT for this laptop as i cant get past the errors when i tried to compile the aml file (if anyone has a DSDT for this model could send me... ps i think i have an after market DVDRW drive installed).

With the most current bios 4.70 I can boot into both osx and win8 and have sound working on windows. Is there something else I should try?

Update: I got my dsdt finally past the complile errors but still no sound with Azailia kext. Can someone look at the dsdt fike and tell me if im doing something wrong??
patched it with Dsdt patcher and patches from the ich8 patches but still no sound using stock Phoenix 4.70 bios. I will try flashing one of the modded bios from the op page and report back.

Update2: Still no success with getting sound to work. Tried the Bios 4.20 for p100 and DSDT edited with no errors and with different distros of os x. Currently im back on osx 10.6.6i from Hazzard with Win XP. Everthing is working still except Sound. In system profiler the sound has device id: 12.

Please someone help me if this thread is still alive.



#369
BugsB

BugsB

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,513 posts
  • Gender:Male
  • Location:Kauai, Hawai'i

nyu1985, great, thank you! As a matter of fact, the grfx + sound DSDT from your old P100-316 works for the P100 -109 PSPA3E-00N004S4 I scored for a few $$s (+ added a 3.33GHz C2D and a new anti-glare 1650 x 1050 hires LCD) which also has the Nvidia GeForce Go 7600. NVinject etc. proved not to really work in 10.7.5 anymore when plugging in a 2nd monitor, so your DSDT comes in very handy.

 

I made a diff patch with Chameleon Wiz and applied to my DSDT, but that did not result in a DSDT which worked as yours for my GeForce Go 7600.

 

I therefore attached my DSDT file with working sound patch already applied. Maybe you can point me into the right direction to integrate your 7600 patch which works for my P100 -109 into its DSDT?

 

Thanks for sticking around ;),

Bugs

 

PS: the node or Layout IDs in my Conexant here must be a bit different because regardless of which DSDT and Conexant Waikik AppleHDA I choose, only line in for input, no Mic.

Attached Files



#370
nyu1985

nyu1985

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 134 posts

Hi Bugs,

 

Sorry for the late answer. I am digging up the topic but do you steal need support ?

 

I maybe will have a few time to help you this week-end but I already can tell you that you can find "Go 7600" informations in the DSDT that I posted so you can try to find it and add it into your DSDT.

 

Keep in touch.







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy