Jump to content

Oblivion 100% Playble


  • Please log in to reply
94 replies to this topic

#41
sheep4wheat

sheep4wheat

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Any more luck on the collision volume problem?

Here is my fix, not a great one, but it's more bearable than having NO collision sound.

change these values in the .ini

fDefaultEffectsVolume=0.9000
fDefaultFootVolume=0.8000
fDefaultVoiceVolume=2.0000
fDefaultMasterVolume=2.7000

And then turn down your mac's volume before starting the game.

What this does is bring up the volume of everything else in the game to match the rediculously loud collision noises. Then you just attenuate it all with the mac's master volume.

The in-game audio sliders can only max the values at 1. However, changing them in the ini allows you to go beyond 1.

#42
saerdric

saerdric

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hello there

Here is my problem : I've downloaded your app but i don't understand what to do of it...

Is it a launcher for Oblivion ? I don't find it anywhere so i suppose it is.

I do everything you explain, step by step, but i think i don't put your app where it has to be.

So, i can't play with mods because i can't launch the launcher ;)


Edit :
Ok, if i understood, i have to put the original Bethesda Sofworks folder in the Program Files folder of your app, is it right ?
If it is, the game is working well, but i don't have the launcher yet :/ Where can i choose the data files the game will use ?
Yarrrrrrgggghhhh

Sorry about my english :P

Re-edit :

Finally, i've found how it works :P
There's no launcher at all, all the mods are automaticly taken by the game, once they're where they have to.

Thanks to you sonic for the tutorial, now i can play Oblivion with mods, and it's really better than without.

Ciao

#43
narodnaja11

narodnaja11

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hi there, i have a big problem...the console dont appears...i tried to use the "ring of god/console" mod, the ring appers is in my inventory and i can put it on...but the console still does not appear.
i checked the ini and there were no command like bAllowConsole=1 , i added it in both ini's and nothing happens if i hit the ^ i looked around in different forum and it seems to be a win probelm, why doses this happen on my mac? i am at the end of my knowledge and i hope you could help me...

#44
jaedreth

jaedreth

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Help! I have Cider Oblivion, and the machine I'm on is plenty powerful to play...

But 1) the launch screen doesn't show when I open up the game, and 2) that means it Won't Let Me Disable HDR Lighting!

Where do I go and manually edit the files to disable HDR Lighting?

I've checked the package contents, I've checked my user preferences. I can't find any place to turn HDR Lighting off!

Please help!

(Not interested in modding... yet...)

#45
may19

may19

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
can you send me a print screen at may19c19@hotmail.com or post it plezz .Posted Image

[quote name='jaedreth' date='May 8 2009, 03:29 AM' post='1150630']
Help! I have Cider Oblivion, and the machine I'm on is plenty powerful to play...

But 1) the launch screen doesn't show when I open up the game, and 2) that means it Won't Let Me Disable HDR Lighting!

Where do I go and manually edit the files to disable HDR Lighting?

I've checked the package contents, I've checked my user preferences. I can't find any place to turn HDR Lighting off!

Please help!

(Not interested in modding... yet...)

Disable HDR Lighting in the game and there in no launch screen

#46
Jackhamma's Machamma

Jackhamma's Machamma

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Well... I swear I've followed the tut to the letter, but I still can't get the bloody thing working. I've put the files in the right place and everything, but I have yet to see Midas Magic shop show up outside of the Mage's Guild. Sorry I have no idea how to take a picture of my folder for ya'll to see.

I hope someone can figure it out >.<

right I think it has something to do with the version of Oblivion I'm playing on... only problem is I can't seem to update it. It asks me to update everytime I launch it but when I try it says it's missing some files n' can't patch it. The only other patches I've seen were all in .exe files... help?

#47
loppa

loppa

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
When i try to enter the shivering isles (on the see), i just can see some exclamation points !
Help me please.

#48
Kroh

Kroh

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
  • Gender:Male
  • Location:Iowa, USA
This stuff is all great, thank you all for the time you've put into this. I've been pulling my hair out trying to figure out how to get mods to run on this, because there is just so much detail stuff that Beth-soft missed or did a poor job on that the mod community takes it upon themselves to remedy.

I downloaded the Oblivion GOTY from pirate bay a few months ago and have been following users instructions in the comments section there. Almost the exact same stuff as the directions here. I did a lot of modding in TESIII Morrowind, so I'm not new to putting mods in the data folder. I am almost positive I have everything in the correct places there, and my two .txt files are set up just like the directions.

Despite all this, I can not get things to work in game. The shop for MidasMagic isn't there, I can't get any different hairstyles, IlluminationWithin doesn't work, etc and etc. I have gotten parts of some mods to work, and some texture replacement stuff seems to work. Any help would be greatly appreciated.

#49
PAZda09

PAZda09

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
I apologize if I sound like I have no idea what I'm doing (I really don't)

But I don't have a bethesda softworks folder or a data folder or anything, I only have the application...oblivion...which works out if I want to play it but not if i want to use any mods.

I'm not sure if I need to activate hidden files and folders or something........
help?

#50
Kroh

Kroh

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
  • Gender:Male
  • Location:Iowa, USA
Right click on the "Oblivion" icon in the application folder and select "Show Package Contents" then from the Contents folder navigate to the Oblivion folder. For my copy, it's Resources/transgaming/c_drive/Program Files/Bethesda Softworks.

#51
PAZda09

PAZda09

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
ooooh
thanks a lot

#52
Kroh

Kroh

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
  • Gender:Male
  • Location:Iowa, USA
anyone have any idea why mods would not work if they're in the right place in data files and the text file in the library/preferences is right? there's no certain order the list in the plugins.txt has to be in, is there? I've tried moving things around in there, the data files were all moved correctly, I'm certain. I can get the Exnem body mod to work, but cannot get any faces/hair/eyes/races to load, and cannot get any places/items mods to run.

#53
MacVega

MacVega

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hey Everyone, I am fairly new to these forums but i am not new to modding. This is the first time I have tried modding on a mac and am slightly upset that i cant figure this out. Oblivion is my favorite game and this is the strongest computer i have ever owned allowing me to finnally run it. Thank you to all who posted the oblivion.ini fixes as they have helped me very much. However i am still stuch with a dillema. Oblivion doesnt recognze that my mods exist. I know for a fact that i have all of the .esp/.esm's in the correct place as well as their related files because all the mods i have (very few) that use meshes and textures without needing a .esp or a .esm are working fine. I do not have parallels but instead have VMware so i have slightly different file paths. I have tried sonicjams idea but cant get it to work but i think the fault lies with me rather than his idea.

My oblivion data is located here:

Oblivion GOTY.app/Content/Resources/transgaming/c_drive/Program Files/Bethesda Softworks/Oblivion/Data

I have narrowed it down to three possible reasons why i am having issues with making his idea work.

1. I have the Plugins.txt and DLCList.txt in the wrong location. They are located in:
Oblivion GOTY.app/Content/Resources/transgaming/c_drive/Documents and Settings/User/Local Settings/Application Data/Oblivion

The only two things in this particular file titled oblivion are the plugins.txt and DLCList.txt and nothing else.

2. I have written either of the two text files incorrectly.
DLCList.text reads as :

# This file is used by Oblivion to keep track of your downloaded content.

# Please do not modify this file.

Plugins.text reads as :

# This file is used to tell Oblivion which data files to load.
# Use the "data files" option in the Oblivion launcher to choose which files
# you want. Please do not modify this file.
DeadlyReflex 5 - Combat Moves.esp
HorseCombatMaster.esm
BathingMod_Placeable_Bathtubs.esp
BathingMod_Soap.esp
BathingMod_Bathroom_Upgrades.esp
BathingMod_Base.esm
Better Cities.esp
Better Cities - Full City Defences.esp
Better Cities Full.esp
Better Imperial City.esp
Better Cities Resources.esm
nVidia Black Screen Fix.esp
PC Sleep Disrober.esp
Retros Fletching and Imbueing.esp
FULL_Oscuro's_Oblivion_Overhaul_V_1.23.esp
CapesandCloaks.esp
RangerEquipment.esp
Crowded Roads.esp
AliveWaters - Koi Addon.esp
AliveWaters - Slaughterfish Addon.esp
AliveWaters.esp
Castle_Dunkerlore_V1.esp
eyja.esp
Guards.esp
NRB4+Vineyard Patch.esp
road+bridges.esp
CampfireBehavior.esp
NRB4 Standard Road Record.esp
DLCShiveringIsles.esp
DLCHorseArmor.esp
Knights.esp
DLCMehrunesRazor.esp
DLCOrrery.esp
DLCSpellTomes.esp
DLCThievesDen.esp
DLCVileLair.esp
DLCFrostcrag.esp
Oblivion.esm

In the actual text there is a space between the notification and the mods and a space inbetween al lof the mods.

3. The error lies in that i have to start a new game for it to read the mods instead of loading the save files i currently have. (I have two at the prison sewer exit for testing purposes) The reason being that the other two games have already compiled data and wont load any changes.

I have found an alternate way to loading the mods but i cant continue because of a strange occurance. I have downloaded Wirebash and it is running perfectly as it allowed me to sort and make sure all the mods were working but i need a save file to load those mods to. For some strange reason the save files i made in oblivion are missing from the universe until i boot it up and load the saves in game. I have concluded from this that you cannot access save games outside of the application because they are stored directlyi in the application. I could very well be wrong and it would please me to no end to be proven so but i have searched everywhere.

If any of you can help me with this issue of mine I would be very grateful

#54
Stevie117

Stevie117

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
I recently downloaded a Growlfs mod, where can i find the character model data?

#55
Fearlessleader

Fearlessleader

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
  • Gender:Male
  • Location:Portland, TN
  • Interests:Thing I love most in life<br />Building Computers<br />Building Harley's...

Hello Everybody ! First post :)



I found a better workaround !

It seems the problem with impact sound comes from an incompatibility between wine and hardware sound acceleration.

In [audio] section of Oblivion.ini set bDSoundHWAcceleration=0 and
bUseSoftwareAudio3D=1 to turn it off and you won't jump out of your chair any more every time you run into a fallen weapon.


fHeadroomdB=2.0000
fMinSoundVel=10.0000
iMaxImpactSoundCount=16
fMaxFootstepDistance=1100.0000
fPlayerFootVolume=0.9000
bUseSpeedForWeaponSwish=1
fLargeWeaponSpeedMax=0.9500
fMediumWeaponSpeedMax=1.1000
fLargeWeaponWeightMin=25.0000
fMediumWeaponWeightMin=8.0000
fGlassLargeMassMin=25.0000
fGlassMediumMassMin=8.0000
fClothLargeMassMin=25.0000
fClothMediumMassMin=8.0000
fMetalLargeMassMin=25.0000
fMetalMediumMassMin=8.0000
fChainLargeMassMin=30.0000
fChainMediumMassMin=5.0000
fSkinLargeMassMin=30.0000
fSkinMediumMassMin=5.0000
fEarthLargeMassMin=30.0000
fEarthMediumMassMin=5.0000
fStoneLargeMassMin=30.0000
fStoneMediumMassMin=5.0000
fWoodLargeMassMin=15.0000
fWoodMediumMassMin=7.0000
iCollisionSoundTimeDelta=50
fDBVoiceAttenuationIn2D=0.0000
fDSoundRolloffFactor=4.0000
fDialogAttenuationMax=35.0000
fDialogAttenuationMin=7.7500
bUseSoundDebugInfo=1
fUnderwaterFrequencyDelta=0.0000
bUseSoftwareAudio3D=0
fDefaultVoiceVolume=0.8000
fDefaultEffectsVolume=0.8000
fDefaultMusicVolume=0.8000
fDefaultFootVolume=0.8000
fDefaultMasterVolume=0.8000
fMainMenuMusicVolume=0.6000
bMusicEnabled=1
bSoundEnabled=1



I don't have bDSoundHWAcceleration=0 value to change. I tried adding the value to the .ini but that did not help either. Any thoughts what I did wrong?

#56
RageBattle

RageBattle

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
Time to stop lurking ;)

For you all installing mods, I suggest you read about load order as it's VERY important.

Something like this
Examples

Generally for Windows users using OMM, you load the Oblivion.esm at the top of the list and other .esm's directly under, these are "master" files. "Plugins", the .esp's, come after them. For the Plugin.txt we must use, you should generally follow this pattern, and make sure you leave the space (hey, it works for me)

# This file is used to tell Oblivion which data files to load.
# Use the "data files" option in the Oblivion launcher to choose which files
# you want. Please do not modify this file.

modc.esp
modb.esp
moda.esp
modc.esm
oblivion.esm


So basically it's just upside down, and remember the load order needs to come into effect. And those are fake mod names in case you are pretty thick.

After about a week of messing with this, I can say from my experience, major tools like OBSE, OMM, Wrye Bash won't work unless someone is more talented than me which I would hazard a guess a lot of you are :P . The Construction Set I did manage to get running and functioning somewhat. It crashes a lot more then I think it should but you should be able to work around it. I'm not sure if there are fixes and this is a general problem, or just the fact I'm on a Mac.

Haven't found a fix for the sound problem either, none of those fixes or mine worked, except turning off collisions entirely which can lead to a lot of in-game confusion.

My real problem is fps. I have jammed my data folder with about every poly reducing mesh and reduced textures and see little to no improvement (talking about 6 or 7 mods that "should" give at least 20 frames). Changing the .ini doesn't provide much success, even following the tweak guide. In game the best solutions I have found are turning off shadows, and reducing the view distance. View distance is probably the biggest fps boost I can get but it's horrible playing on anything under 100% with distant buildings, good luck trying to find dungeons in the haze that you will get unless you stumble upon somewhere by chance.

You might want to avoid flashy armor and weapon mods, or any thing like a buliding that adds "new" things as lot of it has ridiculous high poly counts. As an example just one set of gear I equipped in the armor menu dropped my fps from 60 to low 20's. But that's just my input.

#57
RageBattle

RageBattle

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
There's a guy on the Piratebay website saying to list the plugins like OBMM would, IDK, whatever works for you.

#58
theweakend

theweakend

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
Anyone interested in this topic might want to read this

#59
zackdddd

zackdddd

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
I had Oblivion working great on my computer, and after doing the performance and graphics tweaks suggested on the forums it broke. It shows the splash, then returns the error :

Failed to initialize renderer.
GetAdapterDesc() Failed.

Not sure what caused this exactly, after tweaking I played for about 10 minutes, then when killing a goblin it crashed. It returns this message every time I try to run it now.

#60
CederGraff

CederGraff

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

I found a txt that oblivion reads to order to get the mod to work and its pretty easy too.

1. First download the app i released its in my sig and add the game in its right place.
2. Go, find, and download the mods you want. (i recommend http://www.tesnexus.com )
3. Add the mod in the data folder. Watch out when it asks about replacing something because you can remove your last mod files for accident just open up the folder and move the files into the folder it has to be.
4. now to get your mod or dlc working go to username/library/preference/"The Elder Scrolls 4/Oblivion Preferences"/p_drive/user/local settings/application data/Oblivion/
5. now in there make 2 txt files one named DLCList.txt the other one Plugins.txt
6. just to make sure just add this in your txts


7. to add the mods is the easy part just open up Plugins.txt file and add the file name.ext over oblivion.esm just to make sure. Here is an example:

8. thats it save it and open oblivion and have fun with the mods.

[optional]
to make it easier make an alias for the folder of oblivion to add the mods it will be a pain in the butt opening it every time you found somehting.


im a complete and udder nub at this stuff, so heres my problem everytime i try and start the game it has the little spore symbol and says "Some of the files have been modified! Please re-install" can anyone help me with that?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy