Jump to content

Lenovo ThinkPad R61i [7650-E8G]


  • Please log in to reply
25 replies to this topic

#1
dj_spark

dj_spark

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 197 posts
  • Gender:Male
  • Location:Chantilly, France
Bonjour à tous,
je vais vous parler de mon install histoire d'arriver au bout...

Tout d'abord l'engin :

Type de processeur Mobile DualCore Intel Core 2 Duo T5600, 1000 MHz (11 x 91)
Nom de la carte mère Lenovo ThinkPad R61e
Chipset carte mère Intel Crestline-GM GM965

Carte vidéo Mobile Intel® 965 Express Chipset Family (384 Mo)
Accélérateur 3D Intel GMA X3100
Moniteur Lenovo 154WX4-TLA6 [15.4" LCD] ThinkPad Display 1280x800

Carte audio Conexant Cx20549 @ Intel 82801HBM ICH8M - High Definition Audio Controller

Contrôleur IDE Intel® 82801HEM/HBM SATA AHCI Controller
Contrôleur IDE Intel® ICH8M Ultra ATA Storage Controllers - 2850
Disque dur ST9160824AS (160 Go, 5400 RPM, SATA)
Lecteur optique HL-DT-ST DVDRAM GSA-T20N

Clavier Clavier standard 101/102 touches ou clavier Microsoft Natural Keyboard PS/2
Souris PS/2 TrackPoint

Réseau PCI/PnP
Broadcom NetLink BCM5787M PCI-E Gigabit Ethernet Controller PCI
Intel PRO/Wireless 3945ABG Network Adapter PCI

PCMCIA
Ricoh RL5C476 CardBus Controller


Je suis parti sur la iAKTOS 2.0, la vidéo est en 1280*800, j'ai le son, l'usb, le dvd out of the box (boot avec cpus=1).
J'en suis très content pour l'instant et j'attend de nouveaux développement pour mon wifi et l'éthernet.

Je n'ai que peu de soucis pour l'instant.
Le seul point noir est de ne pas pouvoir exploiter les 2 cores de la machine, j'ai lu qu'il fallait essayer différents kernels, quels sont les kernels que vous me conseillez pour réveiller mon core endormi ?

Toutes les applications mac testées fonctionnent : ilife, iwork, aperture, final cut pro, ical, preview SAUF iMovie.

Merci


#2
dj_spark

dj_spark

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 197 posts
  • Gender:Male
  • Location:Chantilly, France
Je rajoute les détails :

Installation
-
Win XP Pro
- partition étendue FAT 32 (en principale la partition n'était pas utilisable, bien que visible)
- formatage en HFS+ lors de l'installation
- iATKOS 2.0i main system
- darwin bootloader (il a tout fait automatiquement)
- Kernel 9.2.2
- AppleSMbios netkas
- Vga intel GMA X3100

Ce qui fonctionne directement
- Intel Core 2 Duo T5600@1,8Ghz mais que sur 1 core (cpus=1) kernel ?
- Ecran 1200*800
- le GMA X3100 en 2D et 3D (test xbench à l'appui)
- le trackpoint
- le SATA
- le son ainsi que les bouttons de volume et mute (testé avec itunes)
- le dvd
- le clavier (sauf les caractères qui s'activent avec Alt Gr)
- le refroidissement du cpu (la vitesse varie)
- la mise en veille de l'écran
EDIT : l'USB !!! arrêter / redémarrer fonctionnent également sans soucis.

Ce qui ne fonctionne pas
- la mise en veille de la machine acpi ?
- l'économiseur d'écran (ne se déclenche pas mais pourtant fonctionne en test)
- le wifi (normal les drivers sont en cours de développement)
- l'éthernet (pas eu le temps de faire de grandes recherches)

Ce que je n'ai pas encore testé
- le pcmcia
- écran externe
- batterie
- la gravure de cd/dvd

Comme vous pouvez le constater, la iATKOS 2.0 est une superbe distribution à partir du moment ou les specs de la machine sont proches du Mac d'origine.

La prochaine fois je tenterais de rajouter du xbench, des info system et du dpci. Si vous avez des tuyaux n'hésitez pas merci.

#3
dj_spark

dj_spark

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 197 posts
  • Gender:Male
  • Location:Chantilly, France
Le changement de Kernel a résolu beaucoup de petit soucis, la liste a un peu évoluée...

Ce qui fonctionne
- Intel Core 2 Duo T5600@1,8Ghz (2 core grâce au Kernel ToH 9.2.0)
- Ecran 1200*800
- le GMA X3100 en 2D et 3D (test xbench à l'appui)
- le trackpoint
- le SATA
- le son ainsi que les bouttons de volume et mute (testé avec itunes)
- le dvd
- le clavier (sauf les caractères qui s'activent avec Alt Gr)
- le refroidissement du cpu (la vitesse varie)
- la mise en veille de l'écran
- l'USB
- arrêter / redémarrer / mise en veille fonctionnent également sans soucis.
- économiseur d'écran
- la gestion de la batterie

Ce qui ne fonctionne pas
- le wifi (normal les drivers sont en cours de développement)
- l'éthernet (pas eu le temps de faire de grandes recherches)

Ce que je n'ai pas encore testé
- le pcmcia
- écran externe
- la gravure de cd/dvd

Ca avance lentement car j'ai peu de temps à y consacrer mais je suis néanmoins très satisfait de l'expérience.

#4
dj_spark

dj_spark

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 197 posts
  • Gender:Male
  • Location:Chantilly, France
Le wifi est disponible via un dongle wifi (merci E?gle & Electro) : Dlink DWA 110.
Le chipset du mien est un RT2571WF
Les BONS drivers sont ici : http://www.ralinktec.../Macintosh.html

#5
dj_spark

dj_spark

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 197 posts
  • Gender:Male
  • Location:Chantilly, France
Nouveau changement de kernel, j'ai gagné sur quelques points mais perdus sur d'autres... Il se trouve que mon kernel et mon system.kext ne correspondaient pas.
J'ai fait quelques tests.

Résultats :
Ce qui fonctionne
- C2D
- Ecran 1200*800
- le GMA X3100 en 2D et 3D
- le trackpoint
- le SATA
- le son ainsi que les bouttons de volume et mute
- le clavier (sauf les caractères qui s'activent avec Alt Gr)
- le refroidissement du cpu (la vitesse varie)
- la mise en veille de l'écran
- l'USB (désormais hot plug !!!)
- arrêter / redémarrer / mise en veille fonctionnent également sans soucis.
- économiseur d'écran
- le wifi par dongle usb Dlink DWA-110

Ce qui ne fonctionne pas
- la gestion de la batterie
- le speedstep
- le wifi d'origine (drivers en cours de développement)
- l'éthernet (drivers en cours de développement)

Ce que je n'ai pas encore testé
- le pcmcia
- écran externe
- la gravure de cd/dvd

Concrètement j'ai ENFIN le online et ça devrait changer ma vision de OSx parait-il :D En revanche la machine n'a plus rien de nomade puisque la gestion de la batterie n'est plus d'actualité et celle du cpu ne l'a jamais été.
Pas encore génant puisque la partition Mac est justement prévu dans mon cas pour un usage sédentaire de l'internet.

A suivre...

#6
dj_spark

dj_spark

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 197 posts
  • Gender:Male
  • Location:Chantilly, France
Etant donné qu'aucun Kernel 9.2.2 ne tournait correctement sur ma iAktos, j'ai donc décidé de l'upgrader en Kalyway 10.5.2.
kabylkernel = 9.2.2/2cpu/usb/wifi/displaysleep/sleep/reboot/shutdown

Une fois ceci fait je suis passé à une Kalyway combo update 10.5.3 avec un Vanilla 9.3.0 de chez Apple, j'ai bien entendu merdé en faisant le reboot qu'il ne fallait pas faire, puis une fois résolu ce petit soucis : le drame. Elle ne veut booter qu'avec cpus=1...
Je boot a nouveau avec mon Kabyl 9.2.2 mais system.kext 9.3.0, je faits les udpate logiciels, et en dernier la fameuse 10.5.4 qui n'est pas censée fonctionner sans un kernel vanilla.

59Mo plus tard, "le nouveau logiciel nécessite le redémarrage de votre ordinateur" -Redémarrer- click !
Reboot... puis reboot...
C'est bon j'ai compris : cpus=1 et me voici sur le bureau, en wifi "A propos de ce Mac Version 10.5.4", plus d'infos "Darwin 9.4.0", trop facile...

Allez une dernière folie, je remets mon Kabylkernel 9.2.2 avec le system.kext 9.4.0 : c'est bon, core duo, pas de plantage, wifi, bon ben je n'ai plus qu'a me mettre au lit avant d'aller travailler. :unsure:

#7
dj_spark

dj_spark

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 197 posts
  • Gender:Male
  • Location:Chantilly, France
Hier soir, à l'allumage le Mac OSx à commencé un drôle de manège, c'était soit 2cores, soit le wifi : il fallait choisir.
J'en ai donc conclu que mon petit mix de version n'était pas très apprécié, pas grave j'ai downgradé le noyau en vanilla 9.3.0+son kext (le kernel pack de la Kalyway update combo).

Tout refonctionne, tout est en 9.3.0, "a propos de ce Mac" m'indique que je suis sous OSX 10.5.4 et je ne peux pas faire de nouvelle update (normal).

SAUF, que Safari à décidé de ne plus fonctionner, je n'ai pas pu le ré-installer depuis le site d'origine, il va donc me falloir l'extraire avec Pacifist d'une des distributions.

Une aventure sans fin, et sans limite... :unsure:

#8
dj_spark

dj_spark

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 197 posts
  • Gender:Male
  • Location:Chantilly, France
Et voilà, Safari réinstallé depuis le cd de iAktos, tout roule...
Au passage j'en ai profité pour me faire un profil lcd (puisque je ne peux pas régler la luminosité de la dalle) et c'est vraiment mieux, ça ne pique plus les yeux !!! lol
Donc au lieu de perdre du temps avec des solutions du type Shades (que j'ai testé et détesté) vaut mieux passer un peu de temps à faire un profil (ou plusieurs selon son usage).

#9
dj_spark

dj_spark

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 197 posts
  • Gender:Male
  • Location:Chantilly, France
L'éternel recommencement...
ce soir c'était dualcore ou usb (donc wifi) au choix. :rolleyes:
J'ai supprimé tout les fichiers important du système, effacer les caches, ré installé une kalyway 10.5.2 avec kabylkernel
tout fonctionne...
Je passe ensuite en combo update MAIS sans les kernels 9.3.0
tout fonctionne...
update en 10.5.4 de chez Apple (donc kernel 9.4.0)
ça fonctionne qu'en cpus=1 <_<
un petit downgrade de kernel (kabyl 9.2.0) avec les kext sauvegardés
tout fonctionne... SAUF la clef wifi qui se connecte mais ne communique pas
ré installation des drivers de la clef wifi
tout fonctionne... SAUF safari mais je ne m'en sers pas et il suffit de le ré installer.

Conclusion :
On peut très bien utiliser le kernel qui nous conviens le mieux, puis en cas de besoin d'update passer momentanément sur un vanilla (éventuellement avec cpus=1) et ensuite revenir à son kernel préféré et kext associés pour retrouver une machine fonctionelle.


#10
dj_spark

dj_spark

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 197 posts
  • Gender:Male
  • Location:Chantilly, France
Le graveur HL-DT-ST DVDRAM GSA-T20N (si, si c'est son nom) fonctionne parfaitement. Je l'ai utilisé avec SimplyBurns 315 en gravure de données sur un DVD en 4x : bonheur...
C'est impressionnant le nombre de truc 'out of the box' avec cette machine :angry2:

#11
dj_spark

dj_spark

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 197 posts
  • Gender:Male
  • Location:Chantilly, France
Mauvaise nouvelle :
C'est officiel je n'ai pas de speedstep. Apparement pour le tester il suffit de regarder la fréquence cpu dans 'A propos de ce Mac'. En batterie la fréquence doit être inférieure (logique), ce qui n'est pas le cas pour moi.

D'ailleurs pour vérifier j'ai testé l'autonomie, et ça m'a fait 1h50 tout rond (surf+DL).

Nouvelle moyenne :
Le double affichage fonctionne (enfin fonctionnait...). J'ai même pu régler chaque écran à sa résolution native. Tout s'est effondré dès lors que j'ai coché le mode clone. Depuis impossible de brancher un écran externe sans provoquer la perte totale de l'affichage.
je ne sais toujours pas si c'est le mode clone qui fait ça où le fait que je clone avec 2 résolutions différentes.

Bonne nouvelle :
Le temps de boot est de 40 secondes et l'extinction se fait en 5 secondes (sans périphériques usb)

#12
dj_spark

dj_spark

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 197 posts
  • Gender:Male
  • Location:Chantilly, France
2 bonnes nouvelles :
TimeMachine fonctionne très bien, j'ai ré installé la version de la Kalyway 10.5.2 puis j'ai patché avec le timemachinefix de la Kaly upgrade combo 10.5.3. :D
Et à l'instant je viens d'installer l'expérimental speedstep et bien c'est tout simplement hallucinant comme ça tourne bien.

Que me reste-t-il à faire ?
La mise en veille, l'hibernation et la gestion de la luminosité de la dalle.

Superbe aventure que celle de ce hack... :P
EDIT : autonomie sans speedstep 1h50 / avec 2h20 (usage surf wifi+DL)

#13
dj_spark

dj_spark

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 197 posts
  • Gender:Male
  • Location:Chantilly, France
Bon la machine était de plus en plus instable en surf, kernel panic en pagaille, firefox3 toujours en rideau (rapports sur rapports), bref, pas très Mac... :D
J'ai remis la Kaly 10.5.2 par dessus (downgrade donc) et ça a l'air beaucoup mieux pour l'instant.
Petit délire au passage : http://fr.youtube.co...h?v=toz0wcqC6uU

#14
zik_man

zik_man

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 168 posts
  • Gender:Male
  • Location:lyon
Tu pourrais m'en dire plus sur l'experimental speedstep ?
Je n'ai pas à me pleindre je tiens 3h en batterie mais ça peut toujours etre utile.

En tous cas moi je suis toujours en 10.5.2 depuis un foirage de la MAJ et franchement pour l'instant je ne vois pas l'intéret de passer en 10.5.4 si tout marche bien en 10.5.2

#15
dj_spark

dj_spark

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 197 posts
  • Gender:Male
  • Location:Chantilly, France
L'expérimental speedstep te permet de gérer le cpu au niveau des fréquences possible soit manuellement ou automatiquement, et également au niveau du voltage.
Il est relativement efficace (j'ai gagné 30min) mais je suis pénalisé par le fait que mon écran n'est pas géré (luminosité) donc avec la dalle à fond, ça vide les batteries.

Ca se passe là bas : http://forum.insanel...howtopic=119370

#16
zik_man

zik_man

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 168 posts
  • Gender:Male
  • Location:lyon
Tu ne peux pas régler la luminosité avec les touches du clavier ?

Merci pour le lien je vais essayer à l'occasion.

Qu'est ce qui ne vas pas sur ta veille sinon ?

Moi l'écran s'éteind bien mais impossible de le rallumer, je dois reboot le pc enfin ce n'est pas non plus essentiel donc à voir

#17
dj_spark

dj_spark

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 197 posts
  • Gender:Male
  • Location:Chantilly, France
Non le firmware de la dalle n'est pas reconnu, donc rien à faire...
La veille se fait et contrairement à toi je peux rallumer la machine mais l'écran lui reste en rideau. Ca fini néanmoins par un reboot sauvage ! :)

#18
dj_spark

dj_spark

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 197 posts
  • Gender:Male
  • Location:Chantilly, France
Aujourd'hui j'ai attaqué le LAN : http://forum.insanel...howtopic=114605
C'est pas encore ça mais c'est pas loin...

Interface réseau vue, diodes qui clignotent, le routeur voit la machine mais pas le contraire... impossible de pinger le routeur également. Dommage.

#19
dj_spark

dj_spark

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 197 posts
  • Gender:Male
  • Location:Chantilly, France
Après tout ce temps, j'ai eu envie de faire une mise à jour et de passer en 10.5.6 pour diverses raisons :
- plantages intempestifs de Firefox
- 2ème barette de mémoire non géré (passage de 1 à 2Go)
- timemachine HS
- refus de certaines applications de s'installer car version trop ancienne
- refus de se lancer de certaines applications du jour au lendemain sans raisons apparentes.

J'ai donc fait une sauvegarde sauvage : copie de mon dossier_utilisateur vers un disque externe., puis j'ai tenté de suivre un tuto qui avait l'air simple : http://www.insanelym...howtopic=142310

et c'est là que les problèmes ont commencé :
- au redémarrage boot0 error
- rendre la partition active, ok ça boot mais directement sur windows, je n'ai plus le choix de l'os
- ré installer par dessus iaktos et /ou Kaly : rien n'y fait

En désespoir de cause je me dis que si la machine est toujours fonctionnelle sous XP et que tout à l'air dans le même état que lors de la 1ère 'installation du hack, et bien il suffit de recommencer de zéro.

Sauf que contrairement à l'origine où j'avais tenté un Kaly, puis une Léo, puis une iAktos mais à chaque fois en couches successives (bonjour le mélange !!!), cette fois je décide de faire ça plus "proprement".

Installation de cette bonne vieille iAktosv2 si out of the box.
Après quelques tâtonnements pour trouver les bon paramètres d'installation je finis avec ça :
- iaktos v2
- Darwin bootloader
- efi8 no mbr
- vga : intel
- audio : hda

et bien vous me croirez ou pas, tout à re-fonctionné du premier coup (notamment le C2D et l'écran de veille).
En revanche rien à faire pour Timemachine.

Je me décide à refaire la même manip que j'avais consigné ici même : extraction et installation de timemachine et timemachine fix de la Kalyway 10.5.3 combo update, réparations des permissions, reboot.

BINGO ! Timemachine ok.

Je fais une belle première sauvegarde TM fier comme un coq.

Là ça s'est brutalement corsé : impossible de faire fonctionner ma clef wifi. Pourtant j'avais bien conservé la bonne version des drivers, j'ai aussi fait la config manuel dans l'onglet réseau des préférences mais rien n'y fait.
La mort dans l'âme je me décide à aller faire un tour sur le site du constructeur, et là : SUPRISE !!!
nouveaux drivers de décembre08 au lieu des miens de mars08.

je vires les anciens, installe les nouveaux, redémarre, configure : ça marche !!!
L'icone à changé (plus belle), le chargement est beaucoup plus rapide et pour l'instant pas de problème pour accrocher à la première connection du matin (contrairement à ces derniers jours où il ne fallait pas avoir une urgence online).

2ème sauvegarde TM

Ensuite je décide de rappatrier documents, images, fichiers de config et contenu des applications (pas encore les applications).

3ème sauvegarde TM

Enfin je copie les applications qui m'intèressent (toujours depuis la sauvegarde sauvage !), réparations des permissions, reboot : et elles fonctionnent !!! :poster_oops: AAAhhhhhh ooouuèèèèèèè ça c'est Mac quoi... trop fort !

4ème sauvegarde TM

finalement j'avais bien fait de faire ce petit journal en ligne sur mon hack, ça m'a bien servi :P
Config clavier : http://www.insanelym...mp;#entry808021
+ français pc layout de Kalyway 10.5.2.

La grosse question maintenant est de savoir si je tente une update ? (ah quoi bon ?)
Car j'ai également découvert cette astuce : http://www.tiwiti.co...ex.php?page=454
donc du coup j'espère que certaines applications ne vont plus faire la forte tête avec moi :D

#20
dj_spark

dj_spark

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 197 posts
  • Gender:Male
  • Location:Chantilly, France
Petit bloc-note pour éviter de paniquer

Bootloader HS :
http://www.insanelym...howtopic=111653
http://www.insanelym...showtopic=98247
http://www.insanelym...showtopic=83783

Démarrer en mode sans échec : -x





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2015 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy