Jump to content

ATI AC 97 Sounds (SB400) effort


  • This topic is locked This topic is locked
695 replies to this topic

#441
thedopefishlives

thedopefishlives

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 205 posts
I know, burty, not blaming you. :D Actually, the problem is mine more than yours, because the value *should* be checked, which is what your code does.

#442
zelda

zelda

    InsanelyMac Protégé

  • Members
  • PipPip
  • 57 posts
Dope, it would be better if you released your new version so that we can try it on different systems ??

#443
thedopefishlives

thedopefishlives

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 205 posts
chrs got a copy for testing purposes. I haven't released it because I'm still kinda testing it myself, :D but since I haven't heard back from him about it, I'm going to release it later today.

#444
odumso

odumso

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts

chrs got a copy for testing purposes. I haven't released it because I'm still kinda testing it myself, ;) but since I haven't heard back from him about it, I'm going to release it later today.

Will it work with the 4341 sound controller? All of your pervious ones kp at boot except and pre 01 crashes still about an hour to two hours into boot :-/

#445
thedopefishlives

thedopefishlives

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 205 posts
Still debugging. Chrs tells me he had some problems, and we're working on a solution that will be unified across at least both of our chips.

#446
odumso

odumso

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts

Still debugging. Chrs tells me he had some problems, and we're working on a solution that will be unified across at least both of our chips.

Alright cool. Thanks

#447
OldSkoolGamer

OldSkoolGamer

    InsanelyMac Protégé

  • Members
  • PipPip
  • 63 posts
Hey TheDopeFishLives or Ed,

Could one of you post your most current source ? I think I'll take a stab at fixing this stupid sound issue on this laptop myself.

#448
thedopefishlives

thedopefishlives

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 205 posts
PM chrs2021 and tell him I told you to give the links to my pre-release source.

#449
Kilopopo

Kilopopo

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 165 posts
thedopefishlives


Hi I am just wondering if your sound button in your HP zv6000 works properly with any ATIIXP sound kext.

If so can you tell me what kext works. thanks

#450
chrs2021

chrs2021

    InsanelyMac Protégé

  • Members
  • PipPip
  • 69 posts
http://www.thexpower...powersaving.zip
http://www.thexpower...powersaving.zip

sorry for thewait i had to do some stuff dope i am gonna try your suggestion, wish me luck.

#451
chrs2021

chrs2021

    InsanelyMac Protégé

  • Members
  • PipPip
  • 69 posts
ok that didn't work, i mean it did but now i don't have sound. i check the logs and the sound is supossibly playing but it doesn't output to the speakers.

-edit: DOPE you are the f***ing man, excuse my language but you are. i looked what you pmed me that didn't work but look at how the code is normally structured and it tried it that way. Genius i have working sound that it isn't late. i Just want to thank you for putting effort it in this code. it is phenominal. i know this sounds like ass kissing, and you know what? it is thanks a bunch.

#452
thedopefishlives

thedopefishlives

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 205 posts
Dude, that made my day. I'm going to go include what chrs just put in and release version 1.0.5, which should have no latency AND no kernel panics. Next on the feature list is turning off that pesky external amp line for those of you who have it.

EDIT: Attached is the official 1.0.5 release in both power-saving versions. Thanks to all the testers and guys who put their hardware on the line trying new things to fix problems! I can't do this project without you!

Attached Files



#453
Geek

Geek

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
Could you please post a compiled version??
Thanks Alot

#454
thedopefishlives

thedopefishlives

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 205 posts
Ed, I'm going to PM you a private version of this code later that will hopefully have the external amplifier quirk set. *crosses fingers*

#455
unet

unet

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
dope, you could send the code to me as well, I have some time to test it right now.

#456
chrs2021

chrs2021

    InsanelyMac Protégé

  • Members
  • PipPip
  • 69 posts
hey doope check out this error log i gots sound every thing is chill, but this bothers me. i wonder if it has something to do with the multi-channel audio.

Jul 3 04:41:41 localhost kernel[0]: AppleAC97AudioATIIXP::createCodecDevice: Creating Codec 0 device
Jul 3 04:41:41 localhost kernel[0]: AppleAC97AudioATIIXP::attachCodecDevices: Cannot create codec device 1
Jul 3 04:41:41 localhost kernel[0]: AppleAC97AudioATIIXP::attachCodecDevices: Cannot create codec device 2
Jul 3 04:41:41 localhost kernel[0]: AppleAC97AudioATIIXP::attachCodecDevices: Cannot create codec device 3
Jul 3 04:41:41 localhost kernel[0]: display: family specific matching fails
Jul 3 04:41:41 localhost kernel[0]: CallistoHAL Initialized!
Jul 3 04:41:41 localhost kernel[0]: AppleAC97AudioATIIXP::selectDMAEngineForConfiguration: Hardware does not support DMA engine 2
Jul 3 04:41:41 localhost kernel[0]: AppleAC97AudioATIIXP::selectDMAEngineForConfiguration: Hardware does not support DMA engine 2



#457
EdFlyer

EdFlyer

    Computer Lackey

  • Members
  • PipPipPip
  • 159 posts
chrs, do you get any kind of input? Like can you record anything?

#458
thedopefishlives

thedopefishlives

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 205 posts
If I recall correctly, DMA ID 2 is SPDIF out. That is basically unsupported right now.

#459
odumso

odumso

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
Appears to be working without any crashes or latency issues yet!!! :D Will keep you updated!
Thanks
Compiled kext below with power management for dev id 4341
Enjoy

Edit: Here ya go :D Attached File  AppleAC97Audio.kext.zip   224.26KB   760 downloads

#460
zelda

zelda

    InsanelyMac Protégé

  • Members
  • PipPip
  • 57 posts
Same here (no KP or latency now) , great work Dopefish.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy