Jump to content

X3100 to work without sleep trick


  • Please log in to reply
18 replies to this topic

#1
champro

champro

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
I was installing the EFI v8 this afternoon, the oringinal kernel seems doesnt work for me . ;(
but one thing good is that my X3100 bootup normally after I replace the one AppleSMBIOS.KEXT from EFI v8 install folder !

Hope It works for others. just want to share it .
enjoy.

atthach the file in case someone may need it.

Attached Files



#2
larrybird

larrybird

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 105 posts
  • Gender:Male
  • Location:Manchester, England
I'll have a go.

What's your system? I'm on a Dell XPS m1330. These are notorious for having problems with x3100 whilst others have been able to make it function properly.

#3
larrybird

larrybird

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 105 posts
  • Gender:Male
  • Location:Manchester, England
By the way, are you running 10.5.2 and do you have the graphics update or are you using the stock kexts?

#4
GimmeRed

GimmeRed

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 287 posts

I was installing the EFI v8 this afternoon, the oringinal kernel seems doesnt work for me . ;(
but one thing good is that my X3100 bootup normally after I replace the one AppleSMBIOS.KEXT from EFI v8 install folder !

Hope It works for others. just want to share it .
enjoy.

atthach the file in case someone may need it.


I gave it a try on my 1720 and no joy. But it didn't break anything. :)

#5
larrybird

larrybird

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 105 posts
  • Gender:Male
  • Location:Manchester, England

I gave it a try on my 1720 and no joy. But it didn't break anything. :)


How did you get your x3100 to work on your Dell? I've been messing about with it for a few days and I've still nothing.

#6
GimmeRed

GimmeRed

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 287 posts

How did you get your x3100 to work on your Dell? I've been messing about with it for a few days and I've still nothing.


QE/CI and resolution change work out of the box with iATKOS v1r2 & r3 with the only problem of the display going to sleep on the resolution change. The work around for this is setting up a hotcorner sleep display or a sleep display app to open at login. The hotcorner is needed if you manually change the resolution.

Once the system has been put to sleep however the display no longer goes black when the resolution is changed. This is helpful for gamers as some games will change the resolution.

The best solution I have found is to not shut it down I just use sleep mode.

#7
larrybird

larrybird

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 105 posts
  • Gender:Male
  • Location:Manchester, England
I used iAtkos 2.0i and my video didn't work at all after the install. Did you select the x3100 drivers? The only way I could get the system to boot was with a vanilla kernel and not drivers/patches. I'll try copying them over from the DVD and see if that helps. Did you have to do anything else? Have you done the graphics update or does that break the video?

Also, with the sleep corner trick, does that mean the screen always blanks after the Apple loading screen? If I load the drivers, the system will keep running, though the screen goes from blue to black. So it'll always do that, fall asleep, then come back up once I've moved the mouse?

#8
GimmeRed

GimmeRed

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 287 posts

I used iAtkos 2.0i and my video didn't work at all after the install. Did you select the x3100 drivers? The only way I could get the system to boot was with a vanilla kernel and not drivers/patches. I'll try copying them over from the DVD and see if that helps. Did you have to do anything else? Have you done the graphics update or does that break the video?

Also, with the sleep corner trick, does that mean the screen always blanks after the Apple loading screen? If I load the drivers, the system will keep running, though the screen goes from blue to black. So it'll always do that, fall asleep, then come back up once I've moved the mouse?


Here is the guide to get it to work in iATKOS. I have no idea if it would worh on a 1330.
http://forum.insanel...showtopic=79526

It is a little quirky but once it installs and you get a hot corner set up for sleep display and a sleep display app to open at log on it works OK.

And again once the system sleeps and wakes up it works flawlessly.

The apple graphics update just gave me a black screen. I think if delete all of the Gma950kext before reboot it would probably work OK. I just haven't tried it because I don't want to break my install.

#9
larrybird

larrybird

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 105 posts
  • Gender:Male
  • Location:Manchester, England

Here is the guide to get it to work in iATKOS. I have no idea if it would worh on a 1330.
http://forum.insanel...showtopic=79526

It is a little quirky but once it installs and you get a hot corner set up for sleep display and a sleep display app to open at log on it works OK.

And again once the system sleeps and wakes up it works flawlessly.

The apple graphics update just gave me a black screen. I think if delete all of the Gma950kext before reboot it would probably work OK. I just haven't tried it because I don't want to break my install.


I used the sleep bit and finally got it to work. To be honest though--and I don't know if this is because it's a hackintosh--I think Vista looks much better. I wish I could compare it to a real Mac, but the font rendering seems off and the screen profile/settings were way too bright. I calibrated the monitor, though I still don't think it looks as nice.

Have you noticed the same or have I just not spent enough time putting everything in order?

#10
GimmeRed

GimmeRed

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 287 posts

I used the sleep bit and finally got it to work. To be honest though--and I don't know if this is because it's a hackintosh--I think Vista looks much better. I wish I could compare it to a real Mac, but the font rendering seems off and the screen profile/settings were way too bright. I calibrated the monitor, though I still don't think it looks as nice.

Have you noticed the same or have I just not spent enough time putting everything in order?


I calibrate my display and I like it better then vista. The only thing I miss about Windows is IE7.
But I must admit that everything work in Vista.

#11
aster

aster

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
X3100 Without sleep trick!?
Does anyone solved this?!

the problem is that when I start a game (rise of nations), the screen goes black (as the sleep on startup) and I cant wake the video during the game.

how can I solve this!?
could someone make this x310 video card without the sleep trick!?

Thanks!

#12
NickRolando1

NickRolando1

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
I would really like someone to find out a way to do it without the sleep trick as well.

#13
NickRolando1

NickRolando1

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
No solutions on this as of yet?

#14
Hacktrix2006

Hacktrix2006

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 423 posts
  • Gender:Male
Hi folks i'm looking in to the GM965 chipset for answers for the X3100. Once i find a universal solution i'll post everything up!

#15
Bart240

Bart240

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

I was installing the EFI v8 this afternoon, the oringinal kernel seems doesnt work for me . ;(
but one thing good is that my X3100 bootup normally after I replace the one AppleSMBIOS.KEXT from EFI v8 install folder !

Hope It works for others. just want to share it .
enjoy.

atthach the file in case someone may need it.


So, was anyone successfully able to boot into their Mac OSX with respective/full display settings and not having to drag their mouse to the corner or what not with this file from Champro?

Btw, Champro, once we have downloaded the file, you are supposed to delete the '.rar' part correct so the file name reads: "AppleSMBIOS.kext" ?

#16
NickRolando1

NickRolando1

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
Really looking for a way to get it to work without the hot corner....

#17
jmvBMW

jmvBMW

    Insanely Bimmer

  • Members
  • PipPipPipPip
  • 194 posts
  • Gender:Male
  • Location:Chile

Really looking for a way to get it to work without the hot corner....


Do you see this ?

#18
NickRolando1

NickRolando1

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts

Do you see this ?



Just read that over. Kind of confused me. I'm not usre I understand what it will do now?

ALso, we both have the 1525 dell laptop, have you been able to get to burn cds or read cds that you put in the disk drive?

#19
ADHDMedia

ADHDMedia

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 527 posts
  • Gender:Male
  • Location:Modesto, CA, USA
Hello. I have a Dell XPS M1330 with the Intel X3100 chipset. I have a fully working display without using the sleep trick. The key is DSDT editing. I downloaded a DSDT from a thread that works perfectly. The only problem I'm having now is that I can't get the system to go to sleep. All of my USB devices are detected as internal, and I don't really know what else to check. Any ideas? When I go to sleep, it wakes up instantly to a black screen, from which I can't recover without a hard reboot. Thanks.

If anyone wants to give my DSDT a go, let me know. I'll link it here.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy