Jump to content

Prasys' Method of upgrading to 10.5.3 - its easy and safe !


  • Please log in to reply
50 replies to this topic

#1
Prasys

Prasys

    Cheese Cheese cheese

  • Retired Developers
  • 338 posts
  • Gender:Male
Its been ages since i've posted a tutorial and in fact touched any OSX86 related stuff. So here goes my first tutorial (after being 'away' for a really long time).


This guide is meant for those of us who aren't familiar with OSX-upgrading procedure and those of us who are new to the scene. If you want to embark on a new journey/being adventurous . i would suggest you to use this guide -> " OSX 10.5.3 Upgrade Guide instead of mine

First and foremost , I made several assumptions in this guide

I am assuming that you are using Intel® Processor (SSE3/SSE2) , and you have a working OSX 10.5.2/OSX 10.5.1 installation with your devices working such as Sound , Video and other things. I am assuming that you have some background skills on how to backup your extensions folder and core part of OSX Stuff which I'll explain later

THIS GUIDE DOESN'T WORK ON AMD . IT ONLY WORKS FOR INTEL® PROCESSORS SSE2/SSE3.


NOTICE : This just updates the core components of OSX without touching the working kernel and extensions folder. It means that your extensions folder will remain the same (no new drivers will be installed) and your kernel will not be touched. But it allows you to run application which requires you to have OSX 10.5.3. I'll update how to update the kernel part later once we have the kernel for Non C2D pcs (aka non SSSE3 pcs)
Shall we get started :-

Tools that you need

- MacOSX 10.5.2/OSX 10.5.1/OSX 10.5
1. Pacifist -> www.charlessoft.com (Download the latest one)
2. MacOSX 10.5.3 Combo Updater (its around 500MB+ , it took an hour for me to get it) -> http://www.apple.com...omboupdate.html

Okay , shall we get started

1. Mount up the OSX 10.5.3 DMG.

2. Now Right click MacOSXUpdCombo10.5.3.pkg and select open with Pacifist

3. Click the drop down button of Contents of MacOSXUpdCombo 10.5.3pkg

4. First select 'Applications' and hit the install button. It will ask for your root/Administrator password. Enter it. If you see any dialogue boxes just simply hit Replace or update (or put a selection to make it as a default selection). Just hit and replace. This will update the core stuff to the latest and greatest version of OSX 10.5.3. Including Time machine (which is what we need ;))

Posted Image
The authorisation screen - Just enter your username/password

5. Next up is the bin folder , the core unix stuff. Its not a biggie. just do the same thing as well. Just select bin folder and hit Install. Just replace and/or update if it asks you to do so. You may skip this step also (aka if you dont want to update your bin folder it fine).

6. Next up is the Library folder. PLEASE BACKUP THIS FOLDER JUST TO BE SAFE. Now , do the same thing. Select it and hit Install button. when it prompts you to update/replace a file just hit the replace all/replace/update button. It will do the rest for you

ATTENTION 7. DO NOT INSTALL mach_kernel and mach_kernel.ctfsys. AVOID THIS TWO AT ALL COSTS


8. Next up is the private folder and sbin folder, do the same thing as well. Select them and hit the install button. You don't really have to worry about this two folders

9. Next up is the system folder. Here comes the tricky part , now press the drop-down button for the system folder. Then you should see a Library folder. click the drop-down button for the library folder. You should see a huge list of folders. Now, you can safely select them all expect for Extensions , SystemConfiguration . Avoid this two at all costs. do not select them. Install the rest of them one by one , but just dont install these two. If you do that , you will be messing up your whole system. If you have any custom frameworks installed , then do not install the frameworks folder as well (but if you dont have any custom frameworks , etc then you may safely ignore this warning)

Posted Image

IMPORTANT NOTICE - BACKUP your System Folder as well. Just incase if anything gets messed up , you can always restore back !

10. finally we have our usr folder. Select the folder and install it away (if you can't install this just safely ignore - so far tested without installing it and the system seems to be working fine)

Once you have done , you can go and check it out that you have OSX 10.5.3 installed but with an old kernel and old extensions. Now all you have to do is very simple. Simply reboot your PC. Now in the Darwin Bootloader menu. Hit F8 , choose your Leopard partition and type (without quotes) "-f -v". Now it will load till at a point it will hang (Do not panic if it hangs). Just wait for 5-10 minutes and then safely hard reboot your PC (aka switch off and switch on).This time it will boot properly and you have OSX 10.5.3 !. It would be much more easier

I'll write a short guide as well on how to upgrade your graphics card drivers only and stuff like that. Stay tuned. Once we have the kernel ready for OSX 10.5.3. I'll teach you on how to upgrade it (it will be much more easier and painless). On top of that , it wouldn't even fry your installation. your drivers will just work fine :P

Extra-Notes

If you get this error after extraction , you may safely ignore it - "An error of type -60007 occurred while attempting to authorize to launch tools with root privileges.". Just safely ignore this message - Thanks mattrb for reportin


FAQ

1) Does it work with Kalway/<Insert release name here>'s release ?

It fairly works with any release. Provided you have OSX 10.5.x installed and have your stuff working fine.

2) How Do I restore if my system gets screwed up ?

Its fairly simple. all you have to do is boot from the dvd or another partition or use MacDrive on windows and move back all the backup files back to its original location and reboot. Your data will be safe. So when requesting for help , just kindly state that you have your stuff backed up , so that someone in the forums/IRC can help you with it


Changelog
0.1 - 29th May 08 - initial release

0.1a - 29th May 08 - Fixed typos , added a screenshot. Redid couple of stuff. Verified and tested the method on a fresh OSX 10.5 installation
UPDATE #1 - I've uploaded some of the pictures. i'll be uploading more pictures after this !

0.1b - added a faq , and adjusted a couple of stuff

#2
mattrb

mattrb

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 318 posts
  • Location:Chicago, IL
success with your method one problem though, in pacifist I received an error (displayed below) after step 9, its okay for you can just reboot and finish the last step! Done!

An error of type -60007 occurred while attempting to authorize to launch tools with root privileges.

#3
Prasys

Prasys

    Cheese Cheese cheese

  • Retired Developers
  • 338 posts
  • Gender:Male
Great to know that it works. I'll add it back
Thanks for your input

#4
Siro

Siro

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 114 posts
  • Gender:Male
  • Location:London
I'll definitely give this a try as opposed to the other hardcore method because I am not that adept as compared to many others in here.Thanks a lot for the guide.

#5
Prasys

Prasys

    Cheese Cheese cheese

  • Retired Developers
  • 338 posts
  • Gender:Male
Okay Good news , i've some success report regarding on the kernel upgrade for Core 2 Duo users with EFI. So you may update your kernel using this method without destroying your installation. I'll be adding that shortly (the how-to).

#6
timdafweak

timdafweak

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 123 posts
  • Gender:Male
  • Location:New York
Thanks m8! Can't wait to get back home and try this out. I am not too keen to keep the old mach_kernel as I have an EFI install, so I am looking forward to your update. Cheers.

#7
robi62

robi62

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 263 posts
  • Gender:Male
  • Location:Javea Spain
did not work on my dell 640m after booting kept getting a mess cannot load memory then kept asking my for log in password
and then after 1 minute again and again and again.....

#8
Prasys

Prasys

    Cheese Cheese cheese

  • Retired Developers
  • 338 posts
  • Gender:Male

did not work on my dell 640m after booting kept getting a mess cannot load memory then kept asking my for log in password
and then after 1 minute again and again and again.....


simply restore back your system folder and library folder. Did you install any special patches such as intel wireless drivers or such - you can simply boot into -s and restore back things up.

#9
robi62

robi62

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 263 posts
  • Gender:Male
  • Location:Javea Spain
Iam restoring those folder now from usb leo install into my lptop hard drive ill let you know in 10 minutes..... ^_^up running again laptop seems slower that b4 but i get this error at bootupThe system extensions /library/filesystem/fusef.fs/support/fusef.kext was installed improperlyI might do a clean restore from timemachine back up

#10
Prasys

Prasys

    Cheese Cheese cheese

  • Retired Developers
  • 338 posts
  • Gender:Male

Iam restoring those folder now from usb leo install into my lptop hard drive ill let you know in 10 minutes..... ^_^up running again laptop seems slower that b4 but i get this error at bootupThe system extensions /library/filesystem/fusef.fs/support/fusef.kext was installed improperlyI might do a clean restore from timemachine back up


Well its fairly better i guess. So are you like using some NTFS-3G thingy or something like that. that might break the installation. Thats my guess

#11
robi62

robi62

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 263 posts
  • Gender:Male
  • Location:Javea Spain
back with restore and yes an laptop disk I do have NTFS-3G so I can access window partition.

do you think that is the problem????????
How do i uninstall it so I can try again with update??????

Cheers

#12
veagles

veagles

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Did Not Work :D

Tried it on Kalyway 10.5.2 with Toh 9.2 kernel.
I got a blue screen after restarting. The blue screen keeps flashing every 5 seconds. No Login Window.

#13
austinsnyc

austinsnyc

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts

Did Not Work :(

Tried it on Kalyway 10.5.2 with Toh 9.2 kernel.
I got a blue screen after restarting. The blue screen keeps flashing every 5 seconds. No Login Window.



Blue screen is normally a problem with the AppleIntelIntegratedFramebuffer.kext.......
use the one from the leo files and replace the one you have now.

#14
Anubis111

Anubis111

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts
Prasys, thanks, I confirm - your method works in 100% (though instalation takes a lot of time).
Greetz.

#15
robi62

robi62

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 263 posts
  • Gender:Male
  • Location:Javea Spain
latest update on my dell 640m.I installed upgrade from package not with pacifist then I tried to replace my important kext with kext helper woud not let me.It said failed to log in as root.So i booted up from usb leo install replaced applesmbios , applehpet ,appleintegratedframebuffer, appleacpiplatform,appleccpupowermanagment,and mach kernel with my old ones.I rebooted first with -f -v then with -xIt started but I had to reinstall appleintegratedframebuffer with kext helper.Rebooted but now I get cpu panick but if I boot in safe mode is fine any suggestions ????????I have speedstep kernel installedHere is my pic to show running update it took no more than 20 minutes with pacifist took me an hourI also noticed my mouse artifact is now gone I used to get it a lot when I used Flock browser just tried now and is not there :DI also noticed the only thing not working is battery meter anymore........and because I am running in safe mode my cpu does not have speed step so running at full speed and fan coming on a lot.......Is there anywhere on the logs a record of cpu panick that i get???So I can have a look at what is causing it..........Attached File  error.jpg   594.34KB   64 downloadsThis is photo of error if anyone more experience than me could tell me what i have to do......thank you all

Attached Files



#16
robi62

robi62

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 263 posts
  • Gender:Male
  • Location:Javea Spain
I have sorted every thing out.
I was getting cpu panic because I did not reinstall all kexts with kext helper after 2nd boot i only did
appleintegratedframebuffer becuse was showing as not installed properly.
I did them all and also I reinstall my sound with apple hda patcher + sigmatel 9200 and
bingo all running except battery meter .
I am sure some wiz will find solution.....
PS after reinstalling all kexts unfortunately got mouse artifact back.I wonder which kext is responsible for this...........


Attached File  mydell_.jpg   621.65KB   101 downloads

#17
Kvetch

Kvetch

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Worked mostly fine for me.. couple problems:

Lost my 2 NTFS partitions + 2 IDE partitions..
Safari 3.11 didn't start up at all.
And most annoying thing, all menus seem to be fully transparent. It was a bit hard to take a screenshot but here we go:
Attached File  Snapshot_2008_05_30_01_20_46.tiff   496.69KB   79 downloads

(About This Mac shows v 10.5.3)

edit: Other than those problems, the osx itself seems to work faster, applications that require the patch install easily and network problems are gone :) Just need to figure out how to get normal menus and why I get
"cd: error retrieving current directory: getcwd: cannot access parent directories: Input/output error"
when I try to enter any of my other partitions..

edit2: ok, got my partitions back.. seems that ntfs-3g just didnt work anymore for some reason. Any ideas about the transparent menus? Using HD2900 Pro 1024mb version.

edit3: bleh, stupid mistake :D thanks for the help lastExile and JaS

#18
cyclonefr

cyclonefr

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,751 posts
  • Gender:Male
  • Location:Paris, France
Sorry prasys but I would avoid this solution because it doesn't execute the post install scripts that uses the "real pkg installer" after first reboot.

This could result in some problems, mainly the one you are describing (hard lock after reboot) and network problems (samba/afs).

These scripts aren't there just for fun :( !

#19
jacksomm

jacksomm

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
Here is a screenshot of what happened after I did this...it seems like Finder isn't launching for whatever reason.  I tried restoring from backup, but everything seems to be the same.



I can run Opera, Thunderbird, iPhoto, and maybe a few others, but ichat fails to launch, and my iCal icon is clear, trash doesn't work, and if I try to launch anything from documents it just hangs.

I tried repairing permissions and disk from OS X boot disk, but still got nothing.  It seems like finder just isn't launching, because I'm able to attach a picture and I still see all my old desktop stuff.



Any ideas?

Attached Files



#20
iSynapse

iSynapse

    InsanelyMac Protégé

  • Members
  • PipPip
  • 90 posts
  • Gender:Male
  • Location:Romania
Thx for the guide....i worked for me just well.....
I want to add that my system after the reboot didn`t hanged up...it just started normaly...I used Kalyway 10.5.2


Cheers and thx again





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy