Jump to content

10.5.3 is available as an update


  • Please log in to reply
52 replies to this topic

#21
griven

griven

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
  • Gender:Male
  • Location:Bochum, NRW, Germany
Same problem here, used the kalyway Combo Update and it just screwed up any 3d Graphic acceleration.

#22
Aware

Aware

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
Trying to read enough before I try this :-)

I see the instructions here, and on an older thread for 10.5.2 update.

I had no luck previously trying to install 10.5.1, so currently I am running a version of 10.5.0 that was installed as a complete image from a file called "leopard-x86-flat-img".

So my question is - should I be able to install the 10.5.3 update over 10.5.0, or is it a requirement to upgrade (or install) 10.5.1, then 10.5.2 before finally installing the 10.5.3 upgrade?

#23
OneMammoth

OneMammoth

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
  • Gender:Male
n00b question.

If the update goes bad for any reason. Is it possible to reinstall Mac OS X (leo4allv3) and keep all my personal settings and apps I have installed, Or would I need to start all over again?

Thanks

#24
methamp

methamp

    Mac OS X Specialist

  • Members
  • PipPipPipPipPip
  • 292 posts
  • Gender:Male
  • Location:Cupertino
  • Interests:BOFH

Same problem here, used the kalyway Combo Update and it just screwed up any 3d Graphic acceleration.


Try re-installing your graphics drivers (NVInject).

#25
MrRoper

MrRoper

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 179 posts
  • Gender:Male

Try re-installing your graphics drivers (NVInject).



I gave kalyway update a shot and it shelled my kalyway 10.5.1 updated to 10.5.2 install. but the hackintosh panic'd before i could apply the kernel pkg that was included. i didn't have time to do much else last night but i'll try and fiddle later tonight . -x -v or booting normally gets me to "firewire device.../defaulting to full-secure mode" and maybe 2 lines more about ATA device then hangs forever ....


:) on another note, i'm slightly annoyed that i had an almost exact post placed up yesterday and the mod's deleted it for what reason i have no clue. I mentioned that the 10.5.3 update for kalyway, jas and also an amd specific update was available at your favorite spots" and that you could go and check it out... Now i see tons of more literal posts on these forums suggesting or even naming websites or indeces to go and search for things.
just pisses me off a little...

#26
santoz

santoz

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
This update have some corrections for laptop pcmcia card?I tried update the IOPCCardFamily and IOPCIFamily with IOPCCardFamily_chunnan_Leopard_rev8_src.zip and PCCard.10.5.2.beta3.kext.zip but when i update the IOPCIFamily my kernel start in panic.My version is kaleway 10.5.2 and my pc is hp 530 santoz :angel:This update have some corrections for laptop pcmcia card?I tried update the IOPCCardFamily and IOPCIFamily with IOPCCardFamily_chunnan_Leopard_rev8_src.zip and PCCard.10.5.2.beta3.kext.zip but when i update the IOPCIFamily my kernel start in panic.My version is kaleway 10.5.2 and my pc is hp 530 santoz ;)

#27
abrasive8

abrasive8

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
the kalyway comboupdate 10.5.3 worked as expected for me. i installed it with flying colors and no driver meltdowns upon reboot. although i dont have a graphics chipset that is prone to have trouble with standard drivers.

#28
macgirl

macgirl

    Stargate's Pharaoh

  • Retired
  • 7,615 posts
  • Gender:Female
  • Location:Mexico City
  • Interests:Techie gadgets

:wacko: on another note, i'm slightly annoyed that i had an almost exact post placed up yesterday and the mod's deleted it for what reason i have no clue. I mentioned that the 10.5.3 update for kalyway, jas and also an amd specific update was available at your favorite spots" and that you could go and check it out... Now i see tons of more literal posts on these forums suggesting or even naming websites or indeces to go and search for things.
just pisses me off a little...

Your post was not deleted, check first, it is in this thread, it was merged, here it is: http://forum.insanel...&...st&p=763191

The las post that of you tah was delete is from Posted on: Apr 16 2008, 04:43 PM, and even that was deleted with the whole topic, not only your post.

So don't be pissed and blame deletions.

#29
Aware

Aware

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts

I had no luck previously trying to install 10.5.1, so currently I am running a version of 10.5.0 that was installed as a complete image from a file called "leopard-x86-flat-img".

So my question is - should I be able to install the 10.5.3 update over 10.5.0, or is it a requirement to upgrade (or install) 10.5.1, then 10.5.2 before finally installing the 10.5.3 upgrade?


According to this page http://www.apple.com...omboupdate.html, system requirements are "10.5 or later" - but obviously that applies to a real Mac. Can anyone confirm if this is also true of a hackintosh?

Pretty please?

TIA

#30
macgirl

macgirl

    Stargate's Pharaoh

  • Retired
  • 7,615 posts
  • Gender:Female
  • Location:Mexico City
  • Interests:Techie gadgets
Yes because COMBO means that it has all updates that were released before included (10.5.1 and 10.5.2, also security updates).

#31
Aware

Aware

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts

Yes because COMBO means that it has all updates that were released before included (10.5.1 and 10.5.2, also security updates).



OK - s'what I figured, but I didn't know if there was something else I needed to scared of first ;-)

Thanks!

#32
MrRoper

MrRoper

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 179 posts
  • Gender:Male

Your post was not deleted, check first, it is in this thread, it was merged, here it is: http://forum.insanel...&...st&p=763191

The las post that of you tah was delete is from Posted on: Apr 16 2008, 04:43 PM, and even that was deleted with the whole topic, not only your post.

So don't be pissed and blame deletions.



unfortunately i don't have the time to be on these forums all day, tho i'm here often. how was i supposed to know it was merged. after all when a post is moved, there's still a link there that says it was MOVED..... I even checked all my previous posts to make sure and it wasn't there either... thanks....

#33
BugsB

BugsB

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,513 posts
  • Gender:Male
  • Location:Kauai, Hawai'i
for people having trouble mounting dmgs after the hacktint0sh 10.5.3 pdate despite of correct kernel/sys.kext melange: http://forum.insanel...t...st&id=28755

#34
Aware

Aware

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts

OK - s'what I figured, but I didn't know if there was something else I needed to scared of first ;-)

Thanks!



Oh well.... hosed it is then. When I reboot using -v, I see about 4 lines super-fast saying something like loading system somethingorother then machine reboots. Any suggestions gratefully received, otherwise I do a reinstall tomorrow...

Thanks

#35
macgirl

macgirl

    Stargate's Pharaoh

  • Retired
  • 7,615 posts
  • Gender:Female
  • Location:Mexico City
  • Interests:Techie gadgets

unfortunately i don't have the time to be on these forums all day, tho i'm here often. how was i supposed to know it was merged. after all when a post is moved, there's still a link there that says it was MOVED..... I even checked all my previous posts to make sure and it wasn't there either... thanks....

merged topics cannot have links like moved topics.

if You go to your profile you can see all you post in a list that is sorted by date, lastest first.

#36
mattrb

mattrb

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 318 posts
  • Location:Chicago, IL
MacGirl is the coolest moderator

#37
ShaneC

ShaneC

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Looks like it killed my ALCinject too, as well as switched my NVInject to software mode.

I tried the Probe adjustment to 0000, but same problems with NVinject. I switched to NVKush, and it came up correctly with full acceleration.

Adjusting the Info.plist was challenging on NVkush, since the site to help you cranks out a bad structure for the Info.plist. (Caused a number of reboots back and forth until I went line by line through it and figured out the extra <dict> in there.

I still have not gotten ALCinject back online. Any suggestions?

#38
macgirl

macgirl

    Stargate's Pharaoh

  • Retired
  • 7,615 posts
  • Gender:Female
  • Location:Mexico City
  • Interests:Techie gadgets
Is not that it killed the ALCinject, the update replaces the AppleHDA.kext you you need to re apply the patch or restore from backup AppleHDA.kext.

#39
ShaneC

ShaneC

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Of course you nailed it. I replaced the SMBIOS and AppleHDA and 10.5.3 appears to be completely functional.

Thanks to Netkas (and others), MacGirl, and everyone here. Woohoo!

#40
chinmay007

chinmay007

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
  • Gender:Male
  • Location:Earth
when r we planning to start a 10.5.3 compatibilty H.C.L. page on wiki.. ;)





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy