Jump to content

[OH-TOUX] GFX Strings


  • Please log in to reply
94 replies to this topic

#61
angegabriel2k3

angegabriel2k3

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 380 posts
Alors ayant tes posts SONOTONE,
j'ai testé lé dernier injecteur de TARUGA...


Sur ma P35-DS4 (REV 2.0) les infos systèmes me donnent ceci :

Audio haute définition Intel :

Identifiant du périphérique : 0x1458A022
Identifiant audio : 12
Appareils disponibles :



Donc, est-il possible d'avoir les infos de l'option "Appareils disponibles :" ?



@++

#62
sonotone

sonotone

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,151 posts
T'a bien pensé à virer ALCInject.kext?
Sinon tente de repatcher AppleHDA.

#63
angegabriel2k3

angegabriel2k3

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 380 posts
Ha non, j'ai absolument pas pensé à le virer...

Bon alors j'ai viré le "ALCinject.kext" mais ça ne change rien...


@++

(Et évidemment, merci pour l'aide !!!)

#64
MowgliBook

MowgliBook

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 998 posts
  • Gender:Male
Chez moi ça donne ça avec les Strings + HDAenabler 1.0.0d1 + AppleHDA 1.2.4a21 patché.

Posted Image

#65
angegabriel2k3

angegabriel2k3

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 380 posts
Ben po chez moi, LOL


Là, j'ai repatché mon fichier "AppleHDA.kext" avec la version 1.20
de Taruga et le Codec Dump ALC889A (ALC885) que j'ai trouvé sur son site...

Mais pourquoi utiliser le Codec Dump ALC885 alors que c'est du ALC889 ?
Au final, ça serait juste une révision de l'ALC885 l'ALC889 ?

Je viens de rebooter...


Maintenant j'ai ceci :

Audio haute définition Intel :

Identifiant du périphérique : 0x1458A022
Identifiant audio : 12
Appareils disponibles :
0000Haut-parleur :
0000000Connexion : Prise Jack 1/8 pouce
0000Microphone :
0000000Connexion : Prise Jack 1/8 pouce
0000Sortie S/P-DIF :
0000000Connexion : Interne




@++

#66
Chicken!

Chicken!

    from 5pack.be

  • Members
  • PipPipPipPipPip
  • 276 posts
  • Gender:Male
  • Location:Belgium
  • Interests:Music, Photo, Video, ...

Audio haute définition Intel :

Identifiant du périphérique : 0x1458A022
Identifiant audio : 12
Appareils disponibles :


Exactement le même problème sur mon AMD Asus A8V-VM SE (Carte son ALC660).

#67
sonotone

sonotone

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,151 posts
Petite mise à jour du tuto pour ceux qui ne retrouvent pas l'accélération graphique après l'update 10.5.3, et ce même avec les Strings. (voir à la fin)

#68
sonotone

sonotone

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,151 posts
Petite mise à jour avec le trick d'Alex pour avoir la résolution native au démarrage.

#69
libseb

libseb

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
  • Gender:Male
  • Location:paris
Merci beaucoup sonotone. Après la 10.5.3 problème graphique comme beaucoup de monde. Mais là impec. Je met surtout ce message pour remercier l'ensembles des personnes qui developpent et militent depuis quelques temps dejà pour osx86. Moi je n'y connais pas grand chose et je pille à droite à gauche les infos de chacun et ça marche. Je suis monteur et outre d'avoir un pc il me fallait final cut et donc un... mac. He bien c'est chose faite et qui roule parfaitement en plus. Voir mieux que certains mac sur lesquels j'ai travaillé. Donc merci à tous.Juste pour changer ma config qui date : p5k premium / Q6600 3,5 ghz / 4go ram 6400 cl4 / 3DD 500go samsung / 8800 gts 640 / Vista / Leopard 10.5.3

#70
cparm

cparm

    InsanelyMac Legend

  • Retired
  • 997 posts
  • Gender:Male

En essayant la commande " ./gfxutil -f AZAL" j'obtient "DevicePath not found!"

Donc petite précision pour les personnes n'utilisant pas "Azalia Audio" il faut modifier la ligne suivante:

cd ~/desktop
./gfxutil -f AZAL
par (exemple, j'utilise AC97)
cd ~/desktop
./gfxutil -f AC97

Et dans IORegistryExplorer rechercher AC97@ et non AZAL@ <_<

Enfaîte ça dépend des kexts que vous utilisez pour le sons, à vous d'adapter selon ce que vous avez choisis pour faire fonctionné le son.


chez moi c'est pci8086,24d5

dans tout les cas pour trouver a coups la reference de la carte son, on peut utiliser la methode suivante:

il faut telecharger et installer pciutil : [attachment=29741:pciutils...nstaller.zip]

dans le terminal on tape

lspci -nn

ca va me sortir plein de ligne mais ce qui m'intéresse c'est celle de ma carte son ou je peut voir que l'id de ma carte est 8086:24d5:

00:1f.5 Multimedia audio controller [0401]: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller [8086:24d5] (rev 02)


dans IORegistryExplorer, je cherche 24d5 et je tombe sur ma carte

Posted Image

je peut voir que le nom de ma carte est pci8086,24d5

malheureusement, malgré la efi string pour le son, ma carte n'est toujours pas reconnue en built-in donc impossible de faire du 5.1, dommage :hysterical:

mais bon, au moi mon système sera sûrement encore un peu plus stable grâce a ca

#71
g33

g33

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
  • Gender:Male
  • Interests:C2D E6550 @2.8Ghz with default fan.<br />P5K-Pro mobo<br />2G RAM DDR2 667MHz...
Ou trouves-t-on le in.plist?
j'ai une x1900GT et plus de QE/CI (0x724b1002)

j'ai gfxutil, efistudio+pack lspci

je ne comprend pas comment on fait?

HELP PLEASE !

(et merci d'avance)

#72
sonotone

sonotone

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,151 posts

Ou trouves-t-on le in.plist?
j'ai une x1900GT et plus de QE/CI (0x724b1002)

j'ai gfxutil, efistudio+pack lspci

je ne comprend pas comment on fait?

HELP PLEASE !

(et merci d'avance)

Il y a un pack dans le tuto, le fichier in.plist s'y trouve

#73
Wiwi

Wiwi

    InsanelyMac Guy

  • Members
  • PipPipPipPip
  • 212 posts
  • Gender:Male
Salut les gars... Premiere fois que je veins sur le francais, ca fait bizarre !

Bon bin ca marche pas chez moi, je boot avec mais meme avec le IOProbescore number 0 je n'est pas QE et CI sur ma 8400m G, j'ai peut etre loupé un épisode, mais ca marchait avec NVinject (NVcap et tout...)

Personne n'a une idée ??

Nénamoins, merci pour le tuto, ENFIN qq chose de clair...

#74
ad_47

ad_47

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 101 posts
  • Gender:Male
j'ai essayer et ca ne marche pas pour ma ati x1600xt 256MO ram dommage quelqu'un a une solution please :P :(

#75
sonotone

sonotone

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,151 posts
Je crois que ta carte n'est pas supportée, mais faudrait que tu précises si c'est sur un portable ou non

#76
xhala_debru

xhala_debru

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 173 posts
  • Gender:Male
  • Location:Bruxelles
@sonotone:
Salut, ça sert à quoi de "Corriger la taille de la RAM Vidéo (VRAM)"
C'est purement cosmétique ou ça a un réel impact sur les performances de la carte?

En tout cas, très bon tuto.
Clair et précis. :(

#77
alexcooltranquille

alexcooltranquille

    InsanelyMacaholic

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,412 posts
  • Gender:Male
  • Location:Nancy, France
Purement cosmétique

#78
hellboy

hellboy

    InsanelyMac Protégé

  • Members
  • PipPip
  • 58 posts
Salut tout le monde,

Je me suis mis au string moi aussi :P
J'ai commencé par la video, ça tourne bien, resolution native au demarrage
SAUF que toujours pas de QE/CI é_è
Le IOProbeScore n'a rien changé apparement
Si quelqu'un a une solution, je suis preneur.

Et qu'est ce que NVCAP ?
j'ai pas tout saisi sur ce truc ... :)
est ce que ça pourrait mettre le QE/CI ? :D

Et donc je passe à l'audio
MAIS j'ai des soucis, normal
avec gfxutil, je ne detecte pas de AZAL et dans IORegistryExplorer impossible de le retrouver.
cependant il detecte HDEF
( ce dont personne ne parle )

Est ce que HDEF remplace AZAL ?
le tuto marche pour HDEF ?

Merci pour tout
bonne continuation

#79
Cyberdog !

Cyberdog !

    InsanelyMac Sage

  • Donators
  • 280 posts
  • Gender:Male
  • Location:France, Lorraine, Pont-a-Mousson

Exactement le même problème sur mon AMD Asus A8V-VM SE (Carte son ALC660).



Idem pour moi sur ma GA-945GCMX-S2 avec un ALC888
Exactement la même chose.

#80
hellboy

hellboy

    InsanelyMac Protégé

  • Members
  • PipPip
  • 58 posts
Questionnement ...

Avec les GFX string, on ne peut pas se passer de driver, donc il faut toujours mettre un driver en fonction de la carte audio qu'on a ...
Dans ce tuto on ne change aucun driver c'est normal ? O_ô
Reponse -> Il faut quand même patcher AppleHDA.kext

sinon petite confirmation, il faut bien virer AppleAC97.kext ?
Reponse -> Oui on peut le virer il sert a rien...

( j'ai eu mes reponses, en parcourant ce topic :/ )





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy