Jump to content

Shutdown FIX su HP e ACER | CAUSA Audio ALC268 | NUOVO KEXT SENZA FIX!


  • Please log in to reply
83 replies to this topic

#41
homman

homman

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts
  • Gender:Male
  • Location:Roma
installo il taruga installer 2 , riavvio installo il fix 3 riavvio
ma il problema persiste.
Hp dv 6560 el.
Non capisco come mai per?

Ciao e GRazie

#42
Paolo84

Paolo84

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts
@darkonme
grazie per il consiglio, prover :)

@homman
prima di spegnere hai provato ad aumentare/abbassare l'audio utilizzando i tasti sensibili al tocco ?

#43
clipt81

clipt81

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,808 posts
  • Gender:Male
  • Location:Palermo
  • Interests:NOTEBOOK: HP Pavilion DV9695el <br />Leopard retail 10.5.5<br />CPU: Intel Core2...
Ciao ha tutti
Finalmente ho visto il mio HACKINBOOK spegnersi normalmente. ^_^
ma solo se la batteria e l'alimentatore sono collegati entrambi. Se stacco uno dei due nn si spegne pi. Ho provato il vostro consiglio di aumentare o diminuire il volume e poi spegnere ma niente lo stesso, come mai?

#44
netbix

netbix

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts

Allego qui Posted Image Install_HDA_Fix_v3.zip

uno zip contenente una applicazione che "Installa" automaticamente la soluzione trovata da shamrock73.

Informazioni utili

Consente il corretto spegnimento se alimentato a corrente, ma se a batteria, prima di spegnere premere sul tasto volume per alzarlo o abbassarlo.

Cosa fa l'installer ?

crea la cartella AppleHDA.taruga (/System/Library/Extensions/AppleHDA.taruga) e vi sposta all'interno la cartella Contents contenuta in AppleHDA.kext (/System/Library/Extensions/AppleHDA.kext/Contents), che ad ogni avvio viene ripristinata in AppleHDA.kext e dopo aver caricato il kext rispostata in AppleHDA.taruga.

Questo lo script contenuto nella cartella /Library/StartupItems/LoadHDA, che viene lanciato all'avvio:

#!/bin/sh
mv /System/Library/Extensions/AppleHDA.taruga/Contents /System/Library/Extensions/AppleHDA.kext
kextload -t /System/Library/Extensions/ALCinject.kext
kextload -t /System/Library/Extensions/AppleHDA.kext/Contents/PlugIns/AppleHDAController.kext
kextload -t /System/Library/Extensions/AppleHDA.kext
kextcache -k /System/Library/Extensions
mv /System/Library/Extensions/AppleHDA.kext
/Contents /System/Library/Extensions/AppleHDA.taruga

postato da shamrock73.

Per ripristinare la configurazione originale sufficiente dare da terminale i comandi

sudo mv /System/Library/Extensions/AppleHDA.taruga/Contents /System/Library/Extensions/AppleHDA.kext
sudo rm -r /System/Library/Extensions/AppleHDA.taruga

sudo rm -r /Library/StartupItems/LoadHDA


Per conoscere quali script vengono lanciati all'avvio, usare System Profiler e andare su Software -> Elementi di avvio

RingraziamentiSe avete dei consigli su possibili migliorie, ben vengano :(

A Presto, DarkOnMe.


Lo script allegato un po' diverso, non sposta la cartella Contents, ma rinomina AppleHDA.kext.taura in AppleHDA.kext e viceversa

#45
Wiwi

Wiwi

    InsanelyMac Guy

  • Members
  • PipPipPipPip
  • 212 posts
  • Gender:Male
Hi all !

See here !!

We have the same problem, but not the same solutions...

I've test HDA fix, but it breaks boot like Paolo84 (IOresetting...), you think it's caused by MacFuse ????

#46
Paolo84

Paolo84

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts
Hi Wiwi, i think the problem is MacFuse and ntfs-3g. I reinstalled Leopard without MacFuse and all work great ! Now I'm using Paragon NTFS 6.5 for read NTFS partitions.

Bye

#47
Wiwi

Wiwi

    InsanelyMac Guy

  • Members
  • PipPipPipPip
  • 212 posts
  • Gender:Male
Ok thanks i will try this soon !!!!

#48
Wiwi

Wiwi

    InsanelyMac Guy

  • Members
  • PipPipPipPip
  • 212 posts
  • Gender:Male
Doesn't work, even if MAcfuse, ntfs 3g is uninstall... it's strange, this what it produce :

Process:		 kextd [75]
Path:			/usr/libexec/kextd
Identifier:	  kextd
Version:		 ??? (???)
Code Type:	   X86 (Native)
Parent Process:  launchd [1]

Date/Time:	   2008-06-06 13:12:10.343 +0000
OS Version:	  Mac OS X 10.5.3 (9D34)
Report Version:  6

Exception Type:  EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000000
Crashed Thread:  0

Thread 0 Crashed:
0   libobjc.A.dylib			   	0x959876ec objc_msgSend + 28
1   com.apple.framework.IOKit	 	0x90036432 KXKextCopyPersonalitiesArray + 210
2   com.apple.framework.IOKit	 	0x9002df5f KXKextManagerSendAllKextPersonalitiesToCatalog + 477
3   kextd						 	0x00002572 0x1000 + 5490
4   kextd						 	0x000032f5 0x1000 + 8949
5   kextd						 	0x00001b4e 0x1000 + 2894

Thread 1:
0   libSystem.B.dylib			 	0x92fbc4a6 mach_msg_trap + 10
1   libSystem.B.dylib			 	0x92fc3c9c mach_msg + 72
2   libSystem.B.dylib			 	0x93035cef kmod_control + 165
3   kextd						 	0x00003c11 0x1000 + 11281
4   libSystem.B.dylib			 	0x92fed6f5 _pthread_start + 321
5   libSystem.B.dylib			 	0x92fed5b2 thread_start + 34

Thread 0 crashed with X86 Thread State (32-bit):
  eax: 0xa03e1400  ebx: 0x921d08ee  ecx: 0x959b3860  edx: 0x00101180
  edi: 0x00000000  esi: 0xa03e1400  ebp: 0xbffffb48  esp: 0xbffffb24
   ss: 0x0000001f  efl: 0x00010286  eip: 0x959876ec   cs: 0x00000017
   ds: 0x0000001f   es: 0x0000001f   fs: 0x00000000   gs: 0x00000037
  cr2: 0x00000000

Binary Images:
	0x1000 -	0x15ffb  kextd ??? (???) <5cb174fd5fc15854de50a7d67153fef2> /usr/libexec/kextd
0x8fe00000 - 0x8fe2da53  dyld 96.2 (???) <06900973e83f70548b7a2a5fa6435865> /usr/lib/dyld
0x9000d000 - 0x90098fff  com.apple.framework.IOKit 1.5.1 (???) <60cfc4b175c4ef60bb8e9036716a29f4> /System/Library/Frameworks/IOKit.framework/Versions/A/IOKit
0x9159e000 - 0x916d6ff7  libicucore.A.dylib ??? (???) <5031226ea28b371d8dfdbb32acfb48b5> /usr/lib/libicucore.A.dylib
0x916d7000 - 0x91734ffb  libstdc++.6.dylib ??? (???) <04b812dcec670daa8b7d2852ab14be60> /usr/lib/libstdc++.6.dylib
0x9218f000 - 0x922c1fff  com.apple.CoreFoundation 6.5.2 (476.13) <b633d15f2901d73670cb1475628df1b3> /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation
0x92a4a000 - 0x92c17fe7  com.apple.security 5.0.3 (33532) <3bef414f3c6f433e707ac5abee340e16> /System/Library/Frameworks/Security.framework/Versions/A/Security
0x92ec2000 - 0x92ec9fe9  libgcc_s.1.dylib ??? (???) <f53c808e87d1184c0f9df63aef53ce0b> /usr/lib/libgcc_s.1.dylib
0x92fbb000 - 0x9311bff3  libSystem.B.dylib ??? (???) <a12f397abf2285077b89bd726bff5b18> /usr/lib/libSystem.B.dylib
0x9311c000 - 0x93124fff  com.apple.DiskArbitration 2.2.1 (2.2.1) <75b0c8d8940a8a27816961dddcac8e0f> /System/Library/Frameworks/DiskArbitration.framework/Versions/A/DiskArbitration
0x933f9000 - 0x933fdfff  libmathCommon.A.dylib ??? (???) /usr/lib/system/libmathCommon.A.dylib
0x95973000 - 0x95a52fff  libobjc.A.dylib ??? (???) <a53206274b6c2d42691f677863f379ae> /usr/lib/libobjc.A.dylib
0x95ff1000 - 0x9601cfe7  libauto.dylib ??? (???) <42d8422dc23a18071869fdf7b5d8fab5> /usr/lib/libauto.dylib
0x9601e000 - 0x9602cffd  libz.1.dylib ??? (???) <5ddd8539ae2ebfd8e7cc1c57525385c7> /usr/lib/libz.1.dylib
0xfffe8000 - 0xfffebfff  libobjc.A.dylib ??? (???) /usr/lib/libobjc.A.dylib
0xffff0000 - 0xffff1780  libSystem.B.dylib ??? (???) /usr/lib/libSystem.B.dylib


And shutdown (work first time on 10.5.2), doesn't work anymore with 10.5.3....

#49
giovy87

giovy87

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 106 posts
ciao ragazzi io ho un hp pavilion con alc268 installer 2 e leopard 10.5.3 con la versione 10.5.2 andava tutto bene ma da quando ho aggiornato...lo spegnimento non funge pi o comunque funziona di rado..certe volte neanche l'audio vuole funzionare...quando non funziona l'audio non riuslta visibile l'icona nella system tray in questo momento funziona tutto alla perfezione tranne lo spegnimento...ho provato ad installare e disinstallare tutto driver fix ma niente.... la prima vota dopo l'installazione funziona dopo smette di funzionare....

#50
7oby

7oby

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
Script basically works, however can't get running it at System boot.

If I drop LoadHDA script in /Library/StartupItems with root:wheel access rights and +x attributes, I can see in /var/log/system.log:

Jul 4 11:59:47 XXXXXXXX-macintosh SystemStarter[149]: "/Library/StartupItems" failed sanity check: path was created after boot up

I can fix that with "touch -t" and forcing LoadHDA script to have older date before dropping to /Library/StartupItems. However script is not executed during startup.

Sorry: Answer only in english or point me to some related english thread. thanx.

#51
Joeandmat

Joeandmat

    InsanelyMacaholic

  • Retired
  • 3,356 posts
  • Gender:Male
  • Location:Turin (Politecnico)
reinstall taruga driver and try the installer "Install HDA fix v3"...

then reboot and when finder is show, try to shutdown computer..

bye!

#52
7oby

7oby

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts

reinstall taruga driver and try the installer "Install HDA fix v3"...

then reboot and when finder is show, try to shutdown computer..


I was missing StartupParameters.plist, that's why it didn't execute on my machine. I did try now "Install HDA fix v3" and it worked at the beginning. But it didn't fix shutdown for me and also didn't work all of the time: One some reboots it hangs the system while spinning the wheel.

That may be due to using a prepatched kext for Dell XPS M1330 with STAC9228 chipset (= the only working with internal speakers).

I know how to get shutdown working though on my rig (10.5.4 with vanilla kernel 9.4.0):
. put system to sleep
. wake up and play some sound
. shutdown now works (which doesn't if I don't put the system to sleep beforehand; may not be only related to sound stuff therefore)

I guess I'm waiting for taruga HDAPatcher 2.0. Since I have workarounds for shutdown: No big deal.

#53
extremeae

extremeae

    InsanelyMac Protégé

  • Members
  • PipPip
  • 73 posts
The HDAEnabler didn't work for me either. I'm getting broken shutdown. Sometime it works and sometime it doesn't. I noticed that HDA Fix v2 seems to work better than HDA Fix v3.

#54
spasacamen

spasacamen

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Ciao a tutti, credo di aver trovato la soluzione per spegnere correttamente Leopard ANCHE con l'alimentazione a batteria SENZA dover alzare o abbassare il volume (come scritto all'inizio da darkonme). Quest soluzione un'integrazione a tutto quanto avete fatto finora voi (bravi!).

Per risolvere quest'ultimo antipatico problema, necessario scaricare l'applicazione gratuita SystemSound al seguente indirizzo:
http://systemsoundext.sourceforge.net/

Una volta installato, necessario impostare un suono all'avvio ed uno all'uscita (probabilmente sufficiente quello all'uscita, ma io ho testato solo con entrambi impostati). Alcuni suoni da utilizzare possono essere scaricati al seguente indirizzo:
http://www.macupdate...fo.php/id/19079

Fatto questo, anche sotto batteria lo spegnimento dovrebbe essere sempre corretto... in tre giorni di prova non ho pi visto Kernel Panic!

Fatemi sapere se funziona anche a voi!

#55
shamrock73

shamrock73

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts
Bravo anche a te, confermo funziona, e' sufficiente il suono allo shutdown
Bene la soluzione completa ora, funziona il 100% delle volte ;-)






Ciao a tutti, credo di aver trovato la soluzione per spegnere correttamente Leopard ANCHE con l'alimentazione a batteria SENZA dover alzare o abbassare il volume (come scritto all'inizio da darkonme). Quest soluzione un'integrazione a tutto quanto avete fatto finora voi (bravi!).

Per risolvere quest'ultimo antipatico problema, necessario scaricare l'applicazione gratuita SystemSound al seguente indirizzo:
http://systemsoundext.sourceforge.net/

Una volta installato, necessario impostare un suono all'avvio ed uno all'uscita (probabilmente sufficiente quello all'uscita, ma io ho testato solo con entrambi impostati). Alcuni suoni da utilizzare possono essere scaricati al seguente indirizzo:
http://www.macupdate...fo.php/id/19079

Fatto questo, anche sotto batteria lo spegnimento dovrebbe essere sempre corretto... in tre giorni di prova non ho pi visto Kernel Panic!

Fatemi sapere se funziona anche a voi!



#56
FelS

FelS

    InsanelyMac Protégé

  • Members
  • Pip
  • 44 posts
Non funziona per me. La prima volta che riavvio s, poi dopo l'audio compare e scompare ad intermittenza ai successivi boot. Soluzioni?

#57
giovy87

giovy87

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 106 posts
ragazzi ho visto che sul sito di taruga c' una nuova soluzione basata sull hdaenabler.kext e sul fix registratevi se volete link e istruzioni chiedete pure

#58
Joeandmat

Joeandmat

    InsanelyMacaholic

  • Retired
  • 3,356 posts
  • Gender:Male
  • Location:Turin (Politecnico)
potresti spiegarti meglio??
mi sa che il fix sia quello in italiano del nostro forum (sai, l'ho visto in molte pagine del forum inglese, indicato come una scoperta eccezzionale, senza menzionare che stato creato dall'italian team..)

ciao!!

#59
giovy87

giovy87

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 106 posts

potresti spiegarti meglio??
mi sa che il fix sia quello in italiano del nostro forum (sai, l'ho visto in molte pagine del forum inglese, indicato come una scoperta eccezzionale, senza menzionare che stato creato dall'italian team..)

ciao!!


ok mi spiego meglio siccome a me solo hdafixv3 non funziona bene ho cercato altre soluzioni e cercando l'installer 2 della alc268 sul sito di taruga ho trovato questo:

---------------------------------------------------------------------------------------------------------------------


The Definitive Guide To Fixing the Realtek ALC268 Soundcard (With Working Shutdown!!!!) In Leopard


I have finally found a fix to the shutdown problem, so now, you can have both working shutdown and sound! Download is located at the bottom of the post

1. Run ALC268 Installer 2 or ALC268 Installer 1 (Depending on which works for you)

2. Before Restarting, Go to System\Library\Extensions and delete ALCInject.kext

3. Then, use Kext Helper b7 to install HDAEnabler.kext

4. Go to disk utility and Fix Permissions

5. Restart, and make sure that Internal Speakers is selected in Audio Settings

6. Then, Run HDA Fix v3 (Riavvia in seguito means Restart later, Riavvia ora means Restart Now)

7. CLICK RESTART LATER

8. Repair Permissions with Disk Utility

9. Restart

10. Bootup and sound and shutdown should work

11. Now, Sound and Shutdown Should Work!!!

Credit Goes to the following people: Taruga: HDAEnabler and ALCInstaller1/2

Darkonme (from forum.insanelymac.com: http://forum.insanel...inked-image" /> : HDA Fix v3

DOWNLOAD LINK: http://rapidshare.co...inked-image" />

---------------------------------------------------------------------------------------------------------------------

ora riporto pure il link cos nessuno potrebbe pensare che voglio rubare qualcosa a qualcuno:

http://wiki.taruga.n...ts_parentId=813

(bisogna registrarsi per leggere)

#60
shamrock73

shamrock73

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts
Beh mi sembra una versione piu' elaborata della stessa soluzione di cui si parla in questo thread,
non sapevo altri stessero utilizzando lo stesso trucchetto in giro per il pianeta, la cosa mi fa molto piacere
Visto che l'idea l'avevo trovata io in principio (dopo un mese di tentativi part time!!), mi aggiungo di diritto ai credits ;-)





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy