Jump to content

Creative SB [Live!, Audigy, Audigy2, EMU10kX eDSPs] OSX Driver info here!


  • Please log in to reply
809 replies to this topic

#321
supermx3

supermx3

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 229 posts
  • Gender:Male
only real issues i have is no sound after sleep and random times my system loads then locks hard or stops during boot, card is a Audigy Gamer

#322
greyrage

greyrage

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts

I'm assuming that you've already done the following:
1. The Channel testing (to make sure that sound comes out of all speakers),
2. You've checked cable's connections if they're connected properly,
3. You've tried previous build and had success, or Tried on XP and had success,
4. You've reported to the official bug report page (so that new releases are not the same) :P
5. ReInstalled OSX and tried clean install (as older uninstalltions may have failed???)
6. You've Checked that audio card is fully supported @ Compatibility page (see my signature)

On the Freeze issue, I guess I'll give you time to edit your response (till 2 days) so you report back if you're wrong... otherwise, your card will be under category of "not freezing"


Bah, got a freeze today but this time @ arround 6 mins. :( And i cannot track what's happening as the system locksup and comes with a black notice informing me to restart my PC.

1. I'll check again when i get home tonight and will report back.
2. To do.
3. Didn't have much time to play with other builds.
4. No, I haven't ... Shall i do so? or wait a bit more so that i can try to track down the problem.
5. I'm on clean install iDeneb 10.5.4
6. My soundcard is listed as SB0350 [8880], i cannot find this number @ Compatibility page tho i see Audigy 2 ZS Platinum Pro as partialy supported. (My SB is Audigy 2 ZS Platinum with an External Drive)

pic.

Posted Image
Regards,

#323
MTZeon

MTZeon

    InsanelyMac Protégé

  • Members
  • PipPip
  • 60 posts
  • Gender:Male
  • Location:Portugal

If you've tried previous build, same problem existed, you should have reported earlier.

Can someone hear Play 5.1 Audio (Movie or AC3 type media), plug headphones, confirm that they're able to hear front stereo and not surrounded??? (an issue that existed in previous build for my sound card at least) 035x


Just updated to 1,2b on my Audigy 2 ZS SB0350 10K2 [e400] and sound is much better now, no more excess treble! :wacko: Great work Eugene, donation on the way ($41.79), you deserve it. Enjoy it and please, keep us updated with the best audio quality cards there is, since Creative doesn't support them, you do :wacko:

I've just tested 5.1 using DJ Tiesto - Elements of Life DVD concert and it sounds great!!! I've used VLC and checked if Dolby Surround and everything is fine!

Thank you so much for making these cards work on MacOSX, without you they would be useless.

#324
supermx3

supermx3

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 229 posts
  • Gender:Male

only real issues i have is no sound after sleep and random times my system loads then locks hard or stops during boot, card is a Audigy Gamer


add random lock ups while system is running to my list

#325
sirNemanjapro

sirNemanjapro

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts
I have installed 10.5.2 and this driver set for Creative. I have Sound Blaster 5.1 Live!, to be exact:
Creative EMU10K1 SB Live! Audio Processor

When I installed the driver the sounds looks somewhat, well not distorted as much as it is muffled. Its like it cant past cretin barrier. I played Mac OS X sounds, beside the click everything else, like mp3 in iTunes sounds very bad. Its like, I play the song and hear only the lower sounds but distorted.

I have reinstalled 10.5.2

#326
derfwins

derfwins

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
1.2b0 (BETA) worked like a charm on my SB audigy 2 SB0090. Thanks a lot for your hard work and dedication.


PS: I did have to restart the computer and plug it into a different PCI slot before the driver started working, just a heads up if it doesn't work for you, you might want to try that. On my friends Audigy 2 plat, it worked right out of the box without even restarting.

Awesome work guys!

#327
Guest: ѕиоѡ_*

Guest: ѕиоѡ_*
  • Guests
Holy smokes, I just tried the 1.1b0 since the latest release gave me kernel panics and I got 5.1 working which is a big plus because now I have only one more use for Windows which is playing games.

I have just tested between onboard (ALC889A) and Audigy and the quality difference is amazing. I have to say though I'm running straight out the Audigy to my 5400 speakers and line out from the onboard to line in 5400 speakers.
The sound has a lot more dynamics and punch.

Thx to all who made this possible cause to be honest I thought they could never pull something off like this.

Respect!

Update: One issue here that forces me into using the onboard audio again is the wake up from sleep without audio. If Eugene could get the power management working properly without having to set S1 as sleep mode this would be a keeper for sure.

#328
FaitH

FaitH

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
  • Location:İstanbul/Turkiye (not turkey)
sorry that stupid question but still no audio input or mic yet? :(
great work btw... :mellow:

#329
newbmac

newbmac

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 349 posts
  • Location:vertical
Watching some videos and got a kernel crash after about 1hr of video viewing

#330
Guest: ѕиоѡ_*

Guest: ѕиоѡ_*
  • Guests
Use 1.1b0 if you are using S1 as sleep mode. this driver works flawless for me with just slight clipping (distortion) in some apps but that is fixed by turning down the volume of the app.

#331
Peles

Peles

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
Hi,
My system can't shut down propperly after installing sound drivers 1.2b0 on Kalyway 10.5.2
It just goes to sleep instead and all fans are still on. Have to manually shut it down with power button.
Any help there?

Another question...I how can I remove these drivers from system completely?
Thanks.

#332
MTZeon

MTZeon

    InsanelyMac Protégé

  • Members
  • PipPip
  • 60 posts
  • Gender:Male
  • Location:Portugal

Hi,
My system can't shut down propperly after installing sound drivers 1.2b0 on Kalyway 10.5.2
It just goes to sleep instead and all fans are still on. Have to manually shut it down with power button.
Any help there?

Another question...I how can I remove these drivers from system completely?
Thanks.


Included with the drivers you have a file uninstall. Just run it on the terminal :)

#333
Peles

Peles

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
Hmm...
Seems like shutdown problem there is caused by .kext file in extensions directory. Uninstall in terminal doesn't help and does not remove the file (if I'm not doing something wrong). If I manually remove .kext system reverts back to normal shutdown...
Any ideas about how to get the driver and shutdown working together?

#334
Seleuco

Seleuco

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Same problem as Peles My system can't shut down It just goes to sleep instead. Im using iDeneb 10.5.5 v1.3. If I uninstall the kext works again ok.

any idea?

i have tryed lastest driver and 1.1b0

10.5.5 vanilla kernel
Mobo: ASUS P5W Deluxe
Processor: Intel Core 2 Duo Q6600 @ 3.0 GHz
Memory: 4GB DDR2 667 MHz
GFX: 8800 GTX
Sound: Working using Audigy

#335
xaiev

xaiev

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:Paris, France
Hi there, i'm glad there are finaly drivers for SB cards :)

Got one question, is it possible to change the cutoff frequency (routing low frequencies to bass speaker only & mid-high to mediums) ?

Cheers

#336
MTZeon

MTZeon

    InsanelyMac Protégé

  • Members
  • PipPip
  • 60 posts
  • Gender:Male
  • Location:Portugal
Although the excess treble is fixed on 1.2b0, i too have the random kernel panics. I use S1 on ACPI for the record.

#337
SenVa

SenVa

    InsanelyMac Protg

  • Members
  • PipPipPipPipPip
  • 311 posts
  • Gender:Male
  • Location:Michigan
  • Interests:OSx86.....that was a hard one.....
i don't think i did the hallab stuff right... but here are the files i made on a soundblaster live 5.1

Attached Files



#338
Shad0wcat

Shad0wcat

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
I'm getting random kernel panics with the new driver as well. SB Live Value. Kalyway 10.5.2

#339
MTZeon

MTZeon

    InsanelyMac Protégé

  • Members
  • PipPip
  • 60 posts
  • Gender:Male
  • Location:Portugal
Will test as soon as I can.

#340
tungmeister

tungmeister

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
will test when i next bother 2 reboot





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy