Jump to content

theStevo 4.5 Patch Released


  • Please log in to reply
88 replies to this topic

#61
mark_in_2k

mark_in_2k

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts

The »10.5.3 Combo Update by Mysticus« works perfect. My system starts fast and there are no more problems with my GeForce 7600 GT (there is a new NVInject inside the package). :)

Yup, I updated safely using the same method.

Are you using ViaRhine for your network card? How is it holding up? I was still getting disconnects when using heavy internet traffic with the built in Via Rhine on the VSTA-DUAL, which is why I went with a USB-ethernet adapter which is working great.

#62
thiathias

thiathias

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 264 posts
hmmm
it would be great if you could tell me which options did you select during the installation of the combo update by mysticus

#63
mark_in_2k

mark_in_2k

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts

hmmm
it would be great if you could tell me which options did you select during the installation of the combo update by mysticus

I followed the thread to the letter and stuck with 9.2 sleep kernel, as I know that works great.

Only thing you will have to do is copy back the ViaRhine kext, and choose your relevant video card.

#64
thiathias

thiathias

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 264 posts
what is the model of your usb-ethernet adapter mark_in_2k?

#65
mark_in_2k

mark_in_2k

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts

what is the model of your usb-ethernet adapter mark_in_2k?

I got a good deal on an official Apple USB Ethernet adapter which is supposed to be for the Mac Book Air, but works without installing any kexts on my system.

There are a few more out there. Take a look at this site which tells you how to get an adapter working. It's really easy.

#66
thiathias

thiathias

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 264 posts
thanks
I have seen this site already, but it says that products can change of chipset with the same name too.
and as the asrock mobos seem to be a bit special, i wanted to be sure before to spend 30€ (yes it's a bad deal but apple think that 1$=1€).
and i prefer spend 30€ than 10 hours trying to get my internet working ^

#67
heng2006

heng2006

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts
To theStevo,

Do you plan to create the patch for JaS.OSx86.10.5.4.Client.Server.Intel.SSE2.SSE3?

OR you could tell me to select options of this version (JaS.OSx86.10.5.4.) for 4DualVSTA mainboard.

Thank you for your hard works.
heng2006

#68
thestevo

thestevo

    InsanelyMac Chuck Norris

  • Members
  • PipPipPipPipPipPipPip
  • 550 posts
  • Gender:Male
  • Interests:A piano that's in tune and hardware that I don't have to write drivers for.
Well, I don't know yet. I've talked to JaS and he says that it will be included in the first PPF. However, I was told that all installers that use Dense's slipstream would contain it now since I gave the kext to him and they do not. I think I'll let JaS release his PPF and if it isn't there I might do something. Let me know if enough of you are stuck.

I have largely moved beyond this board, and I recommend that some of you look to move to something in an Intel chipset too. Snow Leopard requires 64bit drivers. AppleVIAATA is not 64bit, but we do have the source. I likely don't have the skills necessary to modify the source for 64bit, and thus this board will not run Snow Leopard or beyond. I'd love to see it be able to, it is capable (theoretically) but I don't think I'll be the one to bring that support.

theStevo

#69
Dariosen

Dariosen

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
  • Gender:Male
  • Location:Germany
Iam not very good in written english, so be pleased.

I think i solved the dropping ethernet problem.

I did not know how to change these settings in osx in terminal so i used the Programm MacPilot.
You install it and choose Network - Advanced.
Use the Network Preset (download+browse)


It changes the following options:

  • net.inet.tcp.delayed_ack Value=0 Delay ACK to try and piggyback it onto a data packet. 0=disabled; 1=enabled; 2=more compatible (TH_PUSH); 3=streaming detection;
  • net.inet.tcp.recvspace Value=3072 Maximum TCP receive window
  • net.inet.tcp.sendspace Value=2048 Maximum TCP send window

Then apply settings.


WITH THESE SETTINGS IAM UPLOADING WITH 120kb/s
AND DOWNLOADING WITH 1MB/S SINCE 24HOURS.

I will report if the connection droppes again. (Hopefully not)


Last but not least, thanks theStevo! u did great work!

#70
thestevo

thestevo

    InsanelyMac Chuck Norris

  • Members
  • PipPipPipPipPipPipPip
  • 550 posts
  • Gender:Male
  • Interests:A piano that's in tune and hardware that I don't have to write drivers for.
Acknowledged. Thank you. I can't confirm yet, I don't have an install on the ASRock board right now. Anybody else, feel free to confirm.

#71
Dariosen

Dariosen

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
  • Gender:Male
  • Location:Germany
I still don´t have any problems. My connection never dropped after this modification.

Is there someone who knows another way to change these values?
This would be very interesting for me.

Thanks,
Dario

#72
inspiron2

inspiron2

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
theStevo, Thanks very much for all your work!

I applied your patch to 10.5.2, and verified MD5.

My system is 775Dual-VISTA, 5600+, all IDE, 2GB RAM.

Everything works except ethernet. Got no network. Error message: cable unplugged. Any idea?

BTW, during install, I only selected your package, video driver and EFI (GUID). Did NOT select Vanilla kernel.

Thanks again.

#73
thiathias

thiathias

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 264 posts
i don't have the time to test the solution with macpilot, but as far as i know, these are the command you have to type in terminal to do the same thing as macpilot does :
sudo sysctl -w net.inet.tcp.delayed_ack=0
sudo sysctl -w net.inet.tcp.recvspace=3072
sudo sysctl -w net.inet.tcp.sendspace=2048

BUT plz, anyone can confirm it? because i found this info on unknown site, and i haven't tested it yet. (i have DD problem)

#74
chupaco

chupaco

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Hi Stevo, wonderful job with this comunity, in the majority, noobs, by the way... :)

I need help installign the kalyway, I hope thiis is the right thread, if is not, please feel free to guide me.

I have a Arsrock mobo, I goes to the F8 screen selectionn then BAM!.... REBOOTS AUTOMATICALLY, I have tried modes -v -x -s and -F. in -x mode, it went a long time loading drivers, then REBOOTS.

help needed please


James

by the way, I have downloaded this file "
ADD_KEXT_TO_DVD
Kalyway DVD ReadMe.rtf
Kalyway_10.5.2_DVD_Intel_Amd.iso"


#75
thiathias

thiathias

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 264 posts
i'm back with my 10.5.2 install, i wrote the command line in terminal, and i have no drop at the moment.

#76
thiathias

thiathias

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 264 posts
it droped one time, i reinstalled viarhine.kext, i will redo the commands in terminal, but i think that we have to type these commands at each reboot, which is quite bad...
maybe we can do a script

#77
thiathias

thiathias

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 264 posts
your fix doesn't work for me via the commands in terminal, my connection dropped.
I will se if it drops too with macpilot
what is your version? 10.5.2 or later?
and do you have 4coredual-vsta or 4coredual-sata?

#78
thiathias

thiathias

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 264 posts
it dropped too with macpilot
what is your config plz?

#79
thiathias

thiathias

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 264 posts
ok nevermind i buyed an apple usb ethernet adaptater for macbookair

#80
idjego

idjego

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
Good, I try download TheStevo 4.5 and I can not download bittorent that there are no seeds.
Someone can go up to rapidshare or Megaupload? Thank you.

I also wanted to comment on my situation with my machine ....
I have a motherboard 4coredual VSTA, a graphics card with Nvidia 8500GT, 2 SATA 160 gb.
When I install Kalyway 10.5.1 with TheStevo 4.0 takes a long time to ignite, about 3 minutes, and I can not configure the target graphic

With this patch resolved my problems?

I think one of the problems is the SATA, and I will try to put an IDE hard drive, to see if something improves.

Thanks for your help.
P.D. VSTA works with some other distribution? Should, Toth ..





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy