Jump to content

Marvell Yukon 88E8056 (10.8 - 10.8.5) 3.0 (12F45)

File Information

  • Rate File: * * * * * 2 Votes
  • Submitted: Mar 29 2013 01:04 PM
  • Last Updated: Oct 06 2013 12:56 AM
  • File Size: 1MB
  • Views: 17659
  • Downloads: 3,826

Previous Versions

  • 23 Sep 2013 Download Marvell Yukon 88E8056 (10.8 - 10.8.5) 3.0 (12F37)
  • 30 Apr 2013 Download Marvell Yukon 88E8056 (10.8 - 10.8.4) 3.0 (12E40)

Download Marvell Yukon 88E8056 (10.8 - 10.8.5) 3.0 (12F45)



Screenshots
Ethernet Marvell 88E8056 Yukon2 LAN

Modified Yukon2.kext Plug-In for Marvell Yukon 88E8056 PCI-E Gigabit Ethernet Controller.

Replace the IONetworkingFamily.kext into /System/Library/Extensions

What's New in Version 3.0 (12F45) (See full changelog)

  • Update from 12F37 to 12F45
  • Update from 12E40 to 12F37
  • Update from 12E36 to 12E40
  • Update from 12D78 to 12E36




Isn't a sumple dummy (injector) kext enough for this? I use one on my Marvell 88E8056 and i find it a cleaner solution... Or does this do something else?

work this in Marvell Yukon 88E805? This is inside in Samsung laptop NP-R780H a Ethernet-Lan.

I hav not found a kext or a  patched IOnetworkingFamily.kext for this. Work to time only with WiFi.

 

Thank you for tips.

Sorry... no idea

Already try this? (PCI\VEN_11AB&DEV_4381)

<key>Yukon-88E8059</key>
<dict><key>CFBundleIdentifier</key>
<string>com.apple.iokit.AppleYukon2</string>
<key>EnableLowPwr</key>
<integer>1</integer>
<key>IOClass</key>
<string>yukon2osx</string>
<key>IOPCIPrimaryMatch</key>
<string>0x438111ab</string>
<key>IOProviderClass</key>
<string>IOPCIDevice</string>
<key>MACNumber</key>
<integer>1</integer>
<key>Model</key>
<string>Yukon Gigabit Adapter 88E8059 Singleport Copper SA</string>
<key>NetworkNumber</key>
<integer>1</integer>
<key>RxDeadman</key>
<integer>60</integer>
<key>RxRingGrowOnPause</key>
<integer>10</integer>
<key>RxRingSize</key>
<integer>0</integer>
<key>RxRingSize_100MBit</key>
<integer>128</integer>
<key>RxRingSize_10MBit</key>
<integer>64</integer>
<key>RxRingSize_GigaBit</key>
<integer>256</integer>
<key>TxRingSize</key>
<integer>256</integer>
<key>Vendor</key>
<string>Marvell</string>
</dict>

ErmaC

First of all, since I signed up to speak here, let me say thanks to ErmaC and all the others who make my hack possible.

 

With that said, I have tossed my old AppleYukon2.kext out (macos10.8.5) but it still will not work with your version 3 I just downloaded.  The errors are exactly the same as the previous kext I was using (which is the old one from way back).

 

Either way I would love to help you troubleshoot and/or told what I am doing wrong.

 

My board is P6x58d-e

8056 Marvell Yukon.  Worked with ancient kext up to 10.8.4.

I tried your kext. I want to share with you the strange behavior as far as internet connection is concerned. Prior to this kext, I am using USB N-adapter from Rosewill (RNX-180UBS). Luckily, they have updated software for ML. I continue to use it after I updated from OSX Lion to ML. After I installed your Marvell Yukon 88E8056 kext, restart and then plug in Ethernet cable. It did not work. Then I tried plugging in Ethernet cable first and restarted and it worked as far as connection is concerned. When I viewed through network connection panel, the Ethernet connection is connected through USB wireless adapter. It is a LAN Ethernet connection because this time I can sign into Apple app store finally after 2 long years.   

Update on my situation:

 

My problem seems to not be kext related but related to the npci=0x2000 and npci=0x3000 flags.  On 10.8.5 it seems these need to be removed from either clover or chameleon boot.plist files for networking to function (I think most systems just have audio issues with those flags, I have audio issues but also networking doesn't work using them in my case).

 

Phil511, if you delete and then re-add your network interfaces in the System Preferences you can get the Ethernet to match up with its symbol and the connection you have.  If you ever have trouble with App Store, iMessage, etc. then delete /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist and reboot.  This will cause it to work with App Store, etc. again (though you may need to remove and re-add in system preferences to get them to all match up properly).

 

Hope it helps!

 

Ray

Hi Ray,

 

Thank you Ray. Your advice worked for both ML & Mavericks. 

 

@ErmaC,

 

Thanks for the Marvell 88E8056 kext that really works. 

Thank you, it works on Mavericks on Asus P5K-VM

Thanks for the kext Marvell Yukon 88E8056 (10.8 - 10.8.5) 3.0 (12F37) working on Mavericks on Asus Rampage Formula.

Hello guys!Thanks for the kext,but i have a problem ,if you can help i'll be grateful.I have OS X Mavericks installed with myhack..installation worked fine no problems,etc...it is mostly vanilla.the only thing bothering me is that i can't get ethernet to work.After installing this kext,i can only boot if i set the bios to disable ethernet,otherwise i get a kernel panic.I have tried booting with the 0x3000 option but that does t work either.My motherboard is asus p5e3.Luckily,i was able to install the standard ionetworking back.The weird thing is that :the first time i installed mavericks,the kext worked without problems but after a reboot it didn t work.I thought it isn t supported by mavericks so i went back to mountain lion but i found out that the kext the kext i used does t work anymore....Please,can you help me?


  • 258 Total Files
  • 13 Total Categories
  • 119 Total Authors
  • 578,447 Total Downloads
  • QE_CI Exotic Patch Latest File
  • fantomas1 Latest Submitter
© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy